IRC channel logs

2020-07-12.log

back to list of logs

<alextee[m]>Sweet
<justin_smith>I have a hunch that the problem with JIT is the same as with build systems, versioned deps, and threading, but amplified. People who don't understand it intimately consider it a solved problem and are confused that the options all exist. People who know it well enough to improve it are disappointed by mainstream designs that should be able to do some priority feature.
<justin_smith>without massive institutional backing the likely outcome is large numbers of 40% solutions that mostly work on some happy pass
<justin_smith>s/happy path/happy pass/
<justin_smith>OK that substitution was reversed :/
<justin_smith>either it's a hard enough problem that there's no good solution, or it's hard enough that qualified and competent people can't recognize a bad solution
***catonano_ is now known as catonano
<spk121>.
<dftxbs3e>justin_smith, I am well aware that technical problems need many different experiments before settling onto a solution everyone can approve. But before going into making a whole JIT library, I am confident there has to be a common ground already that solves the portability problem. Such as maybe a portable macro assembler that can make use of CPU features as it detects them. When the portability problem is out of question, it's less of a problem
<dftxbs3e>to make many JIT implementations.
<RhodiumToad>(use-modules (xkcd now-there-are-N+1-conflicting-standards))
<daviid>spk121: hello! everything is alright?
<spk121>daviid: oh hey. been a strange few months. But that's probably true for everyone, I guess.
<daviid>spk121: yes, definitely - very strange times that is ...
<tohoyn>sneek, botsnack
<sneek>:)
<ArneBab>RhodiumToad: do we have that?
<chrislck>I think RhodiumToad was jesting like python's >>>import antigravity
<ArneBab>if xkcd were by-sa instead of by-nc, I’d totally go for such a module :-)
*RhodiumToad checks whether he is connected now
<RhodiumToad>it was mostly a comment on the proliferation of JITs conversation
<RhodiumToad> https://xkcd.com/927/
<ArneBab>I know the strip, I just thought we might have that, because that would be totally cool :-)
<ArneBab>maybe even with keyword search wired into auto-complete? (I don’t know how we could do that)
<alextee[m]>can we please install this binary in future releases of guile? libguile/guile-snarf-docs
<alextee[m]>i currently have to use it directly from the source code of guile after building it
<dsmith>Hey hey
<sneek>dsmith, you have 1 message!
<sneek>dsmith, R1ck77 says: thank you for the info: chibi does look promising (not giving up on Guile yet, though)!
<dsmith>So, just catching up on the logs.
<dsmith>About the proliferation of JITs
<dsmith>And the lack of ppc64 in Guile
<dsmith>My understanding: The Lightning interface was not a good fit for Guile.
<dsmith>Lightnening is Lightning with an api more suited to Guiles needs.
<dsmith>ppc64 *is* in Lightning.
<dsmith>So all that needs to be done is simply provide the same lightning->lightEning trasformation for ppc as was done for arm and intel.
<dsmith>Heh
<dsmith>For example, that nasty segfault bug on arm also exists in Lightning. The lowest level code is very similar if not identical.
<dsmith>Just need someone with PPC64 system and deep understanding of PPC to work on it.
<dsmith>Ppc is rare these days. Arm seems to have taken over.
<dsmith>Motorola/Freescale/NXP seems to have moved to arm too.
<mwette>One explanation for the man JITs: The same as there are many computer languates, C compilers, databases, text processors, operating systems, etc. The one real resource that is requried to start a new JIT is time and an interest to do so. And there is always someone who has different view of what the best design is.
<mwette>My WD network drive is linux/ppc, but it's several years old. Do the new ones use ARM?
<mwette>I see lightning has RISC-V but not lightening.
<dsmith>risc-v might have been added after Andy did the "fork".
<lle-bout>dsmith, I can donate access to a PPC64 VM
<lle-bout>I have a big machine at home
<lle-bout>if you have IPv6 networking, then I can give you access.
<lle-bout>dsmith, PPC64 has a modern and performant FSF RYF certified system: https://www.fsf.org/news/talos-ii-mainboard-and-talos-ii-lite-mainboard-now-fsf-certified-to-respect-your-freedom
<lle-bout>That's why it's so interesting
<lle-bout>All the firmware is FOSS
<dsmith>lle-bout: Thanks, but I'm not the ppc expert. I've used it on various embedded boxes, but only from C.
<lle-bout>The bootloader and all is FOSS, everything is FOSS, it doesnt need proprietary software at ALL.
<lle-bout>and it's on par with some Intel Xeon (minus software optimizations)
<lle-bout>IBM published all the code under FOSS licenses with it's latest chip POWER9 and made the PowerISA 3.x royalty-free just like RISC-V
<lle-bout>but PowerPC has decades of history and software support compared to RISC-V
<lle-bout>So it's more interesting
<lle-bout>You can get a ready to use desktop system here: https://raptorcs.com/content/BK1SD1/intro.html
<lle-bout>also, community of RaptorCS customers and beyond: #talos-workstation
<dsmith>lle-bout: Is it an rs-6000 ?
<lle-bout>dsmith, that's old and slow, it's custom built by RaptorCS and based on this chip: https://en.wikipedia.org/wiki/POWER9
<lle-bout>POWER9 chip was released in 2017
<lle-bout>by IBM
<dsmith>Ewww. Broadcom NIC
<dsmith>Broadcom is just about the wost to get device info from.
<dsmith>But there are probably already working drivers, right?
<lle-bout>dsmith, wrong; I can attest it works very well and it has a FOSS firmware implementation as well! https://github.com/meklort/bcm5719-fw
<lle-bout>the driver is in the Linux tree
<dsmith>Good
***dftxbs3e_ is now known as dftxbs3e
<alextee[m]>are there guile bindings for the glib test system?