IRC channel logs

2020-06-29.log

back to list of logs

<rlb>I might be handling this wrong, but I tried using a (pipe) with (with-error-to-port ... (open-pipe* ...)), and attempts to read from the err pipe (from a separate thread using get-bytevector-all block forever), even after a close-pipe on the subprocess.
<rlb>The command itself doesn't need stdin, so it should finish "immediately" anyway. It seems like maybe the err-pipe isn't actually being closed by the subprocess (assuming it's even connected as I intended).
<rlb>e.g. this hangs on (touch err): https://paste.debian.net/hidden/9265e30e/
***jonsger1 is now known as jonsger
***jonsger1 is now known as jonsger
***apteryx is now known as Guest39931
***apteryx_ is now known as apteryx
***rgherdt_ is now known as rgherdt
<SpaceIgor2075>Hello, I'm a newbie. Can I use Guile as a standalone interpreter for learning Scheme?
<chrislck>SpaceIgor2075: of course
<lloda>what would be needed to have filesystem completion in (load "...") or (load-from-path "...")
<lloda>wonder if anyone has given this a thought
<chrislck>Dear all: we know scheme doesn't quite error out if a var is undefined. (define (my-func) (if #t 'answer never-used)) will never error out.
<chrislck>Is it possible to do some static analysis before run-time to detect these 'never-used' objects?
<chrislck>^ ahh these are 'possibly unbound variable' warnings
<chrislck>^^ does anyone know how to highlight/detect these unbound vars? What IDE is best?
<chrislck>On a whim I tried slib. sudo apt install slib --> installs version 3b1-5. "SLIB does not support Guile-2.2 yet. Ignoring." O_o.
<chrislck>why not remove SLIB from manual?
<dsmith>This has happened before. Guile chanages, slib is broken for a while, evenutally slib syncs.