IRC channel logs

2020-06-15.log

back to list of logs

***catonano_ is now known as catonano
<daviid>here is a code snipset, for so those interested may help me to find why on earth :), which
<daviid>oh, hit enter before text completion :)
<daviid>.. interested may help me to debug among the weirdest bug ever - https://paste.debian.net/1152105/
<daviid>a cpmplete description of what it's supposed to do and how to reproduce i the paste, between the ;;; Commentary: ... ;;; Code: lines
<daviid>I guess it's because it is map, used 'everywhere', and that won't work unless map is bound to a generic before anything using is compiled after it is turned into a generic - just like guile-gnome, g-golf rebinds connect (core guile implementation of the connect(2) posix call) into a generic, but unlike map, it is probably not used any where (in guile itself), and so it is fine ...
<daviid>I think I am going to 'bypass' map as a short method for the time being, probably a few others to, like find ... maybe 'bypass' any core guile proc for the time being, then see how things go ...
***wxie1 is now known as wxie
***wxie1 is now known as wxie
<jackhill>daviid: I'm curious, what needs to be done for guile-3.0 support in g-golf?
***wxie1 is now known as wxie
<daviid>jackhill: actually I don't know, yet :) -
***nikita_ is now known as nikita`
<wingo>moin
<civodul>hi wingo!
<wingo>heya :)
<wingo>have a good weekend?
<civodul>yup, partly sunny, not too bad :-)
<civodul>& you?
<wingo>good good!
<civodul>do you think everything is in place for 3.0.3, with the ARM fix now merged?
<civodul>i should be able to take care of it this week
<wingo>civodul: yeah lgtm
<civodul>awesome
<civodul>what are your thoughts regarding the string-for-each discussion?
<wingo>civodul: string-for-each should be in scheme :) i just wanted to push back on the idea that entering/leaving vm and/or jit was related to after-gc-thunk
<civodul>ah ok
<civodul>when you have time, i'd be curious to learn what you think is happening here
<civodul>i just naively looked at the profile without digging much
<wingo>well gc happens, i dunno, max 100 times a second
<wingo>whereas the test case you were looking at is 3 or 4 magnitudes more, at least
<civodul>right
<wingo>i don't know what the gc issue is. looking at comparative benchmark results, there are no significant regressions afaiu: https://wingolog.org/pub/guile-3.0.3-vs-guile-3.0.2-microbenchmarks.png
<wingo>so, it is something to understand, but not a release blocker afaiu
<civodul>ah no, there's no regression
<civodul>yes, agreed
<civodul>it's just "weird", and we didn't see it in 2.2 i think
<civodul>but definitely not a blocker
<civodul>GC hook aside, the string-for-each case shows suprisingly high (to me) overhead
<wingo>the string-for-each case is essentially measuring overhead afaiu
<wingo>is that how you read it too?
<wingo>i.e. there's no workload
<civodul>wingo: yes, but i expected string_for_each and vm_engine to be higher
<civodul>i also expected a less significant difference compared with pure Scheme
<civodul>but like you say, it should be in Scheme, so maybe it's not worth discussing
***dsmith-w` is now known as dsmith-work
<dsmith-work>UGT Greetings, Guilers
<dsmith-work>NEWS updated!
***guix-vits is now known as bionicbeaver
***sputny1 is now known as sputny
<janneke>wooot, göran mailed me about their xz decompression in scheme
<janneke>i will want to look into that, not sure though what to do with the syntax-case bootstrap thingy...
<janneke>taking it in might harden the requirement on guile/syntax-case, not sure if that's smart
<janneke>otoh it might help getting people on board trying to "crack that nut"
<civodul>janneke: neat
<civodul>weinholt might be around :-)
<janneke>civodul: oh...oops -- ah well, great! :-)
<janneke>i really love how people reach out and help, it's amazing!
<civodul>yup!
<manumanumanu>is there any way to expand macros? Say that I have a procedural macro and want to expand the body of the macro? I could probably hack it together using syntax-local-binding, but hopefully there might be some nicer way...
<manumanumanu>to expand on that: I want to programmatically expand macros, not at the repl.
<tinga>Hi. How do I do benchmarking of my code? Something like `time` in other Scheme implementations.
<civodul>hi tinga!
<civodul>there's (ice-9 time), which provides a 'time' procedure
<civodul>or simply ",t" at the REPL
<tinga>Is there a single stepper in Guile 3?
<tinga>Something like this was for 1.x: https://www.gnu.org/software/guile/docs/docs-1.8/guile-ref/Single-Stepping-through-a-Procedure_0027s-Code.html
<dsmith-work>tinga: A few weeks ago I was having some problems in emacs. Found a stepper thingy. Was *awesome*. Sure wish something like that was in Guile.
<dsmith-work>May have been edebug
<justin_smith>with 2.x you can examine data and step from the debug prompt
<justin_smith>that alone won't do the nice editor source following that emacs edebug does of course
<justin_smith>but surely the guile debugger has enough data to make that work if someone writes the editor code?
<tinga>justin_smith, how do you step? Can't see it mentioned don https://www.gnu.org/software/guile/manual/html_node/Interactive-Debugging.html
<justin_smith>tinga: very strange that those commands are not included in the doc
<tinga>Ah, ",help debug" shows it
<justin_smith>yeah - I was working with some hairy goops multi-dispatch code where I pretty much needed a stepper to even know where things where blowing up thanks to generic dispatch
<justin_smith>between break / step / resume and inspection of the stack and registers, all that's missing is nice editor integration to jump to the code and highlight the active form
<justin_smith>oh and watches (I think that's what tracepoint does but I haven't messed with it)(