IRC channel logs

2020-06-12.log

back to list of logs

<anadon>It looks like the page in the manual dedicated to adding readline support is no longer complete. When Following them in 3.0.2 it can't find the `ice-9 readline` module. guile-readline and guile are both installed via guix.
<RhodiumToad>worked for me?
<RhodiumToad>(not using guix, though)
<tohoyn>sneek, botsnack
<sneek>:)
<tohoyn>FYI: a new version Theme-D-Golf 0.8.2 has been released. The new version includes support for overridden functions in G-Golf.
<tohoyn>see http://www.tohoyn.fi/theme-d-golf/index.html
<RhodiumToad>random thought, has anyone considered whether it's possible to implement proper ephemerons, rather than just key-weak weak hashes?
<wingo>dsmith-work: yeah i don't know! the way i would debug is set GUILE_JIT_THRESHOLD=0 and GUILE_JIT_STOP_AFTER=n
<wingo>and bisect over n until you find the function whose compilation is causing the problem
<wingo>RhodiumToad: i thought about it but could not find a good way to do it. here are some of my confused thoughts about the problem: https://bdwgc.opendylan.narkive.com/BtFAqAtN/gc-weak-maps-and-libgc#post2
<wingo>if we ever replace the gc, native support for ephemeron tables would be a thing to add
<wingo>maybe it is best not to link to my confused thoughts, i have a history of doing badly in this area
*civodul attempts to update gdb to Guile 2.2/3.0
*guix-vits -- "i love 'bastards' like this: (system "cat ~/test/r.json") -> string; i promise to read the manual someday."
*guix-vits * -> 0 *
*guix-vits "my precious: (get-output-string) & Co."
*guix-vits "ok, man will be faster than those unrelated commands. So: File Ports.."
<guix-vits>(get-string-all p) -> $69 = "* {\n ... Want to get the result from 69-th attempt? Avoid reading the manual beforehand :]
<civodul>heh
<civodul>updating those gdb bindings is my "bonne action" of the day, as we say here
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>wingo: Thanks. I'll try the GUILE_JIT_STOP_AFTER=n. Gonna be hard though, as it doesn't fail every time.
<wingo>probably depends on veneers somehow then
<dadinn>hi all
<dadinn>I am trying to use define-syntax rules, I have the following code: (define-syntax-rule (print-to-file path . body) (with-output-to-file path (lambda () (print-headers) body ... (print-footers))))
<dadinn>I am not sure how to do the splicing part with the body argument to the macro
<dadinn>I kinda now that syntax-rules use the ... to do the splicing, but not sure how define-syntax-rules form works :/
<chrislck>dadinn: start with (define-syntax-rule (print-to-file path body ...) ...) and it'll be fine
<dadinn>chrislck: what would be the right expression if i wasn't using ... at all?
<dadinn>chrislck: I wouldn't expect splicing syntax-unquote to work :P
<dsmith-work>civodul: You are working on getting gdb up to date?
<civodul>dsmith-work: yup, i submitted patches
<wingo>i merged lightening btw
<civodul>and i discovered a patch had been posted in 2018 and fell through the cracks
<civodul>wingo: awesome, thanks!
<civodul>does that mean we're all set for a release?
<dsmith-work>While you are at it: libguile/lightening/lightening/lightening.c
<dsmith-work>-#if JIT_NEEDS_LITERAL_POOL
<dsmith-work>+#ifdef JIT_NEEDS_LITERAL_POOL
<dsmith-work>Just to be consistent
***sneek_ is now known as sneek
<zig>hello!
<zig>I managed to port my triple store, dubbed nomunofu, to guile 3.0.2
<zig>but the search engine, dubbed babelia, is not working at all.
<zig>it is complaining about a continuation barrier.
<zig>The thing is that it was working with early guile 3.0.0
<zig>Oh I see, several fixes in things related to the issue I see https://lists.gnu.org/archive/html/guile-devel/2020-03/msg00046.html
<zig>I will try guile-3.0.0 and see if it still works.
***janneke_ is now known as janneke`
<civodul>wingo: scm_call_n is expensive when JIT is enabled: https://lists.gnu.org/archive/html/guile-user/2020-06/msg00038.html
***roptat_ is now known as roptat
<anadon>I still need help getting the guile repl to use readline. Haven't figured this one out.
<justin_smith>anadon: what did you try?
<dsmith-work>anadon: My guess is you didn't have the readline-dev package installed at configure time
<justin_smith>n/m I found the scrollback
<dsmith-work>As line libreadline-dev
<anadon>dsmith-work: guile got installed as a package.
<dsmith-work>Ah
<anadon>justin_smith: What was in the manual, the two lines for ~/.guile got added. I also installed `guile-readline`.
<guix-vits>anadon: (W.A.) geiser in emacs?
***janneke` is now known as janneke
<anadon>sneek: tell later guix-vits What do you mean? ()
<sneek>later, anadon says: guix-vits What do you mean? ()
<anadon>sneek later tell guix-vits What do you mean? (re: (W.A.) geiser in emacs?)
<sneek>Okay.
<dsmith-work>anadon: Probable meant use emacs+geiser instead of readline.
<anadon>I'll look into it. Still, I'd like to understand why the approach in the manual didn't work.
<dsmith-work>anadon: Do you have strace? You could run guile under "strace -efile" and get a better idea of where guile is looking for readline, and why it's not finding it.
<anadon>I keep forgetting it exists.