IRC channel logs

2020-06-11.log

back to list of logs

<ArneBab>manumanumanu: the racket-version is https://paste.debian.net/1151325/ — in both versions a comment at the top says how to call it.
<ArneBab>manumanumanu: keep in mind that the algorithm itself must stay the same because of benchmarkgame rules
***catonano_ is now known as catonano
<daviid>sneek: seen wedesoft
<sneek>I last saw wedesoft in (here?) 4 months ago, saying: Waiting for the Guile FOSDEM 2017 videos to switch to "done" https://review.video.fosdem.org/overview http://video.fosdem.org/2017/K.4.601/.
<daviid>dsmith-work: do we have a bot goops tutorial pointer?
<elliotpotts>hi folks
<lfam>Howdy
<guix-vits>Cool, in /query sneek one can say things without prefixing them with 'snеek:'
<guix-vits>snеek: botsnack
<guix-vits>sneek: seen sneеk
<sneek>Sewni was last seen in (here?) 9 months ago, saying: I didnt realise you were using the bot :P.
<guix-vits>Cyrillic 'e' rules (^^)
*guix-vits Actually not so: "*** snееk is an erroneous nickname"
<marusich>Where can I find a good explanation of how to understand the use of ellipsis (...) in match clauses?
<marusich>I get the idea well enough when I see one being used, but I'm looking at code that uses 3 of them at the same time, and I'm confused: http://git.savannah.gnu.org/cgit/guix.git/tree/guix/build/utils.scm?id=88f85494491a0cd4d4262c97860f01e99c2bc313#n793
<marusich>Like, what the heck is (... ...) ?
<elliotpotts>I have a notice about the definition of the `SCM_UNPACK(x)` macro: in c++20, `volatile` on the left hand side of an assignment is deprecated
<elliotpotts>so this thing will "soon" be invalid c++: `#define SCM_UNPACK(x) ((scm_t_bits) (0? (*(volatile SCM *)0=(x)): x))`
<elliotpotts>should this be reported as a bug or something?
<RhodiumToad>what on earth is that trying to do?
<RhodiumToad>seems to be trying to induce a segfault?
<RhodiumToad>but 0 is false in any event so...
<elliotpotts>it's forcing the `*(volatile SCM *)` to be compiled though never evaluated... in order to typecheck x, I think...
<RhodiumToad>oic
<elliotpotts>there's a comment:
<elliotpotts> The 0?: constructions makes sure that the code is never executed, and that there is no performance hit. However, the alternative is compiled, and does generate a warning when used with the wrong pointer type. We use a volatile pointer type to avoid warnings from clang.
<elliotpotts>I guess there could be a check for c++20 and replace it with decltype and static_assert
<janneke>marusich: i guess that's what syntax-case does for you :-/
<janneke>marusich: try something like:
<janneke>./pre-inst-env guile
<janneke>(use-modules (ice-9 match) (guix build utils))
<janneke>,expand (substitute* '("foo" "bar") (("baz") "bla"))
<janneke>IWBN if there was a way not to expand the "match" macro...hmm
<janneke>marusich: if you e.g., capaitalize 'match and quote its clauses: https://paste.debian.net/1151533/
<janneke>then ,expand => (MATCH '("foo" "bar")
<janneke> '((files ...)
<janneke> (for-each substitute-one-file files))
<janneke> '((? string? f) (substitute-one-file f)))
<RhodiumToad>but aren't we already inside a syntax-rules here?
<RhodiumToad>ahh
<RhodiumToad>(... ...) seems to expand to just ... ?
*RhodiumToad is not finding this documented
<janneke>ah yes, where i said syntax-case, make that syntax-rules, stop the clock
<RhodiumToad>so I'm seeing by experiment that (... ...) inside a syntax-rules is a "quoted" ... identifier
<RhodiumToad>but nothing in the docs actually says this
<RhodiumToad>aha. that part is defined in r6rs, but not mentioned in the guile docs
<dsmith-work>daviid: Doesn't look like it (goops tutorial link). Do you know of one?
<daviid>dsmith-work: this one https://www.wedesoft.de/software/2014/03/02/oop-with-goops/
<dsmith-work>sneek: goops-tutorial is https://www.wedesoft.de/software/2014/03/02/oop-with-goops/
<sneek>Understood.
<dsmith-work>sneek: goops-tutorial ?
<sneek>Its been said that goops-tutorial is https://www.wedesoft.de/software/2014/03/02/oop-with-goops/
<daviid>dsmith-work: great, tx
<guix-vits>(?) Do someone willing to share an Guile example? https://webkitgtk.org/reference/webkit2gtk/unstable/WebKitUserContentFilterStore.html#webkit-user-content-filter-store-save-from-file
<guix-vits>i can't defeat 'callback.
<lloda>sneek: later tell elliotpotts check http://logs.guix.gnu.org/guile/2020-05-27.log
<sneek>Will do.
<lloda>sneek: later tell elliotpotts easiest solution is to compile your code with -DSCM_DEBUG_TYPING_STRICTNESS 2
<sneek>Okay.
<lloda>I already argued for that to be the default
<dsmith-work>lloda: Did you know that you can link to a specific line in the log? It's the nick of that line. For example: http://logs.guix.gnu.org/guile/2020-05-27.log#155008
<dsmith-work>A nice touch.
<dsmith-work>Thank You, logger implementer person.
<lloda>i didn't know dsmith-work thank you
<lloda>the logs are great really
<civodul>hello!
<civodul>wingo: would you be available to push 3.0.3 or would you like me to take care of it?
<dsmith-work>Morning Greetings, Guilers
<wingo>hi :)
<civodul>(not right now, sometime in the coming days)
<civodul>hey :-)
<wingo>civodul: humm, am a bit overloaded atm. if you have the cycles, plz do it :)
<wingo>need to merge the arm patch to lightening tho!!
<sneek>Yes please
<civodul>wingo: ah yes, that one
<civodul>wingo: did that the arm fix need more work or more testing?
<civodul>actually how do you handle merges of lightening in guile.git?
<dsmith-work>civodul: It definitely some real problems. Though I was seeing some errors, most probably unrelated.
<dsmith-work>s/some/fixed some/
<dsmith-work>s/was/was still/
<dsmith-work>civodul: There have been some update since I did any testing, and I haven't been able to get back to it.
<civodul>dsmith-work: alright, we'll synchronize when i get around to preparing the release, then
<wingo>civodul: lightening is merged via git merge -s subtree
<civodul>ok, i see
<dsmith-work>Oh!, but that PR hasn't been merged yet.
***rekado_ is now known as rekado
<rekado>the logging web interface is a ~500 line Guile script: https://git.savannah.gnu.org/cgit/guix/maintenance.git/tree/hydra/goggles.scm
<civodul>%after-gc-thunk shows high in profiles
<civodul>weird
<wingo>that does sound weird
<wingo>i wonder if it is fake somehow
<wingo>like if SIGPROF arrives during gc, will it necessarily be counted as after-gc-thunk?
<wingo>or is it real and either the thunk it being called too often somehow, or taking too long
<wingo>i don't recall seeing it at the top of profiles in the past
<civodul>yeah
<civodul>i've been thinking it might be fake
<civodul>but i don't see how it could
<civodul>after all, statprof is just sampling the stack
<dsmith-work>wingo: So I'm trying to remmember where I was at with jit on armv7. When the env var was set to always jit, it caused more problems.
<dsmith-work>wingo: Any thoughts on why? Stress on mem allocation? Overwriting some bounds?
<dsmith-work>wingo: Maybe overwriting a stack?
<dsmith-work>The backtraces from core dumps seem to indicate a corrupt stack.
<guix-vits>Hi daviid: Is GAsyncReadyCallback, and GCancellable are supported yet in g-golf?
<daviid>guix-vits: not yet, actually at this moment, any function that accepts callback(s) will accept #f (which 'is' NULL), but not yet a 'real' callback - I statd to think about it, had a few very long chat wth the GI folks, g-golf will get there, but don't hold your breath
<guix-vits>Thanks daviid, i'll try #f.
<daviid>guix-vits: for example this will work (example iitially proposed by str1ngs, I just reviewed it a little ...) - https://paste.gnome.org/paob2ihua
<daviid>guix-vits: are you using the very latest g-golf? a source clone, checkout the devel branch ... the guix package is 'late', I wouldn't use it till ther is a g-golf release
*guix-vits loading. . .
<daviid>guix-vits: in the paste you should remove line 47, a comment I made to myslf at the time, but that has been fixed, as line 48 shows ...
<guix-vits>daviid: + on Guix there is no /bin/bash by defauld (only /bin/sh, and those /run/current-system things). Cool.
***slyfox_ is now known as slyfox