IRC channel logs

2020-05-29.log

back to list of logs

<aleix>hi! for those of you who are not in the mailing list (an who use a mac), i just announced a new project this morning: this https://github.com/aconchillo/homebrew-guile . it's basically a way to install Guile libraries/apps easily on mac.
<jao>guilebrew
<jao>(would be a much better name, imho)
<aleix>always complaining :-D
<jao>i haven't touched a mac in a decade, i won't complain much more
<aleix>i followed the recommendation from homebrew, so it works with their commands
<jao>so their recommendation is to call it "guile homebrew tap"? i'm liking apt more and more :)
<jao>okay, i'll stop trolling now. congrats, regardless of names!
<aleix>they recommendation is to use homebrew-something, so "brew tap" works. they find it in githug, etc.
<aleix>*their
<jao>and why not brew guile?
<aleix>a new command?
<jao>i thought brew tap was a command. sorry, i don't know much about brew.
<aleix>easier to just do "brew install chickadee" than learn a new command
<aleix>ah, yes "brew tap" is a command to add a new tap
<aleix>so you do "brew tap aconchillo/guile" and they now it's on github and it's called "homebrew-guile"
<jao>okay, i see. homebrew-guile then. makes sense.
<aleix>after that, you can just do "brew install guile-git"
<jao>nice
***sneek_ is now known as sneek
***sneek_ is now known as sneek
<daviid>str1ngs: I pushes a series of patches to g-golf, which shouldn't affect your code, but still, when you have some free time, please pull, make, check and lt me know if everything is alright ... tx
<daviid>sneek: later tell tohoyn I pushes a series of patches to g-golf, which shouldn't affect your code, but still, when you have some free time, please pull, make, check and lt me know if everything is alright ... tx
<sneek>Will do.
***jao is now known as Guest52152
<daviid>*pushed
<str1ngs> daviid will do thanks
<p0a>Hello
<p0a>I read a bit about guile
<p0a>It looks a bit like lua to me. (I haven't used either)
<p0a>So if guile is the glue between a complex program and the user, where is it used? what are some typical scenaria?
<p0a>Would guile be used to write an emacs mode?
<p0a>sorry for such an ignorant question
<tohoyn>sneek, botsnack
<sneek>tohoyn, you have 1 message!
<sneek>tohoyn, daviid says: I pushes a series of patches to g-golf, which shouldn't affect your code, but still, when you have some free time, please pull, make, check and lt me know if everything is alright ... tx
<sneek>:)
<aleix>tohoyn: what's the difference between g-golf and guile-gi?
<tohoyn>aleix: ask daviid or str1ngs. I have not used guile-gi.
<aleix>p0a: Guile is a general programming language. It can also be embedded (such as Lua) to existing applications written in C or C++. There are Guile projects for game development, bindings for TensorFlow, it is the basis of Guix (a new OS) and it has a bunch of available modules ready to be used. AFAIK, it can not be used to write Emacs modules, eventhough there's been attempts that almost succeed but I didn't follow what happened.
<p0a>aleix: thank you
***apteryx is now known as Guest61150
***apteryx_ is now known as apteryx
<RhodiumToad>other than being embeddable, it's not much like lua :-)
***sputny1 is now known as sputny
<dsmith-work>Happy Friday, Guilers!!
<civodul>Happy Friday!
***sputny1 is now known as sputny
<chrislck>anyone knows if you can get out of hash-for-each early easily? no call/cc pls :)
<civodul>chrislck: you can use let/ec for a non-local exit using delimited continuations
<civodul>or 'throw', which is equivalent
<chrislck>ah nice
<chrislck>(throw ...) sounds like tantrum...
<dsmith-work>call/cc and let/ec sounds like someone dying with something stuck in their throat..
***sneek_ is now known as sneek
<wingo>i fixed the match problem!!!!!!!!!!!!!!!!!!
<wingo>aaaaah this is nice
<civodul>wingo: yay!
<civodul>congrats on that one
<wingo>reduces some big functions that use match by 30-40%
<civodul>woow
<civodul>Guix makes heavy use of match
<civodul>i should give it a spin
<wingo>the % reduction in the limit can be 100% ;)
<civodul>:-)
<wingo>yeah the compiler uses match too, obvs
<civodul>yeah
<civodul>that also means that many tests are elided, right?
<chrislck>o/
<wingo>civodul: yep
<wingo>many tests, many intermediate computations
<wingo>cse.scm is all ugly now but i can try to work on that
<wingo>this is great. now i can finally work on making "case" compile as it should
<civodul>wingo: is this optimization... CPU-intensive? :-)
<wingo>it shouldn't be
<civodul>ok
<wingo>why, is the build taking longer than it used to?
<civodul>no i haven't tried it yet, just wondering
<wingo>the constant factors of CSE are a little higher but it is linear, and it residualizes a smaller program with less control-flow so the net effect is that the compiler speeds up
<civodul>ah yes, more initial work, and less work in later passes
<wingo>e.g. compiling compile-bytecode.scm is around 10% faster with this optimization than in 3.2
<civodul>neat
<wingo>3.0.2 rather
<civodul>so you'll be partying all night long? ;-)
<wingo>hahaha :)
<wingo>gotta admit it's delightful to reach a good place on a friday afternoon :)
<civodul>heh, it's a great feeling!
<janneke>so, #guile is the feel-good place today, great \o/
*sneek dances
<wingo>:)
<janneke>*lol*
<dsmith-work>wingo: Something you might want to fix. Current code is fine, but still.. In lightening.c, JIT_NEEDS_LITERAL_POOL is #ifdef'ed everywhere except for one place that uses #if instead. Should be #ifdef there too.
<lfam>I'm excited to get these improvements in Guix :)
<wingo>dsmith-work: do you want lightening commit access? :)
<dsmith-work>Do I need paperwork?
<wingo>dsmith-work: i dunno, it is not a gnu project, but guile uses it. wdyt civodul, is it important for contributors to lightening to assign to fsf ?
*wingo steps out for a bit
<civodul>wingo: it's currently all copyright FSF (right?), so i'd lean towards preserving it
<civodul>assignment is always a barrier, but maybe it's okay for lightening
<dsmith-work>wingo: btw, the build time for the latest master is about the same. 35m for me.
<civodul>"Fix typo causing performance problems!!!" fun :-)
<rilez>Can you put texinfo in comments above defines?
<sneek>rilez, you have 1 message!
<sneek>rilez, nckx says: <I get an error that says builder for xserver.conf.drv failed with exit code 1. What can I do?> The full output would be helpful. You can use a pastebin on IRC, or send an e-mail to help-guix@gnu.org if you prefer. If the last ~10 lines of that output mention a .bz2 log file, please include its text as well.
<RhodiumToad>moo
<rilez>RhodiumToad 🐮🐮
<rilez>ah ok i figured it out. I found doc-snarf.
<rilez>now the question is how to get geiser to find it