IRC channel logs

2020-05-17.log

back to list of logs

<dsmith>RhodiumToad: That's what I was thinking. (a CG thread)
<kolyad>I'mm having a problem with a recursive macro, and I'm sure I must be doing something stupid. https://paste.debian.net/1147236
<kolyad>It appears to expand indefinitely, Suggestions?
<dsmith>You only have one case in your macro.
<RhodiumToad>the null? test is being done at run time
<RhodiumToad>so there's no way for the macro expansion to terminate
<dsmith>SO when you "call" the macro, it expands again.
<dsmith>You need another case for terminating the macro.
<dsmith>what RhodiumToad says
<kolyad>Ok. Thanks. I was kinda lost.
<dsmith>SO
<dsmith>Just like a recusive function, you need a terminating condition,
<dsmith>You also need a terminating macro condition. In "macro rule" land not "expanded code" land.
<reepca>how would one query which file is backing a certain module?
<reepca>I suspect I have stale .go files somewhere, but can't seem to find them
<dsmith>reepca: Well, they are usually under ~/.cache/
<dsmith>.cache/guile/ccache/3.0-LE-4-4.2/
<dsmith>Or similar
<dsmith>Installed ones are somewhere like /usr/local/lib/guile/3.0/ccache/
<reepca>I've deleted ~/.cache/guile quite a few times though, and the problem persists
<dsmith>reepca: If I'm building guile from git, and it, and it's changing rapidly, I regulary just blow away the ~/.cache/guile dir
<dsmith>reepca: Might I suggest pulliing out the every mighty strace?
<dsmith>strace -efile guile {whatver}
<reepca>when I run (set-current-module (resolve-module '(my-module))) and then try evaluating a certain variable in my-module, it says that it's unbound
<reepca>but when I try evaluating a different variable it doesn't say that it's unbound
<dsmith>You can where it's looking, and what it's looking for, AND where it's not.
<reepca>it just occurred to me that this is probably that one optimization at work
<reepca>where it deletes bindings that aren't exported
***catonano_ is now known as catonano
***jonsger1 is now known as jonsger
<ZombieChicken>Can one write a module for the Linux Kernel using Guile?
<dsmith>ZombieChicken: No
<ZombieChicken>No way to transpile/translate guile into C?
<dsmith>Not at this time, no. There used to be a translater years (more like decades) ago. "hobbit" I think it was.
<dsmith>Around guile 1.3 I think.
<dsmith>Well, this is interesting! https://weinholt.se/articles/quasiquote-literal-magic/
<reepca>so in order for (unshare CLONE_NEWUSER) to work, the process needs to be single-threaded. I count at least 6 threads launched by the time the repl starts up. Is there a way to control this?
<dsmith>Heh. Blast from the past: http://gnu.ist.utl.pt/software/guile/anon-cvs.html
<chrislck>vim is scriptable by racket... how interesting...
<dsmith>Sounds like vim is getting closer and closer to emacs...
<chrislck>lol: it'll have virtuous-mode to counter evil-mode
<dsmith>heh
<tohoyn>daviid, str1ings: has the callback support of G-Golf or GObject Introspection documented anywhere?
<tohoyn>^been documented
***janneke_ is now known as janneke
<str1ngs>tohoyn: Last time I talked to daviid he had not started working on it.
<tohoyn>str1ngs: ok. I just encountered some callbacks when I worked with Theme-D-Golf.
<str1ngs>signals should work, but situations that use GAsyncReadyCallback etc won't work.
<str1ngs>which function are you having problems with?
<tohoyn>str1ings: none. I just noticed that gi-import-xxx procedures imported some callbacks.
<tohoyn>str1ngs: not actually imported (only a notification)
<tohoyn>daviid: it says in https://www.gnu.org/help/evaluation.html that GNU software should be internationalized with gettext. did you have to do that with G-Golf?
***luni is now known as stidue
***stidue is now known as luni
<lampilelo>i'm playing with hooks and snarfing in c, is there more idiomatic way to create a hook than this? https://paste.debian.net/plain/1147305