IRC channel logs

2020-05-07.log

back to list of logs

<rlb>dustyweb: don't have time to read the whole scrollback right now, but (1) yes, I'm using fash, though for it to be suitable for me longer-term, it'll need to add a fash-delete, (2) I have some fash patch(es); I think I've sent them to wingo, but not sure what the general position on them will/would be, and (3) fwiw, you may know, but as more prior-art, the clojure syntax there is just {x y} (and #{x y} is a set), which guile presumably
<rlb>couldn't adopt as-is because, if nothing else, srfi-105. Clojure also evaluates the contents (eventually), i.e. at runtime, {(inc 1) :two} maps 2 to :two (where inc is just 1+).
<rlb>Oh, and I'll also need a fash-set :)
<rlb>In any case, I'd love to see solid persistent map and set support in guile proper, whether or not it ended up being suitable for me right now.
<rlb>One of the patches was to add a fash-update, similar to clojure's update.
<justin_smith>yeah, update / update-in / assoc-in make a big difference in usability of immutable hashes
<rlb>...careful api design and the arrow forms don't hurt either, though I can understand if some are put off by the latter.
***wxie1 is now known as wxie
<dsmith-work>{appropriate time} Greetings, Guilers
<mwette>o/
<dustyweb>rlb: hey
<dustyweb>thanks for responding :)
<dustyweb>glad to hear where we have clear overlap
<str1ngs>hello daviid, I just wanted to follow up on the callback work we looked at the other day. How did you make out with that? It did capture my curiosity :)
<lloda>cyclopsian: thx - i'll try to have a look
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>sneek: seen mwette?
<sneek>mwette was last seen in #guile 2 hours and 20 minutes ago, saying: o/.
<dsmith-work>!version
<dsmith-work>!uname
<sneek>Linux beaglebone 3.8.13-bone47 #1 SMP Fri Apr 11 01:36:09 UTC 2014 armv7l GNU/Linux
<daviid>str1ngs: I will work on this within the next few days ... will let you know
<str1ngs>daviid: I'm not in a rush for the feature. just curious how the implementation was going. if you need help with any of the C parts let me know.
<reepca>are open-pipe and open-pipe* the only built-in guile procedures for starting a process without waiting for it without using primitive-fork?
<daviid>I now have a reasonable idea on how to make it work, after that long chat on #intro ... and I think I can do it without a single line of C code, but if not, will let you know ...
<str1ngs>daviid: that would be nice if you can avoid C even.
<unknown_lamer>dsmith-work: hey, the patch you emailed me against bobot++ a few weeks ago is all there is for 3.x support so far, right?
<unknown_lamer>I should probably apply that and push it out to git
<dsmith-work>unknown_lamer: There few other things I've found since. Some doc errors. Commented out some "cerr <<" debug messages in the mutex code.
<unknown_lamer>docs are probably atrocious heh
<unknown_lamer>I think I wrote them over a weekend when I was ... 17
<unknown_lamer>threading "support" was added pretty late too
<dsmith-work>unknown_lamer: Just some typos. Like bot-log instas of botlog or so.
<unknown_lamer>I wonder if there's any straightforward guide to the changes in C++ since C++98 heh
<unknown_lamer>I think I can drop HP/UX support now too
<dsmith-work>However, there are some odd things going on.
<dsmith-work>Like for-each being uindefined! However, *is* available after using srfi-1.
<dsmith-work>I thing the way bobot tries to put it's scheme interface into guile-user is suspect.
<unknown_lamer>dsmith-work: ancient times...
<unknown_lamer>original code is from ... 97 or 98?
<unknown_lamer>and I think predates modules in guile itself if my memory isn't completely failing me
<dsmith-work>I know the bot has been running for at least 10 years or so.
<unknown_lamer>'tho I could have sworn there's a bobot-user or similar module, probably not hard to do that if not
<unknown_lamer>I remember some low level trickery though, iterating over the exported symbols of some module
<dsmith-work>Yes,
<dsmith-work>So the earliest commit for guile-sqlite is March 2, 2010. Pretty sure the bot was running before that.
<unknown_lamer>yeah, I asked to take over maintenance in 2003
<unknown_lamer>modernized the C++ (... for the time, I guess it's crusty and old again now!) and ported forward to guile 1.9 I think
<unknown_lamer>git history should have everything
<dsmith-work>unknown_lamer: Still hacking CL?
<unknown_lamer> https://git.hcoop.net/clinton/bobotpp.git/commit/2e20c3e1445f1539b3164af29da30654942f6a15
<unknown_lamer>2002 is when I started hacking on it, guess at some point I might have been using CVS ha
<unknown_lamer>guess in 2002 that's all there was other than raw RCS
<unknown_lamer>dsmith-work: nope, just a sysadmin nowadays
<unknown_lamer>doing almost no programming at all for like eight years now :-\
<dsmith-work>Woah.
<dsmith-work>Not cvs, it was bzr I think.
<unknown_lamer>I switched to darcs once that existed
<dsmith-work>Maybe that's what I'm remembering
<unknown_lamer>then imported cvs -> darcs, 2008-11-11 afaict (the "project @ ..." commits are all from the cvs to darcs tool)
<unknown_lamer>and now to git in 2020!
<unknown_lamer>I like darcs more theoretically but there's no good UI to it anymore, magit finally made git tolerable
<dsmith-work>magit make it fun! Makes me want to write code just so I can use magit.
<unknown_lamer>people here thought i was some kind of wizard and it was just because i used magit ha
<unknown_lamer>converted a few vim users to the correct editor thanks to it ;)
<dsmith>unknown_lamer: The hooks section in the docs describes the args to the various hooks, but not what the text regex is matching against.
<dsmith>Seems like it's all the hook args separated by spaces.