IRC channel logs

2020-04-30.log

back to list of logs

<dsmith>SO there must be something in the way bobot is starting that is hiding or removing the normal for-each. But I don't see other things going away..
<dsmith>Odd.
<dsmith>Ya, for-each is in boot-9
<RhodiumToad>very odd
<dsmith>Hmm. There is one in scheme/base.scm too
<alextee[m]>can jinja be used with guile?
<alextee[m]>i have a website that uses python and jinja but the more i use guile the more i want to convert everything!
<dsmith>sneek: paste?
<sneek>Someone once said paste is https://paste.debian.net
***catonano_ is now known as catonano
***logicmoo is now known as dmiles
***apteryx is now known as Guest30039
***apteryx_ is now known as apteryx
<z0d>hi
<z0d>how can I sort an alist by its cdr?
<RhodiumToad>what type are the cdrs?
<RhodiumToad>(sort my-alist (lambda (a b) (< (cdr a) (cdr b)))) or something along those lines, with a suitable comparison in place of <
<z0d>oh. I've read the docs on sort, but didn't see that you can specify an accessor
<z0d>thanks
<z0d>but makes sense
<emys>is there a context-manager like form in guile to change the current work directory for the execution scope
<emys>something like (with-current-work-dir "some/path" exprs ...)
<tohoyn>macro guard in guile-3.0 file module/ice-9/exceptions.scm uses raise-continuable in one place. what would it change if this was changed to raise?
<dsmith>emys: I don't think so. (apropos "with-") doesn't reveal anything. Probably wouldn't be to hard to make though.
<dsmith-work>Morning Greetings, Guilers
<rekado>emys: Guix (guix build utils) has with-directory-excursion. It uses dynamic-wind with chdir.
<wingo>i bet that's exciting in a multi-threaded environment :)
<tohoyn>should expression "(display (guard (exc ((integer? exc) "abc\n")) (raise 10))))" give output "abc"?
<tohoyn>for me it interrupts the program with signal 1
<tohoyn>it works in guile 2.2.7
<tohoyn>but not in guile 3.0.2
<tohoyn>could somebody else check this with guile 3.0?
<mwette>unbound variable: guard
<mwette>where does that come from?
<tohoyn>mwette: (ice-9 exceptions) in guile 3.0
<tohoyn>mwette: guile 2.2: (import (rnrs))
<tohoyn>mwette: it works in 3.0 if you do (import (rnrs)).
<tohoyn>mwette: tx anyway
<mwette>3.0.2 crashes w/ "User defined signal 1"
<mwette>w/ import rnrs: abc
<dsmith-work> https://paste.debian.net/1143954/
<dsmith-work>Works for me.
<dsmith-work>Does get some warnings though.
<tohoyn>strange: (rnrs exceptions) seems to take the implementation of guard from ice-9
<RhodiumToad>weren't there significant changes in this area for 3.0 with the aim of unifying the different exception mechanisms?
<dsmith-work>Ya, I heard something along those lines.
<dsmith-work>Errors in guile are often annoying. You see some format string and a bunch of args instead of a nice message.
<dsmith-work>I think the changes around handling exceptions are meant to improve that.
<dsmith-work>What's expecially annoying is printing some random error causes a much worse segfault or some other abort.
<wingo>sneek: later tell tohoyn definitely a big
<sneek>Got it.
<wingo>sneek: later tell tohoyn definitely a bug
<sneek>Okay.
***dddddd__ is now known as dddddd
<dsmith-work>sneek: seen civodul?
<sneek>civodul was last seen in #guix 5 hours and 2 minutes ago, saying: sorry for the delay!.
<RhodiumToad>is there / should there be a distinction between "seen X here?" and "seen X anywhere?" and which should be the default...
<dsmith-work>RhodiumToad: Hmm.
<dsmith-work>RhodiumToad: Currently only the very last message is saved. No matter what channel.
<dsmith-work>Wasn't ever an issue when the bot was only in #guile.
<dsmith-work>sneek: botsnack
<sneek>:)
***Server sets mode: +nt
<daviid>str1ngs: tohoyn, I pushed a patch that adds a high level api entry for (gdk_) events - a small doc reorganization actually, since its content was previously defined in 'Gdk - Events'. I am not entirely happy with the doc structure (and content, but that is none stop endless task ...) yet, but I think this tiny 'move' is going in the right direction