IRC channel logs

2020-04-19.log

back to list of logs

<seepel>Hi guile, I'm still playing around with cps and I keep seing primcalls that have dotted pairs in the dst field, but I can't figure out what they mean. Does anyone have any ideas or can point me to a good place to learn about the dst field?
<seepel>Managed to find a few instances of these dotted pairs being utilized in the bytecode compiler. Mostly things like scm-set!/immediate. But cache-ref and cache-set! are still a bit of a mystery. Maybe it'll be the next blog post.
<Aurora_v_kosmose>Any general suggestions on Guile testing?
<Aurora_v_kosmose>A quick search shows Greg as being a thing.
<Aurora_v_kosmose>Hm. SRFI-64.
<daviid>Aurora_v_kosmose: fwiw, I use guile-lib unit-test for all my projects
<Aurora_v_kosmose>daviid: Seems like that & SRFI-64 are the current ways to do it.
<daviid>I personally don't beleive in 'current ways' nor do I select 'those' as criteria to orient/select anything I do, but as I said, fwiw ... you do as you wih of course
<Aurora_v_kosmose>Current -> supported and bugs are patched
<Aurora_v_kosmose>That's the main reason why I care.
<Aurora_v_kosmose>Abandonware has the downside that when something breaks, you're on your own.
<str1ngs>Aurora_v_kosmose: unit-test is quite nice.
<Aurora_v_kosmose>Does it have somewhat more wordy documentation somewhere?
<str1ngs> https://www.nongnu.org/guile-lib/doc/ref/unit-test/
<Aurora_v_kosmose>Ah, that's the same as the info-pages.
<str1ngs>there is not much to it really
<str1ngs>create a test class derived from <test-case> and then create generic methods with your assertions
<str1ngs>then call (exit-with-summary (run-all-defined-test-cases)) to run all the tests
<Aurora_v_kosmose>Assertions will generate reports?
<str1ngs>exit-with-summary will
<Aurora_v_kosmose>Ah, I see.
<str1ngs>Aurora_v_kosmose: here's a really basic example http://paste.debian.net/1141259
<str1ngs>Aurora_v_kosmose: one of the nice things about unit-test is you don't have to run your tests at load time.
<str1ngs>so where you call (exit-with-summary (run-all-defined-test-cases)) is subjective.
<Aurora_v_kosmose>Ah, I see.
<Aurora_v_kosmose>Somewhat offtopic, but Nomad seems like a nice project.
<str1ngs>it's definitely really fun to hack on :)
<Aurora_v_kosmose>Is it in what you'd call a usable state or?
<str1ngs>It's pretty usable. though it's pretty bleeding edge. the version in guix is pretty basic compared to the current development version.
<str1ngs>but for the most part if you like emacs you'll probably like using nomad.
<str1ngs>I'm slowly gearing up for a new alpha release. but it's a big release. all of the C code as been ported to scheme. with the help of g-golf
<Aurora_v_kosmose>It does all rendering & everything in Guile?
<Aurora_v_kosmose>That's neat.
<str1ngs>all of the GUI GTK but using scheme and extensible. so for web-buffer it use webkitgtk. for term buffer it use vte
<str1ngs>there is an ibuffer for switching buffers etc.
<Aurora_v_kosmose>Huh, I see what you mean by Emacs-like.
<str1ngs>there is a working echo-area and most emacs keybinds just work like you would expect.
<str1ngs>alot more work needs to be done. I'm mostly laying the ground work for future additions.
<Aurora_v_kosmose>Huh, I might try it later.
<str1ngs>the version in guix is pretty stable but not as complete as the feature-g-golf branch.
<str1ngs>so better to build from git if you really want to try it out.
<Aurora_v_kosmose>Duly noted.
<str1ngs>and there is #nomad-browser if you need help with anything. or have suggestion or bug reports.
<Aurora_v_kosmose>Thanks. The channel probably ought to be mentioned on the Nomad page.
<str1ngs>noted :)
***dddddd_ is now known as dddddd
***hugh_marera_ is now known as hugh_marera
***jonsger1 is now known as jonsger
<mwette>di
***drakonis1 is now known as drakonis
***amiloradovsky1 is now known as amiloradovsky