IRC channel logs

2020-03-06.log

back to list of logs

***apteryx is now known as Guest3073
***apteryx_ is now known as apteryx
<gagbo_>Hello, sorry to disturb, I'm trying to make a header and a footer window with ncurses bindings and I can't make it appear. Can someone quickly check if I'm doing something terribly wrong ? (56 lines example here that can run anywhere ncurses is available) https://paste.centos.org/view/5c2cc94e
<gagbo_>Using derwin instead of newwin seems to work, but I wonder if that has performance implications
<gagbo_>I'm also worried because I want to remember the number of visible lines in the main window, so I'm not sure that (lines) will still be update (i.e. with footer/header heights substracted) automatically when I call the function
<gagbo_>going offline for a bit, if someone tries to use sneek , I'll probably reconnect as gagbo later. Have fun
***V is now known as Guest66803
<obyz>hi, I'm getting error while building guile 3.0 (Windows10 + cygwin): make[2]: *** No rule to make target '../bootstrap/ice-9/eval.go', needed by 'ice-9/and-let-star.go'. Stop.
<obyz>can someone help please
<RhodiumToad>sneek, later tell gagbo curses doesn't handle overlapping windows, so if you want a header+footer, also create a window for the space in between and use that instead of stdscr
<sneek>Will do.
<RhodiumToad>sneek, later tell gagbo though of course using subwindows is another option as you noted
<sneek>Got it.
<chrislck>question regarding named lets: see http://paste.debian.net/1133717/ I've seen old code use an ugly named let recipe (A) whereas modern (B) is nicer. Was (A) common in the past?
<RhodiumToad>well, A doesn't assume the availability of (match ...)
<rekado>(length lst) traverses the whole list first, doesn’t it?
<rekado>if match isn’t available one could do the same with car, cdr, and null?
<rekado>well, very much like in A.
<rekado>I think the single-branched if in A is rather ugly.
<rekado>I’d use an inner let.
<chrislck>gah I was trying to highlight the (xloop (car rest) (cdr rest)) construct vs (xloop rest)
<chrislck>was it common in the past?
<RhodiumToad>well it saves doing either multiple (car ...) or using another let
<RhodiumToad>i.e. you'd need something more like
<RhodiumToad>(let xloop ((lst lst)) (let ((this (car lst)) (rest (cdr lst))) ...
<RhodiumToad>so the (xloop (car ...) (cdr ...)) style simplifies it slightly
*RhodiumToad has no idea what was or was not common in the past
***gagbo_ is now known as gagbo
<jcowan>Single-branched if should be when (or unless)
<jcowan>and in this case cond would be better
***janneke_ is now known as janneke
<gagbo>Documentation of guile-ncurses seems to say I should be able to properly make multiple windows :( I'll try something else then
<sneek>gagbo, you have 2 messages.
<sneek>gagbo, RhodiumToad says: curses doesn't handle overlapping windows, so if you want a header+footer, also create a window for the space in between and use that instead of stdscr
<sneek>gagbo, RhodiumToad says: though of course using subwindows is another option as you noted
<gagbo>Oh right, make a middle window. Thanks RhodiumToad
<civodul>hey ho!
<civodul>wingo: i'm all for a 3.0.1 (and perhaps 2.2.7) release, WDYT?
<civodul>i'm happy to help with that, like updating NEWS or something
<wingo>civodul: yeah i have been a bit time-limited recently, but i agree!
<wingo>would be nice to fix that hash bug
<wingo>the one with arrays and subarrays
<wingo>but i guess it's been with us for forever
<civodul>wingo: yes, i can take a look at the hash bug
<janneke>also, could someone (possibly spk121?) reply to rutger's piped-process patch some time (he's still working on the peg patch that i promised and will probably have to get paperwork done first
<civodul>janneke: i think i haven't seen it yet but yes, it sounds worth a look!
<janneke>it's a patch we've been using for a popular non-posix operating system, that allows a pipepeline without forking (guile-devel)
<janneke>could be nice for gash, esp. wip-mingw-guile-2.2 gets merged
<civodul>i see
<manumanumanu>janneke: that is one hell of a nice patch! One question is whether it should use the shell by default, or if there should be one pipeline and one pipeline*
<manumanumanu>I just got a new keyboard, and I'm not typing the wrong characters anymore. it feels liberating. AND: it's clicky. Let's see if I have to get a divorce.
<oni-on-ion>ah! that is great news. cant wait to upgrade mine as well
<janneke>manumanumanu: thanks, yeah i gues a pipeline* variant could be nice
<janneke>anyway, also we could not figure out how to do the docstring
<manumanumanu>wingo: btw: if there is still interest I made all the changes that you wanted to srfi-171 (transducers). The only thing I am unsure of is the commit message :D :D No stress, though. And there is a fix for sxml in the discussion about ssax not treating CDATA correctly. That should probably be done upstream, though.
<manumanumanu>janneke: there has been some discussion about exposing open-process anyway. Maybe rutger's patch could be a part of a little larger thing to redo the whole working with processes? open-process still does not allow you to get the error port iirc.
<manumanumanu>anyway. Not time for work.
<janneke>manumanumanu: sounds nice
<dsmith-work>Happy Friday, Guilers!!
<janneke>manumanumanu: indeed, handling/piping stderr could be interesting too
<dsmith-work>civodul: https://lists.gnu.org/archive/html/guile-user/2016-06/msg00055.html
<dsmith-work>I'm seeing that with 3.0.0
<civodul>dsmith-work: you're seeing what precisely? :-)
<dsmith-work>Seems to work when I change "ISO-1588-1" to "UTF-8" in the call to mem_iconnvh() in libguile/strings.c
<dsmith-work>civodul: Guile wont start. Errror out reading boot-9. "cannot convert narrow string to output locale"
<dsmith-work>Had to reboot, so I've lost my context.
<dsmith-work>civodul: So I'm attempting to get guile 8 running on arm64 using buildroot.
<dsmith-work>My actual error message is
<dsmith-work>Pre-boot error; key: encoding-error, args: ("scm_to_stringn" "cannot convert narrow string to output locale" 22 #f #f)Aborted
<civodul>dsmith-work: what libc are you using? under what locale?
<civodul>perhaps you could mail this to bug-guile
<dsmith-work>Yes, I'm planning on it. Gathering info.
<dsmith-work>The toolchain is pre-built Linaro. Pretty sure is glibc
<dsmith-work>LOCALE env is not set. What should I set it to?
<civodul>what about the LC_* variables, as well as LANG and LANGUAGE?
<dsmith-work>None of that is set. I think the default is C ?
<dsmith-work>I'm not that up on locale things.
<civodul>then yes, it must be the "C" locale
<dsmith-work>So it's attempting to convert "ice-9/eval" from "ISO-8859-1", to "ANSI_X3.4-1968" and returning an error.
<dsmith-work>Maybe the C lib was configured in some incompatible way.
<dsmith-work>Hmm. Guile is attempting to open /usr/lib/gconv/gconv-modules.cache and /usr/lib/gconv/gconv-modules, which apparently don't exist.
<dsmith-work>And I see an option to include gconv libs. Rebuilding with that option set.
<chrislck>does anyone know a C profiler as easy to use as (statprof slow-fn) ???
<wingo>perf is pretty good
<wingo>run your program under "perf record ..." and then do "perf report"
<chrislck>perf... nice! (thx for all the statprof.py.scm!)
<dsmith-work>Woo! I think that was it!
<dsmith-work>scheme@(guile-user)> (version)
<dsmith-work>$1 = "3.0.0"
<dsmith-work>scheme@(guile-user)> (system "uname -a")
<dsmith-work>Linux maaxboard 4.14.78 #1 SMP PREEMPT Fri Mar 6 09:53:40 EST 2020 aarch64 GNU/Linux
<civodul>dsmith-work: yay, neat!
<civodul>wingo: do you have a lead on the ARMv7/JIT segfault: https://issues.guix.gnu.org/issue/39208 ?
<civodul>we briefly discussed it in Brussels and ISTR you had an idea
***jonsger1 is now known as jonsger
<lampilelo>how do you install guile3 with guix?
<jackhill>lampilelo: guile-next currently
<lampilelo>jackhill: ah, thanks
<jackhill>lampilelo: you're welcome