IRC channel logs

2020-03-05.log

back to list of logs

<dsmith>Hey hey
<theruran>is Guile getting Scheme bindings for GTK3/4?
<str1ngs>theruran: there is g-golf and guile-gi
***sneek_ is now known as sneek
<dsmith-work>Thursday Greetings, Guilers
<mwette>Good day!
<dsmith-work>So. "cannot convert narrow string to output locale"
<dsmith-work>The env doesn't have any locale things set.
<dsmith-work>I'm pretty clueless here. What would be the minimal. Like a basic C locale or so.
<dsmith-work>Well the string that it can't convert is |ice-9/eval.scm|
<dsmith-work>Ahh. Doesn't like ISO-8859-1
<dsmith-work>Woo
<dsmith-work>Looks same as this: https://lists.gnu.org/archive/html/guile-user/2016-06/msg00055.html
<Jmabsd>(doublepost) guys, how do you implement the following in syntax-case:
<Jmabsd>(define-macro (hello-world) '(print "Hello, World!\n"))
<Jmabsd>(define-macro (begin0 arg1 . rest) (define g (gensym)) `(let ((,g ,arg1)) ,@rest ,g)))
<Jmabsd>syntax-case is not trivial to learn, your pointer here would be much appreciated
<Jmabsd>also there are no syntax-case learning resources for people who don't know syntax-case already, kiiinda
<chrislck>try syntax-rules, much easier
<dsmith-work>Indeed
<dsmith-work>And define-syntax-rule is even simpler
<Jmabsd>chrislck: i like to learn syntax-case today
<chrislck>well this is a hill that many have failed to climb, including myself
<Jmabsd>chrislck: at least guile has a man page on it lol.
<Jmabsd> (define-syntax hello-world (lambda (syntax-object) #'(print "Hello, world!\n")))
<Jmabsd>this seems to work
<dsmith-work>scheme@(guile-user)> (define-syntax-rule (hello-world) (display "Hello World\n"))
<dsmith-work>scheme@(guile-user)> (hello-world)
<dsmith-work>Hello World
<dsmith-work>And there it is using define-syntax-rule
<dsmith-work>Great for trivial things like that.
<Jmabsd>dsmith-work: yeah that's syntax-rules, i like to learn how to do it in syntax-case.
<Jmabsd>yea sure, syntax-rules is great. today studying other
<Jmabsd>ok got it all clarified on #scheme, great, also #gerbil-scheme
<str1ngs>sneek: later tell nly you probably want to use webkit_web_context_set_network_proxy_settings with the default context which you can get with webkit_web_context_get_default. see https://webkitgtk.org/reference/webkit2gtk/stable/WebKitWebContext.html. This will set the proxy for all GtkWebView's .
<sneek>Will do.
<str1ngs>sneek: later tell nly, try setting this in startup-hook for now.
<sneek>Okay.