IRC channel logs

2020-01-20.log

back to list of logs

<dsmith>Hey! It built. With only a few changes. Two functions difference. A needed #include, and updating configure for 3.0
<erkin>Nice
<ZombieChicken>back
<ZombieChicken>dsmith: scwm?
<mwette>I'm guessing scwm is a window manager in scheme. There used to be sawfish (aka sawmill).
<ZombieChicken>I'd assume so, too, but there are so many acronyms, I'd rather ask and be sure
<str1ngs>daviid: thank you for looking at this. I had to step out for awhile. For reference I use this documentation https://webkitgtk.org/reference/webkit2gtk/stable/WebKitWebView.html#WebKitWebView-load-changed . I will test your fix now.
<daviid>str1ngs: no problem, let's see if it is a 'real' fix, i think so but ...
<str1ngs>daviid: looks good so far. thank you.
<daviid>str1ngs: welcome, tx for the report
<mwette>ZombieChicken: http://scwm.sourceforge.net/
<str1ngs>daviid: it was an odd bug for sure. webkit has strange IPC though. was that related?
<daviid>str1ngs: no, it was a very big bug of mine!
<daviid>str1ngs: such a bug that i deserv a brown bag for at least a week :):)
<str1ngs>daviid: bugs happen :). though in all fairness events have worked quite well since inception. I thought I might find more bugs by now.
<dsmith>ZombieChicken: Yes, Scheme Configurable Window Manager.
<daviid>str1ngs: wrt to the example 'per se', you know you could use eq? (rather then equal?), then you may even use case, which would, imo, make the code 'cleaner', like this - https://paste.debian.net/1126732/
<daviid>str1ngs: the case for will also allow to treat more then one load-event at the same time - ... (case load-event ((started redirected) <your code here ...>) ((commited) ...)) ...
<daviid>*form
<daviid>str1ngs: just some thought ... fwiw
<rlb>wingo: in v3.0.0 it's still libguile/libguile-2.2-gdb.scm? (Fine with me, just noticed it while working on the debs.)
<mwette>rlb, wingo: when I install 3.0.0 the only "gdb" file I see installed is libguile-3.0.so.1.0.1-gdb.scm
<apteryx>erkin, dsmith, erkin: thanks for the inputs regarding my question about "partitioning" :-). I'll have a closer look at what's in srfi-1.
<str1ngs>daviid: thank you.
<civodul>Hello Guilers!
<rgherdt>hi civodul
***Server sets mode: +nt
<dsmith>sneek: later tell wingo https://github.com/BurntSushi/wingo
<sneek>Okay.
<civodul>do people see segfaults while building Guile 3 on ARMv7?
*civodul does but it might be non-deterministic
<jonsger>civodul: I see a different then you. Unrelated
<civodul>jonsger: but you do see a segfault while it's building, right?
*civodul tries to get a backtrace
<jonsger> https://build.opensuse.org/package/live_build_log/devel:languages:misc/guile/openSUSE_Factory/armv7l my assumption is that it's the "wrong" ARMv7
<civodul>that looks quite different
<civodul>so yeah, SIGILL might be because you're not on the right arch or something
<jonsger>yes. Thats why I said unreleated :P
<civodul>yup!
<dsmith>civodul: I did not get a segfault on armv7l gcc 6.3.0
***nerdypepper is now known as nerd
***nerd is now known as np
***np is now known as nerdypepper
<civodul>dsmith: oh ok
<civodul>would have been too easy it everyone had the same problem ;-)
***nerdypepper is now known as n
***n is now known as nerdypepper
<dsmith>civodul: I would suspect a different compiler version handling something "unspecified" in a different way.
<civodul>could be
<dsmith>sneek: version
<sneek>Sneeky bot running on Guile version 3.0.0 using bobot++ 2.3.0-darcs
<dsmith>civodul: The bot is on 3.0 on arm
<civodul>yeah, nice!
<jonsger>wingo: do you have a guile 3.0 compatible version of guile-charting?
***ng0_ is now known as ng0
<lloda>guile-cairo does work on Guile 3 w/o issue
<lloda> other than maybe the install, I haven't checked that
<str1ngs>funny I was just going to see if I could map out some goop classes with g-golf and cairo
*civodul reported ARMv7 JIT crash: https://issues.guix.gnu.org/issue/39208
<daviid>str1ngs: cairo is not introspectable, but we have guile-cairo
***apteryx_ is now known as apteryx
<str1ngs>darn I was hoping to use it to draw things with g-golf
<daviid>str1ngs: it is possible, maybe it needs some special treatment, but that has been done for guile-gnome and gle-clutter - so they can use a cairo surface ...
<str1ngs>gobject-introspection ships with cairo-1.0.gir but I think that is just providing some type information.
<daviid>str1ngs: here is an example (which I posted already, but ...) - https://www.nongnu.org/grip/learn.html - the clock example
<str1ngs>maybe clutter would work just as well
<daviid>str1ngs: no, cairo is a complete and necessary 'tol' for it offers - clutter is a complete diff best
<daviid>*complete different and necessary tool
<daviid>*beast
<str1ngs>I've used clutter before, cairo would be better for what I need. I just want to map out goops class hierarchy
<daviid>str1ngs: you generally need both, in my experience
<daviid>str1ngs: here the code i was talking about http://git.savannah.gnu.org/cgit/grip.git/tree/grip/clutter/clock.scm
<str1ngs>I think I can draw to a GtkDrawingArea
<str1ngs>but without the cairo GI. i'd have to do the drawing in C
<str1ngs>see https://developer.gnome.org/gtk3/stable/GtkDrawingArea.html
<daviid>str1ngs: i don't have time now, but everything can be done in scheme, i just posted an example and the code ... in gtk4, clutter is included in gtk ...
<daviid>somehow ...
<daviid>have to hack o somethng else now... bbl
<daviid>this none truncat excaption is a disaster
<daviid>a total disaster
<rekado_>trying to build pfds with Guile 3 but get “Unbound variable: &assertion” in procedure “raise-exception”.
<rlb>With 3.0.0 00-repl-server test is failing here with fport_read EINVAL (in I think the read-line) when I build and run it as root, but not when run as another user. Any idea why that might be?
<rlb>(and of course I don't know that "root" is the critical difference, just that's when it appeared, and it's completely reproducible -- happens every time)
<rlb>...looks like it's the ptob->c_read in scm_i_read_bytes that's throwing the EINVAL.
<rlb>...odd -- at that call ptob->c_read is neither a pointer to read() nor to trampoline_to_scm_read, and I can't see any other places c_read would be set to any other value.
<rlb>(though I'm guessing that's not the issue...)
<rlb>Current guess is either something's wrong with the repl socket when building/running as that other (root) account, or there's a race that's plays out differently there...
<rlb>"that plays out"
<rlb>Oh, well -- I'll come back to this, but looks like 3.0 debs will be delayed a bit longer.
<rlb>civodul: ahh -- I noticed you'd had to deal with some 00-repl-server test issues in the past, and right now I'm finding that the test reliably fails when I build 3.0.0 from the v3.0.0 tag as root, but not as a normal user. (Could well not be "root" related.) It fails with an fport_read EINVAL in the read-line in read-until-prompt in the "simple expression" test every time.
<rlb>Ring any bells?
<civodul>hi rlb!
<civodul>rlb: that doesn't ring a bell, but i wouldn't run tests as root :-)
<civodul>it could be root-related indeed
<rlb>They'll always run as root when the debs are building on the buildds. (Debian packages have to be built as root -- or fakeroot.).
<rlb>But no, I don't normally do that, day to day...
<rlb>I traced it down into scm_i_read_bytes -- the ptob->c_read() call there, but no idea why...
<rlb>yet
<civodul>oh, weird
<rlb>also, not sure this is relevant, but the c_read pointer there isn't either read or the trampoline_read -- it's some other address.
<rlb>(couldn't see how that could happen)
<rlb>(I mean at that point -- I printed them via %p)
<rlb>But I'm sure c_read could be getting assigned some way other than the obvious ones...
<rlb>s/sure/imagine/
<rlb>Anyway, I'll have to figure this out before I can finish the 3.0.0 debs.
<akhetopnu>has anyone here used websockets in guile? what library did you use? is it available through guix?
<outtabwz>looks like there is interest in guile emacs
<outtabwz> https://old.reddit.com/r/emacs/comments/equuct/i_would_help_fund_the_development_of_guile_emacs/
<outtabwz>i haven't used it, but sounds cool
<rlb>I'm certainly interested, but as mentioned there, I suspect who really has to be(come) interested is the Emacs maintainers.
<janneke>it's packaged in guix, but yes it's important to get emacs hackers "on board"
<outtabwz>some people are very protective of elisp
<outtabwz>elisp and scheme are both considered lisp1 right?
<jcowan>No, Elisp is a Lisp-2.
<jcowan>That is, an identifier can be bound to both a value and a function, and (foo x) uses the function binding. If you want to use the value binding, you have to write (funcall foo x).
<jcowan>There are some Lisp-1s that aren't Scheme, but I can't think of any offhand.
<outtabwz>oh yeah
<outtabwz>i think there are some other things though
<RhodiumToad>quite a lot of elisp code exists
<outtabwz>it's true
<outtabwz>github is full of elisp
<RhodiumToad>including things like magit, which is extremely useful
<outtabwz>it would be neat if guile's elisp module could handle all that'
<zig>akhetopnu: there is https://github.com/a-guile-mind/guile-websocket/commits/master it needs some love
<zig>in particular, IIRC the last two commits are garbage.
<dsmith>Wooo. Got finally got the scwm simple.scmrc working.
<dsmith> define*-public doesn't curry any more.
<rekado_>It seems that (rnrs condition) has a bug: it exports &assertion but only imports &assertion-failure as &assertion-violation, so &assertion is actually undefined.
*rekado_ submitted a bug report
<dsmith>screen cap: https://drive.google.com/open?id=176CqHg_z8Fzj5ZWui__01YC1YFWZP-1L
<mwette>Can someone define what Guile Emacs is? Is this guile used as emacs-engine running elisp, but also providing bindings in scheme (for the stuff in emacs lisp books)?