IRC channel logs

2020-01-11.log

back to list of logs

***wxie1 is now known as wxie
***logicmoo is now known as dmiles
<raghav-gururajan>test
<sneek>Welcome back raghav-gururajan, you have 1 message.
<sneek>raghav-gururajan, raghav-gururajan says: what
***Server sets mode: +nt
***ng0_ is now known as ng0
<mehlon>does #guile not allow connections from kiwiirc?
<mehlon>it seems a user had trouble sending messages in here
<rndd>hi everyone!
<bandali>mehlon, not sure, but they may have to be a registered freenode user
<bandali>also, hi :)
<mehlon>I guess that might be it. or just a client issue
<rndd>I'm newbe in guix. Trying to find out how to print output of function to file. here is a pastebin https://pastebin.com/egDyas9f . Ask for help =)
<bandali>rndd, this may be useful: https://stackoverflow.com/a/43361469
<bandali>try replacing "hello, world" in there with (print)
<rndd>bandali, thanks but error the same https://pastebin.com/mW9B5VT4
<mehlon> https://www.gnu.org/software/guile/manual/html_node/Pipes.html#Pipes
<mehlon>you need to pipe the output of the command first
<bandali>rndd, ^
<bandali>also, you need to actually call the display function, i think
<rndd>bandali, adding print just write exit code to file (for this situation it writes 0)
<bandali>rndd, you mean adding display? like (display (print) output-port) ?
<bandali>then i guess you need to use pipes, as mehlon mentioned
<rndd>bandali, yes
<bandali>ok
<rndd>i'm sorry, dont understand how to use pipes. could ask for examples? for example what MODE i should use? etc
<bandali>the above page explains what MODE to choose
<bandali>based on your “ls” example, you need OPEN_READ
<bandali>oh
<bandali>actually, that’s the C procedure
<bandali>you should use the open-input-pipe function
<bandali>just read that manual page
<bandali>they even give you an example
<rndd>ok
<rndd>is there any guile-mode for emacs with syntax highlighting and smart-tabs?
<bandali>there’s scheme-mode
<bandali>so yes
<rndd>bandali, oh thanks. dont know it is built-in
<bandali>rndd, no problem :) it’s built-in indeed
<rndd>ok, i've copy-pasted example from manual https://pastebin.com/xBZTAZcW and got error "unbound variable read-line". Do i need to use something else? any module to access read-line?
<bandali>rndd, try adding (use-modules (ice-9 rdelim)) to your file
<rndd>does pipes in guile input only shell commands?
<spk121>.
<daviid>str1ngs: I pushed a series of patches related to gdk-event(s), no doc yet, but here our 'test-bed' hello-world examples adapted, see the 'key-press-event code - the event is now a <gdk-event-key> instance (not 'just' a foreign pointer anymore), and one can use its <gdk-event-key> accessors, just like i the example
<daviid> http://paste.debian.net/1125643/
<daviid>of course I will add other gdk-event struct def and acc one by one ... but feedback welcome
<daviid>spk121: your feedback would be most welcome as well of course, if you 'play' with this and have a comment, please ping me ...
<spk121>daviid: I'm super sick, so my brain in a muddle, but, the code looks pretty at first glance
<daviid>spk121: oh, take care of yourself then! tx for the nice words of course, once you recover, if you try, let me know ...