IRC channel logs

2019-12-15.log

back to list of logs

<rekado_>I’m getting the same error when using the fibers backend instead of the standalone web server in (fibers web server)
<str1ngs>daviid: hello I have been doing some thinking about methods. I think you mentioned you were going to add support for them. ie (gtk-window-show-all window) vs (show-all window) this might allow for generic methods.
<daviid>str1ngs: yes, after i finish the doc for what g-gplf has in its high level api, then signals, i should work to get these 'long name method names' as short names method to ...
<str1ngs>daviid: good to know thanks. I'm looking at it from a generic method stand point. not so much the inconvenience of the long names
<rlb>Is there any more or less approved way to detect when a macro is expanding at the top level, or alternately to detect when a "name" passed to a syntax expander is going to be a toplevel-ref from within the expander?
***Server sets mode: +nt
<chrislck>something stumps me.... (define (proc arg1) ...), and later we call (proc arg1 arg2) which should fail. is this something that changed guile-2.0 to 2.2?
<daviid>chrislck: cold you post the exact sinpset that doesn't do what you think it should ... just you saying so, we can't test and prove ...
***catonano_ is now known as catonano
<daviid>bbl
<chrislck>sent to bug-guile
<chrislck>fwiw the (IMHO incorrect) behaviour seen when (proc) is an *internal* define
<chrislck> http://paste.debian.net/1121118/
<chrislck>using guile-2.2.6
<daviid>chrislck: here, using 2.2.6, it complains at interpreted/compile time already
<daviid>but fail to raise the exception when the situation happens ...
<daviid>i thnk extra args are ignored, you'd receive an exception for insuficient ar number
<daviid>someone familiar with the scheme spec might tell ...
<chrislck>the odd thing is 2.0 raises exception as IIUC it should, but I don't know what the spec says
<daviid>chrislck: you are bing warned at compile time though ... and this doe not produce wrong results either
<chrislck>not sure what you mean by compile. "guild compile try.scm" says no error. not sure if genuinely is an error, yet is a change of behaviour 2.0->2.2 and causes unexpected failure in 2.0, or passes unexpectedly in 2.2
<chrislck>will await spec geniuses to chip in
<daviid>chrislck: one of the 'problem' is that these procedures have to deal with multiple values, without coplaining
<daviid>chrislck: i said warning, not error
<daviid>it is not an error, extra eargs are 'dismissed', but there is no error
<chrislck>sure... a 2.0 -> 2.2 change nonetheless, and haven't found documentation about it
<chrislck>just, surprising
<daviid>management of mltiple values has changed between 2.0 and 2.2, iirc
<chrislck>if add1 was a define* then I'd agree no issue, but a standard define IMHO would have borked
<daviid>chrislck: but again, there is no error, what is your concern wrt this?
<chrislck>ah because code developed in 2.2 yet users may run in 2.0 and get an unexpected error
<daviid>chrislck: so, you don't have to do 'anything', 2.0 users will have to change their 'calls', but 2.2 and newer guiler versions won't complain, rightfully ... progress, not rgression ...
<daviid>and invite everyone to use 2.2, soon 3.0 ...
<chrislck>:) if only... some users refuse to upgrade and keep posting bug reports on releases 2 years old. "It's my right to demand you maintain old releases"
<daviid>chrislck: then the buf is theirs, not yours, since there are calling with extra agrs ...
<daviid>*bug
<zig>hello #guile
<rlb>Answering my own question, maybe syntax-local-binding (to detect a top-level id), if that's likely to stick around.
<johnjay>daviid: looking at that list i don't see anything concrete like a mp3 player or a notepad editor or a image viewer
<johnjay>everything is a library or kit or some kind of framework
<daviid>johnjay: that list is the mst complete list of guile apps and libs we have, time for you to hlp us to complete it ...
<johnjay>well i want to make sure i understand what guile is
<johnjay>if nobody is writing a GUI calculator in guile there must be a reason
<johnjay>i'm trying to install guix but so far no luck
<daviid>johnjay: wrt guix, try to share your difficulties on #guix
<johnjay>i bring it up because maybe it will have some applications written in scheme
<johnjay>i'm a little concerned you can't seem to name any
<johnjay>and i didn't see any on that list
<johnjay>am I wrong?
<daviid>johnjay: thre are tons of apps written in guile scheme, i wrote some :) many other wrote many others .. make yur shoping on that list ...
<daviid>and build your own ...
<catonano>johnjay: you' re right to be concerned. Guile has a problem. As reference you might take the talk by christopher Lemmer Webber about how it lacks libraries
<catonano>as for GUI apps, the integration layer with Gnome is in the works currently, there are some small demos around but it' s gonna be a looong walk and it' s just beginning
<catonano>johnjay: you can read my own take here https://quisquiliae.hashbase.io/guile-and-free-software.html
<johnjay>catonano: the one from FOSDEM 2019?
<catonano>johnjay: I don' t remember if it was Fosdem 2018 ro Fosdem 2019
<catonano>they announced their adoption of Racket and proposd the community the idea of thinking about some convergence between Racket and Guile
<catonano>if I remember correctly
<spk121>yeah. for me personally I've written a couple of fully scheme GTK programs or ncurses programs, but, they are not much more than demos
<johnjay>catonano: ah ok. as a rule of thumb having games like tetris or sokoban is the first sign of a healthy software ecosystem
<johnjay>thanks for the link
<catonano>johnjay: :-)
<spk121>i've got a guile tetris using ncurses, haha
<johnjay>^
<str1ngs>sneek: later tell spk121 how hard would it be to create a generic program that uses either gtk or ncurses?
<sneek>Okay.
*mwette back to working toward nyacc 1.0 release
<mwette>I can now parse "enum { FOO = 1, }; enum { BAR = 1 + FOO };" and generate constant association `(BAR . 2)'
<spk121>mwette: nice!
<sneek>Welcome back spk121, you have 1 message.
<sneek>spk121, str1ngs says: how hard would it be to create a generic program that uses either gtk or ncurses?
<spk121>str1ngs: hmm. gtk is a high level toolkit and handles mouse and keyboard automatically. Ncurses is lower level, analogous to the GDK, Cairo, and libinput. So to both ncurses and Gtk, you'd have to write a widget in ncurses the mostly behaves like the Gtk widget, and then go from there
<mwette>sneek: emacs does that, methinks
<rekado>I can’t seem to build fibers with Guile 2.9.7.
<jcowan>johnjay: There's not that much advantage to replacing an existing C/C__ application with a Guile version. Better to integrate the application with Guile to make it scriptable
<johnjay>ok
<johnjay>that makes sense
<johnjay>that webber talk hard for me to follow but i did get the impression racket is "the best" w.r.t. libraries and guis
<johnjay>and something about mutable toplevels being good for games for some reason
<johnjay>ah the only comment mentions immutable top level