IRC channel logs

2019-11-02.log

back to list of logs

<davidl>amz3: thanks for your help and suggestions. I managed to create a C extension using the guile FFI stuff. I just called the module "cio" and it provides a "read-file" procedure that can read 200MB into a guile string variable in 1.5 seconds. Im gonna write a C extension for writing to file too now :-)
***janneke_ is now known as janneke
<ArneBab>davidl: wow …
<davidl>ArneBab: yeah it's a huge difference :-D
<davidl>ArneBab: still though, it takes almost 40 seconds for the same computation that takes 5-6 seconds in python... :/
<davidl>Im considering that I need to write a C extension for parsing the string to a guile array.
<ArneBab>you might be able to golf this down to similar speeds
<davidl>I hope so eventually.
<ArneBab>it could even work in pure scheme — what mark did to the substring replacement felt magical :-)
<ArneBab>but it migh be better to have a read-lines procedure for this so you don’t have to split the string into lines in scheme
***pc is now known as Guest93751
<davidl>ArneBab: here's the repo if you're interested https://gitlab.com/methuselah-0/guile-cio