IRC channel logs

2019-10-08.log

back to list of logs

<nisstyre>does guile have a good quality actor model library?
<nisstyre>also, can someone explain what "guile mode" is?
<nisstyre>I'm just skimming over the docs for embedding guile in C
<nisstyre>if I wanted to run a C function that blocks in another thread, would I have to leave "guile mode" before calling that function?
<daviid>nisstyre: only partially answering, look at 8sync
<sneek>daviid, you have 1 message.
<sneek>daviid, str1ngs says: I'm not sure where I implied any of that. I was pretty much saying hello, did I read these commit logs correctly. If anything it was a RFC and nothing more.
<nisstyre>daviid: ok I'll check that one out
<nisstyre>hmm, looks like I don't have to leave guile mode: "Starting from Guile 2.0, blocked threads no longer hinder garbage collection. Thus, the functions below are not needed anymore."
<nisstyre>so I could just call my function in another thread and it would all be fine
<nisstyre>still not sure what it means by "guile mode", I assume that's a catch all for code running under guile
***d4ryus1 is now known as d4ryus
***daviid is now known as Guest16914
<jlicht>Hey guile, can guile's `chmod' support relative modifiers, such as "+w"? Or am I forced to use the fully written out forms, such as #o755?
<jlicht>context: I have a directory of files that I want to "+w" for the current user, but some of these files are scripts and others are simply text, so there is not once value to pass to chmod if I simply want to make all of the files writable
<pinoaffe>hi everyone! is there a function kind of like find but unlike find it returns both the predicates value and the item it found?
<pinoaffe>I could of course just implement it myself, but don't feel like reinventing the wheel
<weinholt>jlicht, for your question earlier today, combine stat and chmod: (let ((st (stat fn))) (chmod fn (logior (stat:perms st) #o200)))
<jlicht>weinholt: that is much easier than I thought, thanks!
<dsmith-work>Morning Greetings, Guilers