IRC channel logs

2019-09-06.log

back to list of logs

<daviid>heya
<daviid>str1ngs: the gtk-container-get-children you posted the other day is an example of use for glist returned value ...
<daviid>str1ngs: but yes, if you come to face another use then those gobject subclass instances glist(s), please post ... and i'll work on it, as i said, 'on demand' ...
<str1ngs>daviid: right I know for sure I use GList there. have not look at that portion of code yet. will look at it tomorrow. hopefully
<str1ngs>daviid: I can confirm notebook append is working now when passing #f
<daviid>ok tx
<lispmacs>hi, is there some trick for running an action when an object is garbage-collected? E.g., say you need to close a port that has been hanging out in a procedure's closure, and the procedure object is collected
<lispmacs>i remember doing something like this in Racket, I think it required using a special object definition form or something like that
<spk121>lispmacs: try (add-hook! after-gc-hook (lambda () ....))
<spk121>but that doesn't exactly solve your problem. it just runs a procedure after a GC happens
<lloda>ft: I use this https://github.com/lloda/guile-ffi-fftw
<lloda>it's the bare minimum, just what I needed
***janneke_ is now known as janneke
<ft>lloda: Cheers! :)
<apteryx>how do I get a count of the number of occurences of a substring?
<apteryx>Python has `findall', IIRC.
<apteryx>What's the equivalent in Guile?
<civodul>apteryx: you could to regex-exec + fold-matches, but that's not quite the same
<civodul>i don't know of anything equivalent i guess
<apteryx>civodul:thanks, will try that
***jao is now known as Guest99674
<apteryx>another question: suppose I have a string like ""listen on 127.0.0.1\n listen on ::1\n [...]", shouldn't (string-match ^listen on 127.0.0.1$" that-string) return a match object? (it returns #f)
<apteryx>ah, in the source string there's no carret (^) at the beginning
<apteryx>oh, I guess I need to make my regexp with (make-regexp patt regexp/newline)
<apteryx>civodul:the fold-matches documentation has an example to count matches :-)
<civodul>apteryx: heh, not that bad :-)
<apteryx>indeed :-)
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>Has the bot been behaving itself?
<nly>yes, sneek is very helpful :)
<nly>happy friday!