IRC channel logs

2019-09-04.log

back to list of logs

<daviid>str1ngs: yes, though you're not supposed to use it ... and the 'machinery' is in <gtype-instance>, from which <gobject> inherit ... see (g-golf hl-api gobject) and (g-golf hl-api gtype) if you are interested
<str1ngs>daviid : good to know. thank you. I'm almost done porting all my SCM pointer's so I shouldn't need 'g-inst much longer
<str1ngs>GNUtoo: you can use class-of procedure from oop goops . to figure what a variable is type of it's good for debugging. just an FYI
<GNUtoo>oh nice, thanks
<str1ngs>I hope that made sense, I kinda messed up that last sentence lol
<daviid>str1ngs: ok, not sure how much time i will take for signals and gclosures, so no ruch ...
<str1ngs>daviid: I'm okay with signals for now. I understand that's not going to be an easy feature either.
<daviid>str1ngs: once i have gclosures, signals are 'easy', so to speak
<str1ngs>right, and there is the threading aspect.
<daviid>*once g-golf has ...
<str1ngs>be intresting to see how you do that.
<daviid>yes, like guile-gnome and any other bindings, g-idle-add*
<str1ngs>I'm assuming that we could pass a procedure with connect?
<daviid>*binding g-iddle-*, that is easy, but they also need gclosures
<str1ngs>right, some signals need that. I don't use them often my self
<daviid>str1ngs: yes og course, that is the objective
<str1ngs>if at all. my signals are pretty standard. but I can see some complicated cases.
<daviid>every signal will accept lambda (or proc) that acept th appropriate number of args ...
<str1ngs>I almost said lambda earlier. that seems to make the most sense.
<str1ngs>also this might be an edge case. https://developer.gnome.org/gtk3/stable/GtkNotebook.html#gtk-notebook-append-page when passing NULL. gtk will create the label for the tab. but when I pass #f like so (gtk-notebook-append-page notebook widget #f) seems to work
<str1ngs>to not work*
<str1ngs>I can work around it by passing a <gtk-label> but I thought maybe either was passing the wrong argument in the form of #f. or this is just not supported yet
<daviid>str1ngs: are you in C for this 'queston', because NULL is alloed
<str1ngs>no I C I would use NULL, but for scheme I thought NULL was #f?
<daviid>in g-golf, #f is 'transformed' to %null-pointer
<str1ngs>okay, I will test this more. and come back with a simple example.
<daviid>maybe another bug :), could you paste a sneipset about htis?
<daviid>*snipset
<str1ngs>will do, I think I can replicate this quickly now
<daviid>str1ngs: foe example, this works fine when calling (gtk-init #f #f) (in this case the warning are nt due to these null pointers, but arrays, which i have to investigate ,...
<str1ngs>okay, will have a paste here shortly for you
<daviid>tx
<str1ngs>code http://paste.debian.net/1098678 error is (scm-error goops-error #f "No applicable method for ~S in call ~S" (#<<accessor> !g-inst (270)> (!g-inst #f)) #)
<str1ngs>if I use (make <gtk-label> #:lable "label") instead of #f it works okay.
<str1ngs>my first guess is this is an edge case
<str1ngs>#:label *
<daviid>will look at it asap
<str1ngs>no biggy, this is more a FYI. since it's trivial for me to work around
<daviid>this is extremely important for g-golf, thanks for the report and snpset
<str1ngs>I can just do (gtk-notebook-set-tab-label-text notebook widget page) which will set the label what I need after the fact.
<str1ngs>I agree, it's why I mention them :)
<daviid>str1ngs: i pushed a fix, tx again for the report
<str1ngs>daviid: no problem with test it out
<str1ngs>will*
<daviid>str1ngs: other missing bits are glist (and gslist, ghash), for example clutter-actor-get-children would fail in the current 'state of things', will work on this to ...
<str1ngs> daviid glist could be an issue for me as well. Since I use gtk_container_get_children which is probably on par with the clutter actor method.
<daviid>yes, i'll try to fix it asap
<str1ngs>no worries
***sneek_ is now known as sneek
***jao is now known as Guest42290
<spk121>hmm. my first bug fix to guile-ncurses in two years. So many neglected projects need fixing...
<eiro>a/join #obs
<eiro>oops sorry
***Guest42290 is now known as jao