IRC channel logs

2019-08-31.log

back to list of logs

<nly>has anybody written about moving from a different non-lispy static site generator to haunt?
<heisenberg-25>anyone has experience with using valgrind with guile?
<hackyhacker>Hello how can I read a line from stdin with guile?
<hackyhacker>Is there a port that is stdin? I don't understand
<nly>if you use the procedure (read-line)
<nly>then type "something" and hit Return
<nly>it's available in (ice-9 rdelim) module i think
<nly>and you can get the stdout and stdin with (current-input-port) (current-output-port)
<hackyhacker>Ah thanks that works :)
<Tirifto>Hello all!
<Tirifto>I'm reading about keywords in the Guile manual, where it says that ‘Guile’s keyword support conforms to R5RS’. However, the only keywords R5RS seems to talk about are syntactic keywords, which is not the same thing, is it?
<Tirifto>(Guile's keywords seem to name arguments, as in (procedure #:name1 argument1 #:name3 argument3).)
<mwette>Tirifto: keywords and keyword arguments to procedures are different things
<mwette>keywords are syntax: (keyword? #:hello) => #t
<mwette>(symbol? #:hello) => #f
<Tirifto>mwette: I see—and chapter 6.6.7 of the Guile Reference Manual documents both of them?
<Tirifto>(For Guile 2.2, if you want to refer to it.)
<jcowan>Tirifto: The syntax #:keyword is not a valid R[4567]RS identifier, unlike :keyword (CL) and keyword: (DSSSL). So there is no collision.
<jcowan> https://bitbucket.org/cowan/r7rs-wg1-infra/src/default/KeywordSyntax.md shows which Schemes do what keyword syntax(es).
<rlb>Tirifto: perhaps also related: https://www.gnu.org/software/guile/manual/html_node/SRFI_002d88.html I *think* that may be the only somewhat-agreed-cross-scheme syntax?
<Tirifto>Aha! So it conforms to R5(+)RS by not colliding, right?
<spk121>.
<rlb>Tirifto: I just meant that srfi-88 is (as far as I know) the only "standardized" keyword syntax, and hence might be more likely to be supported now or eventually by any given scheme.
<rlb>And even that srfi doesn't specify that the keywords have to be self-evaluating.
<rlb>(though I'd imagine that they probably would be in any given implementation of srfi-88)
<rlb>...I've switched to using srfi-88 in some new code so that there's a better chance it might be portable.
<Tirifto>Ah, alright. Thanks for pointing me to that!
<rlb>certainly