IRC channel logs

2018-08-28.log

back to list of logs

***Server sets mode: +nt
***Server sets mode: +nt
***geokon1 is now known as geokon
***geokon1 is now known as geokon
***geokon1 is now known as geokon
<wingo>moin
<civodul>hey wingo!
<wingo>greets :)
<amz3>moo
<rekado>I really like using fold with match-lambda and keywords to better structure the accumulator.
<rekado>it’s super useful
<civodul>with keywords?
<rekado>(fold (lambda (item acc) (match acc ((#:foo f #:bar bar) … ))) …)
<rekado>i.e. treating the accumulator as an object with separate bins.
<rekado>nothing special, but I think it’s nice :)
<civodul>rekado: it is, yes
<civodul>i think many have their own 'fold2' as well (there's one in Guix)
<rekado>b
<wingo>lloda: any perf results so far?
<wingo>or crashers?
<daviid>"Jupyter Trademark is registered with the U.S. Patent & Trademark Office"
<daviid>sorry, didn't mean to paste that text here :)
<daviid>lloda: sorry I did say I was going to ak you for some help, then disappeared :), but here is a linear algebra/guile-cv API naming question
<daviid>in guile-cv, I have im-multiply, the matrix multiplication proc name, then working on iage textures, I realized I needed im-times (elts per elts multiplication), and im-divide (elts per elts div, but that name is used for matrix mult. of the inverse ...) hence I thought I should rename ... as octave does things
<daviid>octave uses times, mtimes, divide and mdivide
<daviid>now, I think I should rename im-multiply -> im-mtimes, im-divide im-mdivide, and then create im-divide, im-times ... WDYT?
<daviid>*working on image texture (measures)
<daviid>lloda: our channel is not properly logged anymore (how sad), so don't answer if I'm not here (the text log somtimes comes with a few days delay, and are almost unreadable :(
<amz3>interesting discussion on the value of nothing, I am wondering what does the existing msgpack libary do
<daviid>amz3: I don't know, but I agree with civodul, that one should use (value)
<amz3>(value) can not be stored in a variable, ludo changed his mind, and wrote its prefered solution is to use a singleton record instance
<daviid>anything would be 'something'
<amz3>which I tend to agree
<daviid>then it s not 'nothing' that one once
<amz3>yes
<amz3>the problem i see while using a symbol, is that symbols are part of javascript spec so they might one day end up in JSON
<amz3>and other serialization formats
<daviid>maybe we should have nothing remaned and have it in guile core ... (I haven't red my emal yet ... need to catch)
<daviid>'almost-nothing, and this empty record instance ...
<daviid>we should call it tinn (this is not nothing - ceci n'et pas une pipe)
<daviid>*n'est pas...
<amz3>first joke I read from you
<amz3>^^
<amz3>next billion is the slogan used by google to explain that's its going to capture development countries in its sillos
<amz3>the expressions stayed
<amz3> https://qz.com/on/the-next-billion/
<amz3>exemple of that slogan displaying various attemps to from GAFAM to bite them
<amz3>my xp with people from deveplement countries is that, they will be very hard to convince that 'free' even gratis is something of interest
<amz3>seems like a lost cause
<amz3>at first!
<amz3>basically, they want to the western shit
<amz3>for instance In algeria, we had numerous limonades. People were unhappy because it was no Coco Cola per se.
<amz3>I mean in the past you had choice about which limonade to drink, now there is only Pepsi and Coke and its derivates
<amz3>so much brain drain
<amz3>my last hope, is that free software is way to transfer technology and knowledge and that might talk to them as way to bring more work to those countries, a slim chance.
<amz3>I even plan to create a translator for scheme experession. I take as input dictionary, produce the same code with translated identifiers.
<rekado>these are the worst kind of error messages: Wrong number of arguments to #<procedure 2486760 at ice-9/eval.scm:336:13 (a b)>
<rekado>In ice-9/eval.scm
<rekado>I wonder if this can be avoided.
<janneke>yeah, drop in a repl and inspect it would be nice...
<rekado>turns out this was because of “receive”
<rekado>I had the thing that returned multiple values wrapped in a simple thunk, so the result was just a single value instead of the two that I expected to receive.
<rekado>does anyone happen to know the right format for passing headers to an HTTP request?
<rekado>e.g. (content-type . (text/html))
<rekado>I’ve tried all variants of (cache-control . (max-age 60))), but I always get “bad header”.
<janneke>i pulled this snippet from an older application, not sure if it helps...
<janneke>(values '((content-type . (text/html))) (web-file '(index.html)))
<jlicht> I had the following in some code calling out to some api, rekado: (define (headers) '((content-type . (application/json (charset . "utf-8")))(cache-control . (no-cache))))
<rekado>thanks. Unfortunately, I still don’t understand how to specify cache-control with max-age
<rekado>looks like this is correct: (cache-control . ((max-age . 60)))
<rekado>oh well
<amz3> https://github.com/a-guile-mind/guile-web/blob/master/src/web/helpers.scm#L46
<civodul>rekado: what you show seems to be correct
<civodul>there are examples in 'guix publish' if you want to double-check