IRC channel logs

2018-08-23.log

back to list of logs

<civodul>dustyweb: i've pushed a .texi file (mostly a stub) and a couple of other things to guile-gcrypt
<dustyweb>\o/
<civodul>i can make that a 0.1.0 release if that's fine with you
<dustyweb>civodul: thanks for keeping things rolling :)
<dustyweb>yes please!
<civodul>cool :-)
<civodul>dustyweb: done!
***Server sets mode: +nt
***geokon1 is now known as geokon
<rekado_>I get an error in (web http) when trying to fetch certain bugs from debbugs.
***rekado_ is now known as rekado
<rekado>I get an error in (web http) when trying to fetch certain bugs from debbugs.
<rekado>Bad Content-Type header: multipart/related; type="text/xml"; start="<main_envelope>"; boundary="=-=-="
<lloda>wingo: https://paste.debian.net/1038963/ segfaults lightning just from jit & running (define (array-f1 a) (array-ref a 0))
<wingo>nice
<wingo>must be we have something wrong in the call/receive sequence
<wingo>... or the toplevel-ref code? humm
***slyfox_ is now known as slyfox
<amz3>hello #guile
<rain1>hi
<ArneBab>rekado: you might have to implement multipart parsing. I recently did that for a server, though in a bit of a hurry: https://bitbucket.org/ArneBab/wisp/src/tip/examples/upload-server.scm
<amz3>hi ArneBab I keep you hack around I will need it
<amz3>ArneBab: btw, are you familiar with cross site forgery counter measures?
<rekado>ArneBab: I built that too, also in a hurry :)
<rekado>ArneBab: the problem here is actually sillier: the boundary string contains a bunch of “=”.
<rekado>apparently that’s not okay.
<rekado>Guile looks for the first equal sign and checks that it is the same as the last equal sign.
<rekado>the content type header looks like this:
<rekado>multipart/related; type="text/xml"; start="<main_envelope>"; boundary="=-=-="
<rekado>so in the case of “boundary” it sees the first “=” and then notices that the last “=” is not at the same position
<rekado>(unless (and eq (= eq (string-rindex x #\=))) (bad-header 'content-type str))
<rekado>I think Guile is wrong here.
<massma>Hi guile, new user with a silly question I can't find the answer for: how does guile determine/set search paths for dynamic c libraries?
<massma>the manual says it searches in /usr/lib and /usr/local/lib, but I'm on GuixSD with my libraries in ~/.guix-profile/lib
<amz3>massma: use absolute path
<amz3>massma: but not to ~/.guix-profile
<amz3>massma: use /gnu/foobar/thing
<amz3>massma: install guile-wiredtiger and see the config.scm file
<amz3>to see how it's done
<amz3>massma: ok?
<massma>amz3: gotcha, thanks a bunch.
<massma>amz3: Yes, (dynamic-link "/gnu/store/g234d3mja3s49d77nrwkf7sgfgh4xr3g-netcdf-4.4.1.1/lib/libnetcdf") does work
<rekado>massma: there are two ways: either the programme uses just the simple library name – in that case you can force it to load it from elsewhere by setting LD_LIBRARY_PATH; or the programme detects the library location at configure time and embeds the absolute file name of the library.
<rekado>massma: when packaging things for Guix in the former case we usually patch the code so that it refers to the exact path of the library.
<rekado>in user code you should not use /gnu/store manually.
<rekado>either add a configuration step or set an environment variable.
<amz3>what rekad said
<massma>rekado: thanks for the help, setting LD_LIBRARY_PATH seems like the easy thing for now, then add configure infrastructure later
<massma>appreciate the help
<amz3>!
<amz3>massma: subscribe to the mailling list https://lists.gnu.org/mailman/listinfo/guile-user ;]
<amz3>I got a comment on my guile youtube video, at last, world famous (tm)
<jcowan>Why does Guile support cyclic dependencies between modules? Does it even make sense to do so?