IRC channel logs

2018-06-26.log

back to list of logs

<ArneBab>daviid: thank you!
<daviid>ArneBab: wc!
<ArneBab>A first tutorial for writing programs with wisp: http://www.draketo.de/proj/with-guise-and-guile/wisp-tutorial.html — basic introduction to programming
<manumanumanu>ArneBab: now the pre-checks are merged (which means support for in-generator). There wont be any post-checks any time soon, but I managed to simplify in-value so that it isn't needed anyway. In the long term I will make a re-write to have the loops be composed of more manageable parts (now I am doing everything at the same time, which gets pretty hairy if you look at the for/emit macro). However, now they do
<manumanumanu>everything I set out to do, and they produce very good code (almost always as fast as hand-rolled loops).
<manumanumanu>BTW: what do you want me to write in the blog? Just about the macros, or about writing complex macros in general?
<snape>Is there a way to identify a fiber? I'd like to log its name or id, for debugging purposes.
<wingo>snape: not really. i had that at one point but removed it. if you want to make something like that, i think you need to wrap the fiber primitives
<snape>wingo: okay, thanks, I'll do that maybe
<civodul>"Transient intmap owned by another thread ((2008))" oh oh!
<civodul>i had never seen this one
<wingo>really??
<wingo>intmaps were designed to be threadsafe in the clojure sense but implemented before atomic references landed
<civodul>isn't there a TOCTTOU race with assert-readable! there?
<wingo>so their "atomics" aren't fully implemented; they need to use atomic references
<wingo>however there are never multiple threads accessing an intmap at the same time
<wingo>in current guile
<wingo>so i dunno how you got there!
<wingo>ACTION has to run, biab
<civodul>indeed
<civodul>see ya!
<wingo>good evening
<OrangeShark>hello everyone
<ArneBab>manumanumanu: either would be a great topic!
<ArneBab>manumanumanu: a discussion why you like this style of for-loops and how people can use them would also be great.
<OrangeShark>hmm, the change daviid did for installation location of Guile-Lib is interesting
<janneke>i'm thinking of making Mes a GNU package, wdyt?
<civodul>janneke: why not!
<sneek>Welcome back civodul, you have 1 message.
<sneek>civodul, lfam says: I pushed the security reporting changes we discussed to guix-artwork.git. Can you deploy the changes?
<civodul>janneke: you could explain how it differs from Guile, MIT, and SCM
<civodul>just so they understand that it's a different beast ;-)
<civodul>but then i think it definitely has its place, in terms of user freedom preservation
<janneke>civodul: thanks! yes, i'll do that.
<daviid>janneke: 1+ for GNU Mes
<civodul>speaking of which, does Mes have '1+'? :-)
<daviid>haha
<janneke>hmm
<janneke>ACTION goes to check
<janneke>mes> (1+ 3)
<janneke>[sexp=(1+ 3)]
<janneke>$0 = 4
<civodul>it passes the test, pheww ;-)
<janneke>here i was going: let's hope it fails
<janneke>ACTION would have loved to say: I take patches :-D
<civodul>heheh :-)
<snape>I'm trying to debug (with pk) in a test suite (srfi-64 I believe), but I can't see any output. Any idea about how it should be done?
<janneke>snape: i've been adding and using a `pke' variant that writes to stderr
<janneke>maybe i should present a patch to Guile
<snape>I'll try that janneke, thank you
<janneke>snape: my usage was /not/ in the context in srfi-64, but i imagine & hope it will work for you
<snape>well, the thing is: I can't even redirect the output to a file
<janneke>hmm
<snape>janneke: oops yes I can, of course it was my mistake
<snape>so you trick should work
<snape>Actually even stdout worked, it was another mistake. Sorry for the noise :p
<janneke>good for you!