IRC channel logs

2018-04-27.log

back to list of logs

***Raimondii is now known as Raimondi
<djcb>I'm defining some global config variables for my API; is there a recommended way to name them>? I.e., *my-variable* or %my-variable seem to be the popular choices.
<lloda>*parameter* and %global-variable I think
<lloda>I only use *parameter* myself
<OrangeShark>djcb: http://mumble.net/~campbell/scheme/style.txt is what is recommended to follow in guix
<OrangeShark>so it recommends *my-variable* for globally mutable variables.
<thomasd>repeating my question from yesterday (how many tries do I get? :-) ): is there a way to compile a guile script and run it, apart from the auto-compilation?
<OrangeShark>thomasd: so you compile the guile script and it still auto-compiles when you run it?
<thomasd>no, I compile the guile script with guild compile script.scm -o script.go, but then I don't know how to run the script .go
<thomasd>I know it's possible by creating a module and an entry procedure and calling 'guile -c "((@ my-module) my-procedure))"', but that seems overkill
<thomasd>Oh, it's just the file-name. The compiled file should be "script.scm.go", and then guile does find it :-D
<thomasd>instead of "script.go", that is
***webshinra_ is now known as webshinra
<djcb>OrangeShark: lloda: great, thanks!
<bavier`>thomasd: you can put guile in the shebang. there's a section in the guile manual discussing it
<amz3`>o/
<amz3`>héllo all
<rain1>hi
<amz3`>rain1: what's up?
<rain1>nothing much, thinking about what to work on next
<amz3`>that's the hardest
<amz3`>;)
<amz3`>everything is difficult
<amz3`>rain1: what did you do previously?
<amz3`>On my side, I am trying to create a user interface that looks like a REPL in a browser
<amz3`>my initial thought was to create a Natural Language to RDF query but I will stick to simple commands for the time being
<amz3`>also, I resurected the documentation https://github.com/amirouche/neon/blob/feb2f221b7a9dc0a89477618dec2d2917ca85612/doc/MOCHA2018/preview/neon-mocha-2018-preview.pdf
<amz3`>I had prepared a paper for participating to mocha challenge
<amz3`>but did not submit it
<amz3`>it's the most interesting documentation
<amz3`>also I've been adding unit tests
<amz3`>I am thinking about how to implement full text search inside the versioned triple store
<amz3`>quad store acutally
<amz3`>My current thought is to simply implement a blog app with a REPL-like user interface
<amz3`>even if it's sound silly and is not very good for search engines, it could be fun
<amz3`>I will store REPL session in the database with private links, so that people can come back later and continue there session
<amz3`>what I would like to know is how people interact with the REPL
<amz3`>and increase coverage of commands little by little
<amz3`>actually, I already wrote somekind of REPL in a web browser in the past, https://imgur.com/a/uYBUPTA
<amz3`>I would love to use guile-gnome, but the setup is daunting
<amz3`>Also, I am trying to get hang of the code base at my new job
<amz3`>very difficult, a lot of moving pieces, and many many repositories, which makes it hard to reason about the code properly
<amz3`>thankfully emacs support go-to-definition via elpy
<amz3`>what I would like to know is how people interact with the REPL, and increase coverage of commands little, maybe along the way I can do some AI that is more interesting that regular expressions
<spk121>Hello everybody. Is guile-enabled gdb still broken because of the guile 2.2 ports change? Or does guile-enabled gdb build now?