IRC channel logs

2018-04-22.log

back to list of logs

<jralls>wingo: What's Guile's policy about Windows? Is Cygwin a hard requirement?
<spk121>jralls: I'm the last one to patch up Cygwin, and for the past couple of weeks, I've been working on the MinGW. I'm close to making the 32-bit, non-threaded MinGW work in a private branch.
<spk121>I think Cygwin is in pretty good shape except for fork and some minor locale problems.
***logicmoo is now known as dmiles
<guile-guest4>hello all
<guile-guest4>newbie curious about LISP considering to dip my toe in, any suggestions where to get a first taste?
<guile-guest4>anyone listening?
<guile-guest4>hello
<guile-guest4>testing a little, seems nobody's on line at the moment
<slondr>uile
<slondr>hello
<amz3>héllo
<slondr>this is a basic question but how do I call reduce/fold in guile
<ngz>You have to load srfi-1
<slondr>How do I do that? I am very new to this language
<ngz>For example, from the REPL, you use (use-modules (srfi srfi-1))
<ngz>Then `fold' is available.
<ngz>You may want to read (info "(guile) SRFI Support")
<slondr>Thank you!
<turlando>Hello folks
<turlando>I know it sounds silly, but I couldn't find in the documentation the C function to convert an SCM string to a char pointer. Is there any? Will it produce an ASCII string?
<turlando>Also: is there a function to convert a keyword to a char pointer? Currently I'm doing keyword->string->charp
<turlando>Ok, just found scm_to_*_stringn
<faraco>Hi..where could I find GTK3 (not gtk2) for Guile binding?
<amz3>faraco: there is
<amz3>faraco: look at guile-clutter and an example app called gnu foliot
<amz3>faraco: I mean guile-clutter and guile-gtk2 or 3 I don't remember
<amz3>I will find the link for yoiu
<amz3>it's called guile-gnome → https://www.gnu.org/software/guile-gnome/
<amz3>faraco: ^
<amz3>spoiler I made a patch for skribilio :]
<amz3>+small
<mwette>looks like guile-gnome uses gkt2+ , check configure.ac in dist root
<faraco>amz3: Thanks for the link but it is not Gtk+3 as far as I know..
<mwette>There are raw ffi "pre-bindings" for gtk2+ in the ffi-helper part of nyacc. It might be possible to generate a gtk3+.ffi from the gtk2+.ffi. Are there extra libraries gtk3+ needs that gtk2+ does not have?
<mwette>gtk2+.ffi: http://paste.debian.net/1021463/
<mwette>but the generated scm code is a raw guile API to the underlying C code
<faraco>So I can just use the ffi to connect through gtk3?
<mwette>The command "guild compile-ffi" (not "guile compile-ffi") generated a .scm file from the .ffi file. Then, if that works, you use-modules the .scm file and go with that. I have been able to get very simple gtk2 demos to work. This is experimental code.
<mwette>Here is a working gtk2 demo: http://paste.debian.net/1021467/
<mwette>You would need to "cp gtk2+.ffi gtk3+.ffi" and go from there. I don't have gtk3 to try.
<amz3>let's start another project..
<mwette>faraco: I'm looking at gtk3. The package seems to depend on subclassing objects with help from lots of C macros. I'd guess generating apps from the raw interface provided by the FFI Helper is likely to be hard work.
<kristofer>davexunit: hey! can you possibly share an idea of your workflow when using haunt to build a site?
<daviid>is there an emacs command to switch between editng adn viewing lnks?
<daviid>is there an emacs command to switch between editng adn viewing lnks?
<daviid>in org-mode
<daviid>in org-mode
<ngz>C-c C-l maybe
<ngz>C-c C-l maybe
<ngz>But I think this is the wrong channel
<ngz>But I think this is the wrong channel
<daviid>ngz: :), most of us use org mode, so its fine to ask a few tips, not as if I started a political conversation or so ... relax
<daviid>ngz: :), most of us use org mode, so its fine to ask a few tips, not as if I started a political conversation or so ... relax
<ngz>I'm totally relaxed. I was merely suggesting you might have more luck on #emacs or #org-mode.
<ngz>I'm totally relaxed. I was merely suggesting you might have more luck on #emacs or #org-mode.
<daviid>yep, we all know this too, but thanks
<daviid>yep, we all know this too, but thanks
<ngz>...
<amz3>I have the feeling i was more proeductive a few years back, it's unrelated to the actual programming language
<amz3>I don't to what to attribute, my lazyness
<amz3>some flame of programming was exctinct in me
<amz3>I must revive it