IRC channel logs

2018-04-03.log

back to list of logs

<ArneBab>manumanumanu: :-)
<Digit>hi. i just daydreamed of an any-webkit guile-configurable web-browser. tis an enjoyable day-dream.
<turlando>Hello people
<manumanumanu>hello turlando ! what are you doing today?
<turlando>manumanumanu I have to work
<turlando>ACTION sighs
<lloda>sneek: later tell daviid g-wrap it's ok now, guile-config is not on my PATH, my complaint is that it shouldn't be required when pkg-config does the same
<sneek>Okay.
<lloda>sneek: later tell daviid wrt guile-lib install location, I don't have a preference on the *default* install location, but when I override it with --prefix, that should be respected. I have several installs of Guile and it makes no sense to have to install libraries on each of them
<sneek>Okay.
<lloda>sneek: later tell daviid my questions where about guile-cairo doc (not guile-gnome), where there are a couple of bugs that I can't fix b/c I cannot make the doc generation system work
<sneek>Got it.
<lloda>sneek: later tell daviid I'm now in the guile-cairo group in savannah, so I pushed my patches here http://git.savannah.nongnu.org/cgit/guile-cairo.git/
<sneek>Got it.
<lloda>sneek: later tell daviid bugs are in freedesktop.org here: https://bugs.freedesktop.org/buglist.cgi?quicksearch=guile-cairo
<sneek>Will do.
<lloda>sneek: botsnack
<sneek>:)
<turlando>I need to pass an unix pipe to the guile runtime so that functions defined with scm_c_define_gsubr can access it. Any suggestion?
<turlando>(it is to handle side effects, I have to access an OpenGL event loop)
<amz3>pmikkelsen: you want to write a new language on top of guile compiler or write a new backend?
<pmikkelsen>amz3: Not on top of guile, i just wanted to try and write a very simple stand-alone compiler
<amz3>ah
<amz3>then maybe brainfuck is a good start
<amz3>there is also work done on a javascript backend
<amz3>that might interest you
<amz3>does it?
<amz3>anyway, here is it https://gitlab.com/ijp/guile/tree/compile-to-js-2017
<amz3>myself, I don't understand how it works, but I am not into compilers
<pmikkelsen>Javascript is not of interest no, but I also think brainfuck is a good choice :) If i can get something to work, I may write a blogpost about it for anyone interested.
<amz3>I said, it could be interesting because it's a custom backend of guile compiler vm
<amz3>pmikkelsen: yes, make a blogpost and post it on the mailling list please
<amz3>ACTION always happy to read about new things in guile lab
<amz3>s/lab/land/
<pmikkelsen>amz3: Sure I will do, but it is maybe going to take some time as I have alot of work atm.
<amz3>no problem
<civodul>grrr delete-duplicates is in C so non-interruptible in Fibers
<manumanumanu>civodul: you can have this: https://pastebin.com/f8DRfRif
<civodul>sorry pastebin.com blocks Tor users, could you try paste.debian.net for instance?
<manumanumanu>civodul: http://paste.debian.net/1018299/
<civodul>thanks!
<civodul>oh yes, thank you :-)
<manumanumanu>oh... delete is probably c as well
<manumanumanu>I have delete somewhere here as well. to learn list processing I re-implemented parts of srfi-1. https://bitbucket.org/bjoli/nietzsche/src/1769998a800955d5831aa7c0c8b3c31ba00f7050/data/list.scm?at=default&fileviewer=file-view-default
<manumanumanu>pick and chose. don't mind the license.
<manumanumanu>(this channel is logged i suspect. you have my permission to do whatever you want with that source code).
<OrangeShark>hello everyone
<manumanumanu>ahoy
***chrislck1 is now known as chrislck
<roelj>Is it possible to get the symbol name from within a function? Like so: (define (test a b) (get-name-of-function)) => test
<spk121>roelj: maybe like this?
<spk121>(use-modules (system vm frame))
<spk121>(define (func x) (write (frame-procedure-name (stack-ref (make-stack #t) 1))))
<roelj>spk121: That is cool. Thanks!
<spk121>but it probably would be better to define your test func as some sort of syntax instead
<roelj>I solved it another way: (define (prefix uri) (lambda (suffix) (format #f "<~a~a>" uri suffix)))
<roelj>Then: (define hello (prefix "http://localhost/"))
<roelj>Which results in: (hello "world") => "<http://localhost/world>"
<roelj>So it doesn't actually look up the symbol name it's part of..
<spk121>That's much more practical.
<civodul>roelj: i'd suggest writing your own macro, like: (define-with-name the-name (proc a b) (pk the-name) (+ a b))
<buenouanq>ERROR: In procedure dynamic-link: file: "libpq", message: "file not found"
<buenouanq>does this look like a guixsd thing or something in guile-squee I need to change?
<spk121>buenouanq: make sure that the shared libraries you are using and *all their dependencies* are in expected places
<spk121>maybe set LD_LIBRARY_PATH
<spk121>If you can't figure it out, try running your command or whatever preceded by LD_DEBUG=all. And then somewhere near the bottom of all the spew it will tell you what the problem is.
<sirkmatija1>Hello, I am having some trouble with Guile 2.2.2 (ice-9 arrays) module. When trying to use it I get "ERROR: no code for module (ice-9 arrays)" error message. Can anyone help me? Thanks in advance
<Labu>Hello!
<djcb>WARNING: (guile-user): `<foo>' imported from both (oop goops) and (bar)
<djcb>^^^ Is that something I should worry about?
***guile-guest5 is now known as rcm
<rcm>Hi All. Once I've designe
<rcm>Oops. I meant to say: Hi all, I've been reading through the "guile fibers" documentation and playing around with the API. I remember the manual saying that fibers was inspired by CSP and concurrent ML. I'm not quite sure about how to convert a CSP design into fibers code
<rcm>does anyone have any experience with this?
<Labu>Hello I need to store some datas into database. I thought about sqlite. the only lib I found is guile-dbd-sqlite3. But repo doesn't be updated since 2014.
<Labu>Have you any advice about store data with guile in sql db or else ?
<amz3>Labu: they are other bindings for sqlite
<amz3>Labu: https://notabug.org/civodul/guile-sqlite3/
<Labu>thx amz3
<amz3>Labu: also I am the maintainer of guile wiredtiger if you feel like willing to adventure yourself outside the strict realm of SQL
<amz3> http://www.hyperdev.fr/projects/wiredtiger/
<Labu>thx I am looking
<amz3>Labu: do you use guix or guixsd?
<Labu>no I am on netbsd
<amz3>Labu: both guile-wiredtiger and wiredtiger are on guix
<amz3>ok
<Labu>I am going give a try to wiredtiger
<amz3>Labu: let me know what you think
<Labu>ok seems to be cool
<amz3>Labu: :)
<amz3>Labu: the code is @ https://framagit.org/a-guile-mind/guile-wiredtiger
<amz3>you can git clone https://framagit.org/a-guile-mind/guile-wiredtiger.git
<Labu>thx
<amz3>like it's explained it the "manual" from above
<Labu>the project page give a link to github did you migrate from to framagit .
<Labu>?
<amz3>there is three layers: 0) the raw wiredtiger bindings 1) a thin layer to make it bit more useable 2) some database abstrations like graph and "feature space" with microkanren querying
<amz3>Labu: that is a mistake
<Labu>ok
<amz3>Labu: the recent version is at framagit
<Labu>I didn't read until the end
<amz3>Labu: the documentation is not very good TBH
<Labu>no problem
<Labu>you have worked on berkeley db ?
<amz3>Labu: don't hesitate to ask question, right now I need to go, happy hacking
<Labu>ok thx for the share
<stis>hello guilers!
<OrangeShark>hello stis
<daviid>djcb: yes you should, definitely
<sneek>daviid, you have 5 messages.
<sneek>daviid, lloda says: g-wrap it's ok now, guile-config is not on my PATH, my complaint is that it shouldn't be required when pkg-config does the same
<sneek>daviid, lloda says: wrt guile-lib install location, I don't have a preference on the *default* install location, but when I override it with --prefix, that should be respected. I have several installs of Guile and it makes no sense to have to install libraries on each of them
<sneek>daviid, lloda says: my questions where about guile-cairo doc (not guile-gnome), where there are a couple of bugs that I can't fix b/c I cannot make the doc generation system work
<sneek>daviid, lloda says: I'm now in the guile-cairo group in savannah, so I pushed my patches here http://git.savannah.nongnu.org/cgit/guile-cairo.git/
<sneek>daviid, lloda says: bugs are in freedesktop.org here: https://bugs.freedesktop.org/buglist.cgi?quicksearch=guile-cairo
<daviid>lloda: g-wrap, not sure i agree with you: to me, it does make sence to make/compile/install g-wrap if g-wrap does not find guile-config, because it means it would not find guild, neither guile itself ... and not finding it is a recurrent ACLOCAL local config related problem ... that having guile.nm4 distributed with the lib/app concerned solves (and it deliver a better msg when guile is in fact not installed ...). what I can't figure
<daviid>out with your answer, is if you did pull and tried again, since I patched after you reported this in the first place ... I just want to confirm it does in fact solve the problem, for other uers, in the future ...
<daviid>lloda: guile-lib, I totally agree with you, it was a mistake on my side not to take that into account in the first place. Iwill try to fix this asap, but don't hold your breath ... :)
<daviid>lloda: guile-cairo doc: I thnk guile-cairo doc builder uses guile-gnome doc builder (it's a copy, it does not depend on guile-gnome), and guile-gnime doc builder also does not work either, this is what I meant to say ... so, if you fix it, please let me know, I could back-copy and try on guile-gnome ...
<daviid>lloda: very pleased you are in the guile-cairo savannah group, I have a 5 to 6y pending request :) ... you should release asap, the last tarball is 5 to 6y old and misses important patches for guile-clutter (among other thingd): this provides any distro to propose guile-clutter (except guix, because guixers are top notch hackers that can build from source ... and patch the autotoolchain, guix is a must ... but not everyone has guix ...
<daviid>I actually still don't have guix installed)
<daviid>ACTION hides
<buenouanq>DO IT
<buenouanq>it's the best
<Digit>last time i did, the process was fairly quick and painless, afaicr. been a while.
<daviid>lloda: when brwosing this exact address, https://bugs.freedesktop.org/buglist.cgi?quicksearch=guile-cairo I don't see your bug report, only the very old ones ... what am I doing wrong :)? (I'm such a pathetic web user ...)
<daviid>lloda: no big deal, I see the patch in savannah of course ... just curious
<daviid>lloda: in the first sentence I posted today, g-wrap ... I meant to write '... it does not make sence to make/install ...' (as you prob understood by yourself ...)
<daviid>djcb: I suggest you read this (and the rest of the thread) http://lists.gnu.org/archive/html/guile-user/2016-07/msg00089.html