IRC channel logs

2018-04-02.log

back to list of logs

<Labu>Hello
<amz3>Héllo all
<amz3>Héllo Labu
<OrangeShark>hello guile
***chrislck1 is now known as chrislck
<weirdlispalien>what should I read after SICP to learn more about scheme/guile? Like if I would want to create practical applications with scheme.
<OrangeShark>weirdlispalien: I don't think there is much to read if you are interested in learning more about creating practical applications.
<Labu>weirdlispalien: if you have some science background : Functional differential geometry. depends what kind of application
<Labu>weirdlispalien: start coding and read guile book
<chrislck>+1
<OrangeShark>would probably be nice to document the tools we use and how to use them
<weirdlispalien>are there really any other resources for guile other than the GNU guile manual?
<chrislck>if you understand guile is an implementation of scheme, there's incredible amounts of scheme resources available -htdp/sicp/tls are the core classics
<OrangeShark>weirdlispalien: there is some blogs here and there, but I am not aware of anything extensive.
<OrangeShark>chrislck: there is more than just the language
<void_pointer>there is also reading the R6RS standard and the SRFIs as well, or skimming for specific features you want to use
<void_pointer> http://www.r6rs.org/ and https://srfi.schemers.org/
<Labu>weirdlispalien: What kind of application do you want to make ?
<weirdlispalien>Labu: games, text editors, web servers, just general scripts for example
<chrislck>wow
<void_pointer>well, one good approach is to start with something small and reasonably self-contained, or can at least be reasonably self contained with a few core features and other stuff is just extra that can be added on
<void_pointer>small utility scripts or command line tools are always good candidates
<void_pointer>games, except at the very very small end (e.g. pong level), are not the best candidates for a first project in a language unless you essentially know a language and very closely related (e.g. if you already knew common lisp and some functional language well, doing a bit larger one as a first project in scheme could be approachable)
<void_pointer>would say that something similar applies to other sorts of project ideas
<void_pointer>to a lesser degree
<void_pointer>but not that much lesser
<Labu>weirdlispalien: web application (not server) is a easiest approch. Or general script.
<void_pointer>another one is to, if you have a larger project idea you want to eventually do that is missing a key small library, write said library with tests as a first project
<weirdlispalien>reading source code of software written in scheme would also be good practice, right?
<Labu>yes of course
<Labu>If you want make (little) games there is a SDL binding in guile
<weirdlispalien>if I would read some projects source code, where should I start reading?
<Labu>Try little lib there are a lot on github and savanah
<Labu>I don't know what is interesting you.
<spk121>As soon as I hook in Audio+Opus support, my ridiculous Guile-based Twine-like interactive fiction engine will be complete.
<spk121>I'm rather please how it is coming together.
<ArneBab>manumanumanu: wow, nice!
<manumanumanu>ArneBab: it was an ultimately pointless exercise though: it brings very little since the transducers are not integrated into the language. As it is now, they are only usable with lists, which means a named let is much faster and probably a much better choice (or better yet: use my racket-like for loops :D )
***francesco_ is now known as Franciman
<pmikkelsen>hi guilers, I want to try and write a simple compiler in guile scheme, do you know any reading material on this?
<spk121>pmikkelsen: there is this joke language called Brainfuck, that has only 8 instructions
<spk121>There's a wikipedia page for it.
<spk121>Anyway, there is an interpreter for it in the guile source tree under module/language/brainfuck
<spk121>you could start there
<ota>Spk121 +1
<ota>If there was ever a good use for brainfuck this may be it.
<ota>Tho, it's been years and years since I looked at it.
<spk121>ota: :)
<pmikkelsen>thanks!