IRC channel logs

2018-03-15.log

back to list of logs

<manumanumanu>Guten heute alle leute! How are we doing today?
<wingo>ACTION ported fibers to lua, woo
<civodul>woow :-)
<manumanumanu>now we only need to make guile-lua-rebirth run it!
<civodul>heheh, that'd be fun :-)
<manumanumanu>wingo: how did you do it? Curoutines i suspect?
<wingo>yeah coroutines
<wingo> https://github.com/snabbco/snabb/pull/1292
<wingo>a WIP...
<civodul>so you started working directly with coroutines and then felt that this wasn't as nice as CSP? :-)
<wingo>coroutines are insufficient :) you need a scheduler, channels, synchronization, etc
<wingo>coroutines are a building block like delimited continuations
<civodul>yeah i know, but i assume Lua users typically use them "directly" no?
<manumanumanu>I suspect however that coroutines, although not as general as delimited continuations, is faster.
<manumanumanu>continuation-based generators have quite a bit of overhead, no?
<manumanumanu>oh... you even wrote a blog about it :D :D
<manumanumanu>haha.
<wingo>civodul: dunno :) the snabb use case is a bit special; up to now we haven't used them at all
<wingo>but i was porting a tcp implementation and it turned out that you really want tcp endpoints to be implemented as fibers or processes or whatever and not state machines, so it seemed like a natural thing to port fibers over; seems to work but i haven't done any benchmarking yet
<civodul>interesting
<amz3>o/
<manumanumanu>ahoy hoy
<manumanumanu>so... about module versions... I am writing a pretty darn complete binding for libsodium, and I was wondering if I could use module versions to keep up with new specs.
<manumanumanu>I am currently pretty much feature complete for libsodium-1.0.16
<manumanumanu>but when libsodium-1.0.17 adds a feature, can I support both with the same codebase in any way?
<manumanumanu>you have got to be kidding. libsodium has a crypto_box function utilizing xchacha20poly1305, but it isn't effin documented.
<manumanumanu>jesus christ that was a waste of time on my behalf.
<manumanumanu>sad day.
<spk121>does anyone have a Guile solution to convert audio files to PCM bytevectors
<daviid>spk121: I don't know, but if something ever existed, it might be listed here http://sph.mn/c/view/g2
<spk121>daviid: cool library page
<daviid>spk121: yes, it's not mine, it's tantalum (that his/her name)