IRC channel logs

2018-03-07.log

back to list of logs

<spk121>exit
<drmeister>Hi - does guile have a DWARF interpreter built into it for debugging?
<lloda>daviid: haven't managed to build g-wrap yet. Can't say I've looked into it much, I just tried it once, it failed, I gave up.
<MaliRemorker>is the support for R6RS libraries broken in guile?
<MaliRemorker>i'm trying to evaluate (library (gimp) (export fun) (define (fun x) x))
<MaliRemorker>but this is not accepted by the interpreter
<MaliRemorker>i'm just looking at the code for the `library' macro in r6rs-libraries.scm. Whoever wrote that should get the Oscar for opaqueness. Syntax-case macros at their best! :D
<lloda>sneek: later tell MaliRemorker (library (gimp) (export fun) (import (rnrs)) (define (fun x) x)) works, apparently you can't skip the import form (haven't used r6rs much myself)
<sneek>Got it.
<OrangeShark>hello amz3, I saw your video on neon. Looks really cool.
<amz3>tx :)
<amz3>OrangeShark: the issue is that I have no long term plan
<amz3>OrangeShark: I could build a blog application on top of versioned database, but at the end of the day it looks overkill
<OrangeShark>amz3: is it because you need to find a useful application for it?
<amz3>OrangeShark: yes
<amz3>I need to find another use case
<amz3>I was thinking about a gitlab -like application for knowledge bases, but I have a difficult time to figure the ui
<OrangeShark>a sort of versioned knowledge base?
<amz3>yes
<amz3>like instead of code you have some kind of data .csv or something else
<amz3>like github or gitlab those are the same ideas
<amz3>I could show the data in tabular format or in a graph-like format that the two data viz i know about databases
<amz3>but graph is difficult
<amz3>let's go shopping!
<OrangeShark>visualizations can be pretty difficult
<OrangeShark>There is some ideas I wanted to pursue that might work with neon. I will post it later on the mailing list when I get the chance to.
<amz3>oh
***chris is now known as Guest41783
<daviid>lloda: you need to pass CFLAGS=-Wno-error=deprecated-declarations
<daviid>from the source, you'd do ./autogen.sh [--prefix=...] CFLAGS=-Wno-error=deprecated-declarations; make; make check
<daviid>if you use the tarball, ./configure [--prefix=...] CFLAGS=-Wno-error=deprecated-declarations
<daviid>lloda: that should solve your problem, let me know ...
<daviid>lloda: then if you have guile-cairo, which I beleive yu do, you can build guile-gnome [and guile-clutter, which is fun to use ...]
<daviid>lloda: wrt guile-cairo, where is your code hosted?
<spk121>So, I've been thinking a bit about a minimal GUI toolkit.
<spk121>I think it would be simple enough to bind Guile to GtkWebkit.
<spk121>And then express a scheme API for webkit and DOM.
<spk121>So you could have a local desktop application via HTML widgets.
<spk121>Without having to finish gobject for guile or bind all of GTK3
<civodul>spk121: there have been experiments in that direction
<civodul>like the Kawa person wrote a terminal emulator like this
<civodul>Hop also pretty much started around that idea
<civodul>somehow i remain skeptical about the idea of using "the browser" for everything
<spk121>civodul: Yeah. I'm not a huge fan of HTML DOM. But as the kids say, it would be a "minimum viable product"
<civodul>heh :-)
<spk121>7ik654r76yer