IRC channel logs

2018-02-23.log

back to list of logs

<ym>As I understand, Guile differs from Common Lisp mainly in Lisp-1 vs Lisp-2 namespaces (and better way of writing higher order functions consequently) and macro system. Seems like it's quite simple to add CL support to Guiles VM, isn't it? I'm not sure I'm qualified enough to support such complicated project, but I'm highly interested in the subject, so is Common Lisp support planned at least?
<OrangeShark>ym: not that I know of. You might want to check out Guile's emacs lisp support
***holomorph is now known as ammo
<chrislck>another question about sxpath - (xml->sxml "<a></a><b></b>") only produces (*TOP (a)) - how do I make it produce (*TOP* (a) (b))
<chrislck>the other way (sxml->xml '(*TOP* (a) (b))) does produce "<a></a><b></b>" as I expect
<chrislck>in other words xml->sxml seems to only parse the first root element
<amz3>chrislck: I think all xml parsers work like that
<amz3>chrislck: it's not possible AFAIK to do what you want
<chrislck>amz3: thank you as it turns out the XML generator was broken and was lacking the overarching root element.
<amz3>ok
<amz3>yw
<amz3>I am trying to implement the query optimizer for sparql, reading through the literature is hard, I guess I will take a shot at my own optimization startegy first and then go through the literature again
<amz3>also, being standard compliant is hard
<amz3>I am at the very start of my journey
<OrangeShark>hello
<amz3>héllo OrangeShark
<amz3>scheme makes the news via the opencog project that use guile https://www.cbronline.com/list/top-5-open-source-projects-2018
<amz3>they do not cite GNU Guile but scheme
<terpri>ym, i'd like to see cl support in guile someday. it would be a tremendous task to implement it fully, though
<terpri>the elisp compiler shows that lisp-2 support is possible, but guile elisp defines around 100 symbols, vs around 1000 in cl
<stis>The question is if one can define a core language and then use that + already made cl code to create the rest of the 1000 symbols
<stis>How big is the core language? and where can we steel the cl implementations of the rest of the symbols
<stis>FYi I have a full tagbody implementation in guile
<stis>slow but featrure complete
<stis>I also have an implementation of CL's loop macro
<terpri>i know of http://home.pipeline.com/~hbaker1/MetaCircular.html which discusses special forms... also some of https://github.com/robert-strandh/SICL may be usable
<terpri>kent pitman wrote a prototype for a lisp dialect where lisp-1 and lisp-2 environments could coexist: http://www.nhplace.com/kent/Half-Baked/index-spiel.html
***siel_ is now known as siel
<janneke>how do i display binary data to current-output-port?
<janneke>this works: (display binary-data (open-output-file "/dev/stdout" #:binary #t))
<amz3>sorry, idk, keep it steady nonetheless ;)
***rubdos_ is now known as rubdos
<spk121>janneke: did you figure out the binary output? it is 'put-bytevector'
<janneke>spk121: thanks...but oh wow; now it looks like
<janneke>((compose (cut put-bytevector (current-output-port) <>) (cut string->bytevector <> "ISO-8859-1")) "binary-data")
<janneke>i was hoping for something simpler than my hack:
<janneke> (display binary-data (open-output-file "/dev/stdout" #:binary #t))
<spk121>janneke: if all you really want to do is put binary output over stdout, you can set the output encoding to iso-8859-1
<spk121>(set-port-encoding! (current-output-port) "ISO-8859-1")
<janneke>spk121: yeah...that does not seem to work somehow
<janneke>i seemed to remember that, so i need to find what's wrong on my side/create a bug report
<janneke>spk121: thanks!
<spk121>but then, of course, if your terminal emulator is utf8, the terminal emulator will not be happy
<janneke>spk121: :-) it's for pipeline code in gash, and tools that pipe binary data
<amz3>what is gash?
<janneke>amz3: https://gitlab.com/rutger.van.beusekom/gash