IRC channel logs

2018-02-20.log

back to list of logs

<chrislck>maybe someone here knows, is there any reason travis-ubuntu would fail when guile 2.0 complains that "no code for module" (srfi srfi-64) ? Is srfi-64 an optional compile for guile2.0?
<amz3>chrislck: are you running the tests in parallel?
<amz3>that might be the issue
<amz3>I think there is a race condition upon compilation of module, but you are right, the module should already be compiled
<OrangeShark>chrislck: do you mean travis CI?
<OrangeShark>chrislck: srfi-64 was introduced in Guile 2.0.10. Travis CI with Ubuntu trusty has version 2.0.9
<chrislck>Orange: oh, what a pain
<manumanumanu>Good morning guilers!
<ayys>when using the random function from the interpreter, I get a random number every time. But when I use it in a script, I get the same result every time. Here is a snippet of the code I am using in the script. https://paste.debian.net/1011111/
<ayys>Is the function being compiled before runtime?
***ayys_ is now known as ayys
<chrislck>Been checking macros and - there seems to be a way to access the (current-source-location) - but it tells me the location of the (current-source-location) rather than the macro-caller. What am I doing wrong?
<chrislck>(define-macro (something stx)
<chrislck> (format #t "~a" (current-source-location)))
<chrislck>ok this needs quoting
<OrangeShark>ayys: have you looked at the manual? https://www.gnu.org/software/guile/manual/html_node/Random.html
<OrangeShark>specifically "Note that the initial value of *random-state* is the same every time Guile starts up."
<OrangeShark>it also mentions how to change *random-state*
<dsmith-work>Hey Hi Howdy, Guilers
<amz3>o/
<manumanumanu>ahoy hoy!
<OrangeShark>hello