IRC channel logs

2018-02-16.log

back to list of logs

<peepsalot>hello, i just git cloned stable-2.2 branch and the readme says "Generic instructions for configuring and compiling Guile can be found
<peepsalot>in the INSTALL file."
<peepsalot>my question is, what INSTALL file? it doesn't seem to exist?
<daviid>peepsalot: you need to run /autogen.sh first, this file is created
<daviid>what distro are you running?
<peepsalot>linux mint 18.3 (based on ubuntu 16.04)
<daviid>is gle not available there?
<daviid>*guile
<peepsalot>guile 2.2 is not available through package manager until ubuntu 18.04 comes out
<daviid>peepsalot: ok, it's easy anyway: ./autogen.sh; ./configure [--prefix=...]; make
<daviid>you're on your own for dependencies though, carefully read the output of the configure step ...
<peepsalot>looks like dependecies are ok as far as I can tell. waiting for make to complete...
<peepsalot>thanks daviid
<daviid>peepsalot: be prepared to be patient as well, compiling from the source can take quite some time, depending on the power you have of course, but on a medium laptop, ut to few hours ...
<daviid>wc!
<peepsalot>well, my laptop is pretty hardcore :D
<rlb>peepsalot: and "make -j 4" or whatever will help some, but there are a few files that are a bottleneck. And if you get the upstream .tar.gz it'll be *much* faster than building from a git checkout.
<rlb>(because the tar file includes prebuilt bootstrap files)
<peepsalot>looks like make failed on makeinfo which is not on my system. don't know what package it would be in
<peepsalot>ok, its called texinfo
<peepsalot>and yeah, rlb i ran make -j10
<peepsalot>looks like it succeeded
<peepsalot>it would be nice to also list that dependency in the README
<peepsalot>i'm trying the tar.gz now. i didn't know it is partly prebuilt
<peepsalot>hey, done in about 4.5 minutes, much better
<peepsalot>i guess texinfo also isn't needed if you build it from the tar.gz?
<daviid>peepsalot: it's texinfo yes, it won't cost anything you install it, goahead ...
<daviid>it's needed to build the doc locally anyway, and it is really recommended you do that (make install-html (or info, pdf ...)
<daviid>peepsalot: you'll spend quite a good amount of time in the doc anyway, so better have it locally, so when you are in the woods ... you still can guile :)
<lispmacs`>hi, if I have, e.g., a (vec2 10.0 20.0) in a body of a procedure, is there something I can do to prevent that from being reallocated every time procedure is called? I could use global var, yes, but that looks a little messy I'm thinking
<rlb>lispmacs`: depending on what you need, you could also use a closure (let [x (vec ...)] (define (foo ...) ...use x here...))
<lloda>lispmacs`: if the vector is constant you can write #(10.0 20.0) and the compiler will make it static
<dsmith-work>Happy Friday, Guilers!!
<dsmith-work>sneek: botsnack
<sneek>:)
<dsmith-work>good bot