IRC channel logs

2018-01-11.log

back to list of logs

<amz3>o/
<ZombieChicken>Trying to get termbox.scm working and I'm getting an error "no code for module (bytestructures guile)". Where might I find that module?
<ZombieChicken>First time trying to handle this kind of thing, so I'm a bit lost overall
<ZombieChicken>nvm. Think I found it. Now to just get it working...
<ZombieChicken>Okay, so I'm lost. Seems termbox.scm isn't loading, and I'm not sure why: http://dpaste.com/1WP53CK.txt <- source http://dpaste.com/140711A.txt <- error
<ZombieChicken>termbox.scm is sitting in the same dir as term-test.scm and i'm starting it with "guile -L ~/path/to/bytestructures term-test.scm"
<manumanumanu>Good morning everyone
<amz3>ZombieChicken: you need to install termbox library too
<amz3> https://github.com/nsf/termbox
<amz3>sorry the README is very poor
<ZombieChicken>It is installed
<ZombieChicken>Hrm. Ran "LD_PRELOAD=/usr/local/lib64/libtermbox.so guile ..." and now I'm getting this error http://dpaste.com/0GNVEM1.txt
<ZombieChicken>Not sure why it didn't automatically look there, but oh well
<amz3>ZombieChicken: are you using guix's guile?
<ZombieChicken>No
<ZombieChicken>Gentoo's. version 2.2.3
<amz3>ZombieChicken: run you script with, guile -L path/to/where/is/termbox.scm term-test.scm
<amz3>-L will add the path to GUILE_LOAD_PATH
<ZombieChicken>Same error
<amz3>what command do you use to execute your term-test.scm ?
<ZombieChicken>okay, I had changed something in term-text.scm (s/load/module-load/ or something) and swapped it back. Now I'm getting "ERROR: In prodecure primative-load: In procedure fport_read: Is a directory"
<amz3>-L value must be directory
<amz3>if you create term-test.scm inside azul.scm repository, you need to do something like: guile -L . term-text.scm
<amz3>with LD_PRELOAD
<amz3>in front if it's required
<ZombieChicken>okay, so I'm calling the script with "LD_PRELOAD=path/to/lib guile -L ~/path/to/scheme-bytestructures/ -L . term-test.scm", and am now getting "/path/to/term-test.scm:1:0: In prodecure module-lookup: Unbound variable: tb-init
<ZombieChicken>the (load ...) is (load "termbox.scm"), but otherwise it's the same as previously posted
<amz3>it's not (load ...) but (use-modules ((termbox))
<ZombieChicken>Well, now it's garbling my screen, which I think is a Good Thing right now
<ZombieChicken>Thanks
<amz3>;)
<amz3>:)
***mario-go` is now known as mario-goulart`
***mario-goulart` is now known as mario-goulart
<dsmith-work>{appropriate time} Greetings, Guilers
<amz3>o/
<amz3>ZombieChicken: does it work?
<ZombieChicken>amz3: Yeah, I got it to work
<ZombieChicken>Once I got a garbled screen, I knew it was working
<ZombieChicken>Now I'm just messing with it
<amz3>:)
<amz3>ZombieChicken: I did not tell you previously but there is a fork of termbox with true color support ie. 24 bits colors ie. good colors let me know if you need it
<ArneBab_>daviid: there are now scheme versions of all examples, you’ll need to test them, though (I only did the automatic conversion, didn’t have the time to check whether they actually work): http://bitbucket.org/ArneBab/wisp/src/tip/examples ?
<ArneBab_>daviid: but they should work - each which doesn’t exposes a corner case I missed.
<OrangeShark>hello everyone
<ArneBab_>Hi OrangeShark
<daviid>ArneBab_: nice, thanks, I'll look at them again
<ArneBab_>daviid: have fun! ☺
<ZombieChicken>amz3: Go ahead and link me, though I don't think I'll need it
<amz3>ZombieChicken: it's in the PR of nsf's repository: https://github.com/nsf/termbox/pull/104
<ZombieChicken>amz3: ty