IRC channel logs

2017-12-22.log

back to list of logs

<mwette>daviid: thanks. I read through some of the docs. They base it on the interface to the llvm compiler collection, so dependence on llvm.
<mwette>and it handles C++ for which I don't see much hope for now. It has whiteligsting and blacklisting which my ffi-helper can deal with in other ways (i.e., using the decl-filter option).
<daviid>mwette: I was just trying to help, no making any comparuson myself
<daviid>even if this other lib (rust based) just prove your approach is better, this, is already good :)
<daviid>it is terrible we don't have lisppaste anymore
<mwette>daviid: much thanks for the link. What is lisppaste? You can go to paste.debian.net and set lang to lisp I believe.
<daviid>mwette: http://paste.lisp.org/ Due to continued abuse, this service has been disabled
<daviid>yes debian paste, but I prefered lisppaste...
<daviid>any latex guru here? #latex is asleep, or nobody can help, don't know, but it'sbeen two days I can't find a solution to my problem, here is the problem:
<daviid> https://paste.debian.net/1001898/
<daviid>in the above example, replace the image with any image you have on yur computer, then try to comile (pdflatex ...) and you see that the text aside the image is not vertically centered
<daviid>sorry for this OT quiz, just in case some one would have, like i regurlaly do, produce report in latex generted by gule of course ...
<daviid>how to verticallt center a text of a table column, when all neighbors are images is the quiz...
<mwette>daviid: did you try adding \\vfill above and/or below ?
<mwette>anyone know how to interpret this error message:
<mwette>ERROR: Wrong type (expecting md-edes-t): #<md-edes-t 110b0d660>
<mwette>
<mwette>static SCM
<mwette>scm_des_id(SCM _des)
<mwette>{
<mwette> md_edes_t *des;
<mwette> scm_assert_foreign_object_type(edes_type, _des);
<mwette> des = scm_foreign_object_ref(_des, 0);
<mwette> return cnvt_md_to_scm(des->id);
<mwette>}
<mwette>never mind -- somehow working now
<civodul> https://lwn.net/SubscriberLink/741176/a1fa9a530fd434ce/ <- on locale-dependent string decoding in Python 3
<civodul>the same kind of issue that we have in Guile 2.x
<civodul>perhaps worth a look
<dsmith>sneek: botsnack
<sneek>:)
<dsmith>Yey
<dsmith>Howdy Guilers!
<jlicht>hey dsmith
<mwette>hi all
<davexunit>is there any way to turn auto compilation off when using guile in a script with a shebang like `#!/usr/bin/env guile`?
<jlicht>davexunit: Unless guile has some special provisions for this, no
<jlicht>at least not a flag in the shebang line
<davexunit>I thought guile did have some special provisions
<davexunit>but it seems they all fail in this case
<ft>Can't you use --no-auto-compile with the script-header approach from the manual?
<davexunit>no
<davexunit>it only works if you refer to a guile binary specifically
<davexunit>like #!/usr/bin/guile
<ft>Interesting. No idea then.
<davexunit>I was hoping guile had some other workaround to deal with this
<davexunit>yeah I think I'm screwed here.
<davexunit>oh wait
<davexunit>found something I overlooked in the manual
<ft>The -s switch?
<ft>It was -s wasn't it?
<davexunit>that was part of it
<davexunit>but you can't just do #!/usr/bin/env guile -s
<ft>That and the #! ... !#
<davexunit>you have to do #!/usr/bin/env sh
<ft>with additional lines? :)
<ft>oh
<ft>Ah, I see. Okay.
<davexunit>after the shebang line I have `exec guile --no-auto-compile -s "$0" "$@"`
<davexunit>ugly, but effective
<davexunit>the --no-auto-compile is actually redundant
<davexunit>just -s is fine
<davexunit>nvm it is necessary. :)
<davexunit>I'm all over the place today
<jlicht>btw, why is --no-auto-compile desirable?
<davexunit>so you don't get the auto compilation text every time you run it
<davexunit>and since it's a script it's really not something that needs compiling
<mwette>what about this:
<mwette>#!/bin/sh
<mwette>GUILE_AUTO_COMPILE=0
<mwette>export GUILE_AUTO_COMPILE
<mwette>exec guile -s $0 $@
<mwette>!#
<mwette>(simple-format #t "~S\\n" (program-arguments))
<davexunit>accomplishes the same task
<davexunit>just more typing
<daviid>hello guilers!
<daviid>mwette: \\vfill is not allowed in tabular[x], afaict, it raises an exception, and \\vspace*{\\fill} is 'accepted' but does not produce any results, but tx
<mwette>daviid: i googled and found this: https://tex.stackexchange.com/questions/30551/centering-mutirow-text-in-a-table-whose-cells-contain-several-lines-of-text
<daviid>mwette: yes, but, the quiz is when all other column but the first contain images, none of these approach that work with text 'only' table work
<mwette>that sucks -- sorry
<daviid>mwette: yeah, so far I'm stuck! funny, as if no one as ever tried this before, which is a bit hard to believe :), give latex is an old lady
<mwette>daviid: but still awesome. MS Word is such a PoS.
<daviid>mwette: i've never used anything else then latex actually :)