IRC channel logs

2017-12-07.log

back to list of logs

<roelj>If I have a script, say, "test-guile-prog", can I then get the absolute path to this script within the script? Kind of like (getcwd), but then for the location of the script.
<roelj>I now use a function that either returns the path when (car (command-line)) is absolute-file-name?, and otherwise concatenates (getcwd) and (car (command-line)). The only downside is that a ./ and a ../ are not processed.
<civodul>roelj: overall there's no portable way to do this
<civodul>however, if you're on GNU/Linux, you can readlink /proc/self/exe
<civodul>well actually that'd give you the file name of guile, not that of the script
<civodul>maybe (canonicalize-path (car (command-line))) would be a good approximation?
<roelj>civodul: Yes, canonicalize-path is what I'm looking for. Thanks!
<civodul>yw!
<numerobis>Hi #guile! Is it possible to know in which directory/path a module is defined? On my machine, 'ssh me@localhost 'echo $GUILE_LOAD_[COMPILED_]PATH' and 'echo $GUILE_LOAD_[COMPILED_]PATH' produce exactly the same result, but 'guile -c '(use-modules (guix config))'' works while 'ssh me@localhost guile -c "'(use-modules (guix config)'"' fails with 'ERROR: no code for module (guix config)'. Any idea why this
<numerobis>happens? (My goal is to offload 'guix build' to another machine)
<roelj>How would I "fire and forget" a thread in Guile?
<roelj>I just want to do a (system ...) without waiting for its completion from the main thread.
<roelj>Oh, nevermind. call-with-new-thread does exactly this.
<dsmith-work>Thursday Greetings, Guilers
<webshinra> https://framapic.org/CiPYzf5MeD9N/5uY00hFSHgVz.jpg I speak about it some time ago, here is the quasi-final version
<christopher74837>hi, I'm trying to compile guile git, but i receive configure error message "required guile module not found: (bytestructures guile)
<christopher74837>i have bytestructures installed at /usr/local/lib/guile/2.2/site-ccache
<christopher74837>but if I tried GUILE_LOAD_PATH=/usr/local/lib/guile/2.2/site-ccache ./configure, the error still appears
<christopher74837>hmm, trying from guile interpreter, I get message "no code for module (bytestructures r6 bytevectors)
<christopher74837>must need an earlier version of bytestructures
<christopher74837>no, seems there is missing .scm file for r6 directory
<bavier>christopher74837: could you open an issue for that?
<kristofer>hello!
<kristofer>I need some help trying to read POST data from a request
<kristofer>nevermind, I didn't do enough research
<christopher74837>is guix-0.14 dependent on a certain version of libgcrypt?