IRC channel logs

2017-12-05.log

back to list of logs

<dsmith-work>jeko: Just to be sure you understand. cybo should NOT be in the load path. The directory cybo is in must be in the load path.
<dsmith-work>So /usr/foo not /usr/foo/cybo
<jeko>Ok, so my cybo dir is in ~/Workspace
<jeko>I did export GUILE_LOAD_PATH=".:...:~/Workspace"
<daviid>jeko, this won't work guile does not exapnd filenames
<daviid>jelo you must pass the full dirname
<jeko>hmm I am too confused right know lol I think I will manage dependancies using (load) in my .scm files
<daviid>jeko: it is not that difficult, keep trying :) pena terminal and cd ~/Worspace, the pwd
<jeko>and just (define-module (todo-txt))
<daviid>that is the path you must add to GUILE_LOAD_PATH ..
<jeko>Oh when you said guile doesn't expand filenames, you where talking about the ~ replacing the /home/jeko ?
<daviid>jeko, if you are serious about guile, you really want to pend some time right at the begining to understand this
<daviid>jeko, yes, you have to pass full directory name, no ~
<jeko>Okkkk
<daviid>jeko did you reaad the manual abut this? I recommend you read that part of the manual very carefully
<jeko>I read the Load Path chapter, the Environment Variables, but I surely have issues with technical english... need more time to write it in my brain.
<daviid>ok, good did it work now?
<daviid>jeko, you can use add-to-load-path as well and you can check asking the value of the variable %load-path
<dsmith-work>jeko: https://www.gnu.org/software/guile/manual/guile.html#Modules-and-the-File-System
<jeko>god it worked
<daviid>jeko perfect!
<dsmith-work>yey!
<jeko>thank you both of you
<str1ngs>daviid: off topic % in %load-path what meaning does that have?
<daviid>str1ngs: it is generally a convention for internal vars and procedures, but there is no strict semantic
<jeko>I can know go to bed ^^"
<jeko>++
<daviid>good dreams then :)
<str1ngs>daviid: I took it as global variable. but I could not find documentation on it
<dsmith-work>The %foo convention predates modules I think.
<str1ngs>ah that makes sense
<daviid>str1ngs: global vars are generally named *, like *foo*
<str1ngs>as long as I know it's convention, vs syntax
<dsmith-work>Yep. Just a convention
<str1ngs>#' confused me for sometime aswell
<str1ngs>wait guile scheme has #' right?
<str1ngs>function qoute
<OrangeShark>str1ngs: no, guile doesn't have that
<str1ngs>I'm confusing elisp sorry
<dsmith-work> http://community.schemewiki.org/?variable-naming-convention
<str1ngs>its #: I was thinking of for guile scheme
<str1ngs>#: is named argument?
<daviid>OrangeShark: it has yes
<daviid>#'identity
<daviid>$2 = #<syntax identity>
<daviid>scheme@(guile-user)>
<OrangeShark>daviid: oh I was not aware of that
<str1ngs>daviid: it's related to byte completion?
<str1ngs>compilation*
<daviid>afaict it's unused in scheme because you can 'type' the procedure ame directly, unlike in lis iirc
<dsmith-work> https://www.gnu.org/software/guile/manual/guile.html#index-with_002dsyntax
<OrangeShark>so it not the same as the function quote found in elisp and common lisp
<OrangeShark>but (syntax identity)
<dsmith-work>Also https://www.gnu.org/software/guile/manual/guile.html#index-syntax
<daviid>it is not thesame thing no
<dsmith-work>The ` , ,@ reader macros have similar #` #, #,@ for use in macros.
<str1ngs>oh #' is a reader macro
<dsmith-work>Man. Been a while since I thought about this stuff. Hope I'm getting it right!
<dsmith-work>Too much C and Python lately for me
<str1ngs>in elisp #' does function name lookup during byte compilation essentially it quotes the function though. I got the two confused
<str1ngs>nope I have it wrong.
<str1ngs>I'm confused haha
<str1ngs>#' = (syntax foo) right?
<str1ngs>err #'foo = (syntax foo)
<dsmith-work>Yeah.
<str1ngs>ok thanks
<str1ngs>sorry I got things side tracked there.
<dsmith-work>Yeah, emacs lisp like CL have different name spaces for functions and variables.
<str1ngs>I personally like guile modules
<dsmith-work>So you need two different quotes.
<str1ngs>so in guile scheme variables and functions exist in the same name space. I guess as types?
<dsmith-work>str1ngs: So ((if x + *) 3 4) is 7 or 12 depending on x
<str1ngs>ah that interesting. took me while to grok what was going on there
<dsmith-work>str1ngs: I think that's probably something like ((if x #'+ #'*) 3 4) in elisp/CL, but I'm not sure.
<dsmith-work>Nah. Ah well.
<str1ngs>syntax macros I still do not understand yet. I need research them more
<dsmith-work>str1ngs: syntax-rules macros are simple and beautifuly elegant.
<dsmith-work>ACTION heads out ..
<dsmith-work>Morning Greetings, Guilers
<ftknox>dsmith-work: Good morning
<amz3>hi dsmith
<dhamidi>what is the recommended way to set up a new scheme-only project with guix as a package manager and without having to use autotools?
<OrangeShark>dhamidi: using autotools makes it easier when using guix as you can just use the gnu build system
<dhamidi>wingo mentioned a "guile-build-system" herer https://lists.gnu.org/archive/html/guile-user/2017-03/msg00168.html
<dhamidi>has somebody written that build system already?
<dhamidi>didn't find anything in the guix source tree, but maybe that was the wrong place to go looking for it
<amz3>dhamidi: they are examples of guix recipes for pure guile project, have a look at guile-bytestructures for instance
<dhamidi>sorry, I couldn't find a link after some googling
<mistnim>daviid: I read your answer, I'm actually in the right directory
<sneek>Welcome back mistnim, you have 2 messages.
<sneek>mistnim, daviid` says: actually, I recommend you to keep guix and remove the guile version you have on you debian, then try again ... be sure to purge guile, not just uninstall it: 'aptitude purge guile'
<sneek>mistnim, daviid` says: the guix approach is alot safer i the long run, and worth spend some time to make it work now ... also becuse the team is working on a new release, and that will hold the latest guile stable-2.2, which will boost your guile-cv experience by a couple of order of magnitudes
<mistnim>I had made sure of that
<civodul>the ABI of (web uri) in 2.2.3 is incompatible with that in 2.2.2: https://bugs.gnu.org/29570
<civodul>not sure how to work around that
<dsmith-work>civodul: Maybe the same way wingo turned (load) into a macro?
<civodul>i think 'load' has been a macro since 2.0.0 no?
<civodul>or thereabouts
<dsmith-work>yes. But he contrived it so you can pass it as a function.
<civodul>yeah
<daviid>sneek: later tell mistmim it is impossible :), you think you are in the right directory, but most likely you are not. run (getcwd) and compare, then run (system "ls") .. till you are convinced this is the source of your problem (or proved me wrong, then I'll pay a pacj ok beers :)
<sneek>Okay.
<daviid>sneek: later tell mistmim did you run make check? did all check pass? because it checks if im-load works fine ...
<sneek>Okay.
<dustyweb>beep
<daviid>hello dustyweb!
<dustyweb>hi daviid
<amz3>sneek: later tell dhamidi use 'guix edit guile-bytestructures'
<sneek>Will do.
<amz3>o/