IRC channel logs

2017-11-29.log

back to list of logs

<happy_gnu[m]>hello
<happy_gnu[m]>when I do
<happy_gnu[m]>(http-get some-url)
<happy_gnu[m]>if I call it in the REPL I get headers and body
<happy_gnu[m]>(I am trying to do an IRC bot with 8sync, that will look up at a wikipedia page, when you tell the bot to, with something like "irc-bot: wikipedia gnu" and the bot will look at that wikipedia page using wikimedia API, get the xml and give me the first paragraph or something)
<happy_gnu[m]>So I am trying to use http-get to get the xml as indicated by wikimedia API, (http-get some-url) works from RELP and gives me all the xml and headers, but if I try to define it, I only get headers
<happy_gnu[m]>I was suggested to use (call-with values (http-get ....)) but is not good either
<happy_gnu[m]>if I do (define text (http-get some-url)) I get headers and then it says port was closed
<happy_gnu[m]>port: #<closed: string 1add2a0>>
<happy_gnu[m]>how can I get the xml or json outside the REPL and put it in a definiton or a file or something else ?
<happy_gnu[m]>here is an example webpage I am trying to get
<happy_gnu[m]> https://en.wikipedia.org/w/api.php?action=query&titles=Linux&prop=revisions&rvprop=content&format=xml
<sirgazil>happy_gnu[m]: Maybe try receive: https://paste.gnome.org/ppwdp6kvr
<sirgazil>happy_gnu[m]: See section 6.13.7 Returning and Accepting Multiple Values in the manual for more info.
<str1ngs> /msg nicserv help
<str1ngs>opps
<amz3>héllo #guile
<OrangeShark>hello amz3
<dsmith-work>Wednesday Greetings, Guilers
<dsmith-work>sneek: botsnack
<sneek>:)
<bavier>hi dsmith-work
<amz3>hi
<OrangeShark>I want to get better at using emacs
<OrangeShark>was reading some of the emacs source code, it actually looks pretty similar to libguile
<ArneBab_>OrangeShark: do you know emacs rocks and mastering emacs? http://emacsrocks.com/ https://www.masteringemacs.org/
<OrangeShark>ArneBab_: I bought mastering emacs on Monday and started reading it :)
<ArneBab_>nice! happy hacking then :)
<OrangeShark>ArneBab_: thanks :)
<happy_gnu[m]>sirgazil: hi!!
<happy_gnu[m]>thank you so much :)
<happy_gnu[m]>bot is working now!!
<sirgazil>Yay! :)
<happy_gnu[m]>it needs to be polished though, but it answers now :D
<happy_gnu[m]>you can talk with puppy-bot on #lgn
<happy_gnu[m]>if you want to try it :D
<sirgazil>Let's see...
<sirgazil>happy_gnu[m]: The puppy just pee on my shoes :)
<happy_gnu[m]>sirgazil: si es mala nvidia :/
<happy_gnu[m]>sirgazil: sorry I had a little problem at home :)
<happy_gnu[m]>we are playing warzone 2010
<happy_gnu[m]>2100*
<happy_gnu[m]>sirgazil: muchas gracias de verdad :D
<sirgazil>happy_gnu[m]: con mucho susto :D
<rekado>OrangeShark: mastering emacs is very good. I wished I had it on my first two attempts to get started with Emacs.