IRC channel logs

2017-11-22.log

back to list of logs

<lloda>sneek: later tell daviid something like this, not tested https://paste.debian.net/996997/
<sneek>Got it.
<lloda>sneek: later tell daviid might need to declare channels as void* and cast it
<sneek>Okay.
<lloda>sneek: later tell daviid it's kind of weird to mix the ffi and oldschool libguile like this, if you're writing the C I'd declare all the C args as SCM and do the conversions on that side
<sneek>Got it.
<lloda>by the way in all the scm_kind_of_vector_elements calls, the incp parameter is always 1, it's compatibility cruft. For general array there's scm_array_handle_f32_elements and scm_array_handle_dims instead
<lloda>there's no reason for the scm_kind_of_vector_elements functions to write an array handle, either
<lloda>some rename-and-deprecation is needed there :-\\
<brendyn>how can i write the output of ,trace ... to a file?
<Walakea>does guile scheme have multiple dispatch?
<civodul>Wla
<civodul>argh
<rekado>on the topic of bug #29258: is there someone who cannot reproduce this with Guile 2.2.2?
<thomassgn>what's the difference between the #:use-module (module) that follows (define-module and calling (use-modules (module)) ? It doesn't look like it matters which I use from reading the manual.
<thomassgn>additionally, how can I make emacs/geiser understand where my guile modules are installed?
<thomassgn>(I should probably search for the last before asking)
<civodul>rekado: i saw something similar while playing with guile-debbugs the other day
<civodul>on 2.2.2
<civodul>i suspect a TLS parameter issue
<civodul>(guix build download) has many tweaks
<thomassgn>it seems putting (add-to-load-path "...") in the file and evaluating it in geiser does the trick. It would be nice to not need this to be evaluated, but it's a simple solution for now... :)
<atheia>Hello
<atheia>I'm using (www client) to make a request to a https server.
<atheia>Unfortunately it does not close the TLS socket properly.
<atheia>The make-request procedure throws to GNUTLS error of that type
<atheia>Does anyone here know of a way to ignore the error and still get the contents of the response?
<janneke>hey mwette...i just tried to inject the textual-ports bit from d33dc6a2 onto nyacc master...
<janneke>but i failed; it looks OK for simple .c files but breaks with tcc.c
<janneke>[scm-error misc-error #f "~A" ("bad escape sequence") #f]
<janneke>i see lots of guile1.8 work which is great! :-)
<mwette>I had bug adding \\b for 1.8. Let me push, but other changes coming: I am trying to eliminate sxml-match; replacing with my own sx-match
<OrangeShark>thomassgn: geiser has a command `geiser-add-to-load-path` which you can do to add a path. There is also a variable `geiser-guile-load-path`.
<janneke>mwette: amazing!
<janneke>i am prototyping the full source bootstrap in Guix packages and just switched from depending on guile-2.2 to guile-2.0 ... and nyacc broke for me ;-)
<thomassgn>OrangeShark: Nice, thanks.
<mwette>OrangeShark: thanks
<OrangeShark>thomassgn: you can probably use a directory level variable in emacs so it loads up when you are in that project's directory. Look up .dir-locals.el
<mwette>janneke: I have pushed my c99dev stuff. and i'm running the tests against guile20
<mwette>I get: pprint.scm:106:28: warning: possibly unbound variable `#{\\\\#space}#'
<mwette>so hang on
<janneke>mwette: thanks for the headsup
<mwette>all tests pass now; and pushed upstream
<janneke>ACTION is creating necessary binary seed for tinycc to be able to attempt compiling gcc
<janneke>mwette: amazing, thanks!
<amz3>héllo all
<OrangeShark>hello amz3
<amz3>I restarted my work on the search engine, I have new ideas
<OrangeShark>amz3: what new ideas do you have for your search engine?
<amz3>it's mainly about the implementation of the scoring function which was wrong
<amz3>I use TF-IDF
<amz3> https://en.wikipedia.org/wiki/Tf%E2%80%93idf
<amz3>also the search/vm function was not scaling with the size of the index
<mwette>janneke: still finding some minor 18 incompatibilities -- fixing
<janneke>mwette: thanks again!
<amz3>basically, it required to load all uid of documents that match two keywords to do the intersection
<amz3>which is slow and not memory efficient
<amz3>now what I will do, is that I will compute the most discrimnent keyword in the search query based on term document frequency, fetch all the uids and then filter each documents based on the search query
<amz3>I should read how lucene does that actually, but I am lazy
<amz3>this takes the assumtion that looking in all text of the documents that match the discriminent is faster that doing intersection between massive list of non sorted integers
<amz3>it's just a guess
<amz3>well, I look at how lucene does keyword matching because I don't want to rewrite that a fourth time
<amz3>interesting article about code ux https://blog.keras.io/user-experience-design-for-apis.html
<amz3>interesting article about code ux https://blog.keras.io/user-experience-design-for-apis.html
<amz3>daviid: what are you doing with guile-cv?
<mwette>ACTION has cleaned up the c99dev branch of nyacc and pushed upstream
<delmarre>hello
***bairui_ is now known as bairui