IRC channel logs

2017-11-17.log

back to list of logs

<ays>I am just messing around with guile and I was wondering, how can I import a bunch of functions from a file?
<davexunit>ays: use-modules
<davexunit>for example (use-modules (srfi srfi-1))
<davexunit>you can include more than one module as well
<OrangeShark>Happy Friday!
<janneke>o/
<delmarre>hello people
<OrangeShark>hello delmarre
<delmarre>just fucked my knee up
<delmarre>so gonna be bed bound for the next couple of days
<delmarre>what fun things can i do with guile?
<amz3>a CMS
<amz3>or whatever yoiu call it
<amz3>E.g. a newspaper engine
<amz3>delmarre: ^
<OrangeShark>content management system?
<amz3>yes
<amz3>or a blog
<delmarre>that would actually be kinda fun i guess
<delmarre>been meaning to get a website for ages
<amz3>^^
<delmarre>what fun things can i do with guile?
<delmarre>woops lol
<delmarre>but yeah is there any specific package i should be looking at for making a blog via guile?
<delmarre>chicken has html-utils which looks super easy
<delmarre>for blocking out a template
<amz3>I can guess you can use artanis, or my guile boilerplate or maybe dustyweb 8sync
<dustyweb>delmarre: if it's just a blog and it's static, I recommend Haunt
<dustyweb>otherwise if dynamic yeah amz3's suggestions are some various routes
<delmarre>oooh yeah haunt looks good to me
<dustyweb>haunt is A+
<dustyweb>used for 8sync's site and Guile's and activitypub.rocks and Guix's
<delmarre>ffs can't get haunt to install properly
<OrangeShark>delmarre: what issue are you having?
<delmarre>not actually sure
<delmarre>literally getting "Error: No code for module (haunt ...)"
<OrangeShark>did you just do ./configure?
<delmarre>nah ran make && make install after
<delmarre>with no errors
<OrangeShark>yeah, by that I mean you ran configure without any arguments
<delmarre>oh right
<delmarre>oh yeah, that's what the README said
<OrangeShark>so they are installed in /usr/local
<delmarre>and guile doesn't look there for modules
<OrangeShark>you need to add that to the GUILE_LOAD_PATH and GUILE_COMPILED_LOAD_PATH
<OrangeShark>correct
<delmarre>right, sweet haha
<delmarre>jesus wept still haven't got it going
<delmarre>moved the haunt stuff to /usr/share/guile/2.2/
<OrangeShark>still couldn't find the haunt modules?
<delmarre>nope lol
<delmarre>then tried running (add-to-load-path "/usr/local/") after reinstalling it with no prefix
<delmarre>and then loading them
<delmarre>and it doesn't like that after
<OrangeShark>oh it not /usr/local but it /usr/local/share/guile/2.2
<delmarre>either
<OrangeShark>hold on let me see the full path
<OrangeShark>$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
<OrangeShark>$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/ccache
<OrangeShark>so that would be /usr/local/share/guile/site/2.2/ for load path and then /usr/local/lib/guile/2.2/ccache/ for compiled
<delmarre>right got there
<delmarre>now just need to edit the load paths permanently
<delmarre>(add-to-load-path) seems to be just for that session
<OrangeShark>you can put it in your .profile or .bash_profile or you can put it in a .guile
<OrangeShark>.guile would be written in scheme
<OrangeShark>oh, .guile is only for interactive
<delmarre>fuck me i'll deal with it tomorrow haha
<OrangeShark>export GUILE_LOAD_PATH="/usr/local/share/guile/site/2.2${GUILE_LOAD_PATH:+:}$GUILE_LOAD_PATH"
<OrangeShark>export GUILE_LOAD_COMPILED_PATH="/usr/local/lib/guile/2.2/site-cacche${GUILE_LOAD_COMPILED_PATH:+:}$GUILE_COMPILED_LOAD_PATH"
<OrangeShark>replace site-cacche with ccache for haunt