IRC channel logs

2017-11-09.log

back to list of logs

<bms_>Hello.
<ArneBab_>happy_gnu[m]: would you share that bot?
<numerobis>Hi! Does anyone know how to create an array of integers in guile using (make-array-typed ...)? I can't seem to find the how to write the "integer" type in the manual. Thanks!
<civodul>numerobis: you could use the SRFI-4 API for that
<civodul>like 'make-u8vector', etc.
<numerobis>civodul: thank you very much, I think that would work!
<civodul>yw!
<manumanumanu>Ahoy hoy!
<Ober>srfi's are soo nice
<manumanumanu>Ober: I'm not always so sure. I think they are a great way to receive feedback and standardise some primitives, but I am not sure about some of them
<Ober>oh sure.
<Ober>but... having had folks thump the clhs as the holy book for ages, it's a great thing to see something written in this millenia
<manumanumanu>hehe
<manumanumanu>I am a bit afraid that r7rs-large will include srfi-42. even after using it quite a bit, I am still confused about the syntax, and a bit disappointed that the code it generates is so slow
<Ober>"what does it mean 'thall shall not cons!'?"
<manumanumanu>But I can easily see how it inspired rackets loops
<Ober>yeah. great ideas persist
<manumanumanu>So then, people: favourite srfis?
<manumanumanu>Mine are 115 159 and 2.
<manumanumanu>even though nr. 2 is the only one I use as an srfi. The others I download directly from ashinn
<rekado>I cannot do without srfi 1 and 26.
<rekado>115 is great and I wished it were part of Guile. It’s just so very useful.
<OrangeShark>wow, there has been a lot of new srfis
<ArneBab_>rekado: can’t you add 115 to Guile?
<civodul>so, on that big CPS compilation thing, it's compute-strongly-connected-components on the top-level thunk that's causing the biggest memory growth
<civodul>i wonder if this is a case where doing it the purely functional way doesn't cut it, at least not with the usual data structures
<amz3>hi everybody
<amz3>manumanumanu: who is ashinn?
<amz3>ah from chibe-scheme ok
<amz3>nvm
<amz3>looking up a new domain name tlds
<amz3>those are awefully expensive
<amz3>mind that the .space tld is available 40€ for 10 years
<amz3>which is not expensive, but it's difficult to come up with a short domain name that is also available
<amz3>on a related note
<amz3>there is this gnu taler thing, a cryptographic money that is also a gnu project that allows anonymous payment but also taxes
<amz3>youtube-dl https://media.ccc.de/v/SHA2017-241-gnu_taler
<bavier>amz3: gnu taler seems pretty cool to me
<amz3>bavier: indeed
<amz3>at least one of the maintainer is also a gnunet maintainer or contributor
<p4cman>how should i get started with guile
<p4cman>also hello
<amz3>grothoff is his name
<amz3>p4cman: do you mind giving me feedback in a tutorial I amde?
<amz3>acme
<amz3>made*
<amz3>p4cman: what's your programming knowledge?
<amz3>background in programming?
<amz3>grothoff is their name
<p4cman>amz3: a little bit C, that's all.
<amz3>p4cman: then you can start with my tutorial, but only if you plan on giving me feedback :D
<p4cman>i'll try :)
<amz3>cool
<amz3>p4cman: you can have it https://a-guile-mind.github.io/book/
<amz3>also there are comics :D
<amz3>and it's space related somewhat
<bavier>p4cman: SICP is also a good intro to scheme/guile https://mitpress.mit.edu/sicp/full-text/book/book.html
<amz3>p4cman: you keep SICP around :)
<amz3>+shall
<p4cman> is elisp different then? or would i be able to write emacs extensions in guile itself
<amz3>p4cman: no
<bavier>elisp is different
<amz3>it doesn't have flying robots
<amz3>p4cman: don't hesitate to read the a-guile-mind book and ask questions on the fly, actually it's not a book there are less than 3,000 words
<OrangeShark>p4cman: elisp is a different language, but there is a lot of similarities.
<p4cman>one question: so is guile a general purpose language and not just an ectension language? considering dmd and guix are written in guile
<OrangeShark>p4cman: yes.
<OrangeShark>guilers are pretty much on the side where an extension language should be a general purpose language
<amz3>+1
<amz3>p4cman: also they are various attempt at building a clone of emacs in guile
<amz3>there is also guile emacs, but... the ladder is ver high
<amz3>very*
<amz3>honestly, I never needed to use elisp
<amz3>I mostly copy paste, and know enough of it to tweak some variables
<amz3>I can read elisp but not write it
<happy_gnu[m]>I did 2 bots with guile \\o/
<happy_gnu[m]>Thanks to 8sync of dustyweb
<happy_gnu[m]> https://notabug.org/happy_gnu/Bots
<happy_gnu[m]>One of them is, of course, and interjection bot :)
<bavier>happy_gnu[m]: cool
<amz3>nice!
<daviid>Romantic: https://github.com/ChaosEternal/guile-inotify2.git
<daviid>here is a list of guile related projects that is relatively well maintained http://sph.mn/c/view/g2
<happy_gnu[m]>Thanks :)
<happy_gnu[m]>Code is messy
<happy_gnu[m]>But I had been having so much fun
<happy_gnu[m]> https://www.quora.com/What-did-Alan-Kay-mean-by-Lisp-is-the-greatest-single-programming-language-ever-designed/answer/Alan-Kay-11?share=1
<manumanumanu>ArneBab_: irregex (the basis of srfi-115) is trivial to install in guile.
<manumanumanu>daviid: I just used guile-inotify2 to write a small script to automatically sort my download directory
<manumanumanu>it does not handle errors at all, so you need to do some housekeeping yourself (make sure the directory exists, etc).
<manumanumanu>and it has no licence info
<manumanumanu>probably something gpl-ish
<manumanumanu>daviid: is that your list?
<daviid>manumanumanu: I dod not write this project, you probably want to talk to the author about all this ... chaosethernal iirc
<daviid>no it is not my list, i posted it to help Romantic and possibly new comers I don't know to bookmark it, afaict, it i the 'best list' we have, it tracks a lot more then our own web pages ... some are old and there for history of course...
<daviid>the author is tantalum, his/her email is sph at posteo dot eu, i emailed a few times to help with some corrections and missing link, i just did it again to mention guile-cv which i just realized was still missing
<daviid>i've used inotify2, i did not face any error, for my use case it was fine
<daviid>it would be nice to have it as a 'good' binding, proper autotool, tests, doc, license of course .. don't know why the author did not make it so, something to think about i guess ... someone could pick it up (not me though, too busy)