IRC channel logs

2017-11-05.log

back to list of logs

<amz3`>héllo #guile
<slyfox>finally found out why guile crashed on ia64: use of uninitialized pointer! https://debbugs.gnu.org/cgi/bugreport.cgi?bug=29151
<rekado_>I’m trying to use syntax-case to generate arbitrarily named procedures with arbitrarily named keyword arguments
<rekado_>the input is a specification that I need to access at macro-expansion time
<rekado_>when I use syntax->datum on the input, however, all I get is the symbol identifier, not the value of the expression.
<rekado_>e.g. when I call the macro on $18, which is bound to an expression and I inspect the value of the argument at macro expansion time I get the value '$18
<rekado_>how can I access the value bound to the identifier?
<janneke>rekado_: something like module-ref, module-variable
<janneke>?
<rekado_>I don’t know if I can use this at macro expansion time, though
<janneke>...aaand you're probably looking for the right way too. also primitive-eval came to mind but ...
<rekado_>maybe I shouldn’t try to use a macro at all
<rekado_>maybe higher order functions would suffice in this case.
<jeko>Hello guilers !
<sneek>Welcome back jeko, you have 1 message.
<sneek>jeko, OrangeShark says: the blog post is up https://erikedrosa.com/2017/10/29/guile-projects-with-autotools.html
<jeko>Does anybody has a way to design (methodo) a guile application ? I like to do some diagrams before coding...
<jeko>And I am looking for an academic/systematic way
<jeko>(like UML for OO)
<amz3`>jeko: sequence diagrams works well
<amz3`>OrangeShark: tx for the article it's helpful, but It's unlikely I will put it to good use, I am terrible autotools ninja
<amz3`>jeko: what are you coding? maybe we can figure things together?
<jeko>amz3`: It's for my toy-app in Guile, as I am not a Guile super-coder (first time functional) I mostly think about a way to do thing then I seek in the Guile reference if i can find all the components
<amz3`>jeko: good thing, you are confident enough to put together proceudres to build abstractions
<jeko>amz3`: It is a personal organizer using the GTD methodology and a todo.txt format for my tasks
<amz3`>ok
<jeko>I have think about some "layers"
<amz3`>what's the input and output of your program? is it a cli or a gui?
<jeko>Actually it is a cli
<amz3`>ok
<jeko>I will think about gui later ^^"
<amz3`>good thing
<jeko>And the input is a string
<jeko>well not exactly
<amz3`>so what it is the specifications of the options that takes your program?
<jeko>I do ./cyborg collect Design the +cyborg architecture
<amz3`>ok
<jeko>then it add a line in my central.txt file
<jeko>with a creation date etc...
<amz3`>ok
<amz3`>what does +cyboard means?
<amz3`>+cyborg sorry
<jeko>it means the task is related to my cyborg project
<amz3`>oh
<jeko>it is just a way to identify what is a project
<amz3`>it's a tag
<amz3`>?
<jeko>yes !
<amz3`>what about architecture?
<jeko>sorry was a french word which suite for "structure"
<jeko>or "organisation"
<jeko>in some cases
<jeko>^^"
<jeko>at the beginning I thought, I have a cyborg module which get the command line
<jeko>cyborg.scm
<jeko>which call procedures from gtd.scm
<jeko>which then call procedures from todo-txt.scm
<jeko>I tried to summarize it in this README https://framagit.org/Jeko/cyborg
<amz3`>ok, I look it at it
<amz3`>jeko: so what is your problem?
<amz3`>it seems to me that the layering makes sens
<amz3`>jeko: for parsing the todo.txt file lines I recommend you have a look at guile-combinators
<jeko>I was not 100% confident so I was looking to visualize it on diagram... bu maybe I should focus on coding lol
<amz3`> http://hyperdev.fr/notes/getting-started-with-guile-parser-combinators.html
<jeko>amz3`: ok I will look at it
<amz3`>yes, you can do a diagram if you feel like it
<amz3`>or several diagrams
<amz3`>the more documentation the better :)
<jeko>sure
<amz3`>jeko: if you don't find your way around guile-combinators, don't hesitate to ask here or on the mailinglist
<amz3`> https://lists.gnu.org/mailman/listinfo/guile-user/
<jeko>even if it concerne my particular software?
<amz3`>yes
<jeko>ok i will do that. thank you amz3`
<amz3`>yw
<laertus>when trying to compile guile emacs from the wip branch of git://git.hcoop.net/git/bpt/emacs.git i get a bunch of undefined reference errors to scm_make_obarray, scm_find_symbol, scm_intern, scm_unintern, and scm_obarray_for_each
<laertus>here's the full build log: https://paste.pound-python.org/show/1FNUL2AqdgnVjFUSU8QW/
<laertus>i think it may have to do with the fact that i'm using the newest guile from git instead of guile-2.2
<laertus>i had to change the configure script of guile-emacs to change all references to guile 2.2 to guile 3.0
<laertus>any advice on how to fix this (apart from going back to guile 2.2) ?
<amz3`>maybe read all the commits from guile 2.2 until guile 3.0 and see where the missing symbols are gone
<laertus>i was hoping someone here might know
<daviid>laertus: others would know better, but i don't think the git repo you are using is the latest guile-emacs, there is a branch on savannah, I think ...
<laertus>ah
<daviid>laertus: you should not try to ork with guile-3 at this moment
<laertus>i was going by the instructions on the emacs wiki: https://www.emacswiki.org/emacs/GuileEmacsBuild
<laertus>which referenced that git repo
<laertus>ok, i'll go back to guile-2.2
<laertus>thanks
<daviid>laertus: beleive the branch is wip-elisp
<laertus>i found this: https://www.reddit.com/r/emacs/comments/4zttlt/guileemacs_status/
<laertus>which asked which branch to use:
<laertus> http://git.hcoop.net/?p=bpt/guile.git (last updated 2015)
<laertus> http://git.savannah.gnu.org/cgit/guile.git/log/?h=wip-elisp (looks like the same branch rebased on newer guile)
<daviid>yes, that is the latest, wip-elisp, with some patches by dustyweb ...
<laertus>there's also: http://git.savannah.gnu.org/cgit/guile.git/log/?h=wip-bpt-elisp (has the newest commits, but seems to be on an older version of guile?)
<daviid>that is the (very) old one
<laertus>ah, ok
<daviid>use wip-elisp and patches welcome ...
<laertus>cool
<laertus>thank you very much
<daviid>laertus: wc! though dustyweb would know better, I don't use neither did I nerver worked on wip-elisp... but i know it would be fantastic if some good hacker take this on they shoulder :)
<laertus>i'm definitely not a good hacker, and have very little time to spend on this, unfortunately... i'm just interested in trying it out and maybe filing some bug reports :]
<laertus>i think my contributions will be more in the testing capacity
<laertus>i might also write some docs on how i got guile emacs up and running, and my impressions of it vs regular emacs
<laertus>if i get it running, that is..
<manumanumanu>Ahoy hoy, fellow guilers!
<stis>hej manumanumanu!
<manumanumanu>Today's five million euro question: Why is geiser surpressing my guile errors?
<manumanumanu>stis: What is boiling in that genious mind of yours this week?
<slyfox>does 'make check' pass checks on current guile git for you?
<stis>spent all time in Skåne with two of my brothers, and my children. It's vacation times for the school kids.
<daviid>slyfox: you have to checkout the stable-2.2 branch
<slyfox>daviid: i planned to upstream a fix into main tree and wanted to make sure i don't break anything
<slyfox>and found quite silly bug in foreign object creation
<stis>manumanumanu: did you cook something together this weekend or what's up.
<stis>ACTION is too tired to do anything useful after 6 hours of driving - slacking and enjoying music
<daviid>slyfox: so, you want to patch and check your patch using stable-2.2, then report a bug with your patch atached...
<slyfox>ok
<manumanumanu>stis: found guile-inode2, so I whipped together a self-sorting download-folder with the 20 most recent files symlinked
<manumanumanu>got bitten by the fact that case is eqv and not equal?
<manumanumanu>so I wrote a case-of macro that lets you pick the comparison procedure
<stis>manumanumanu: great, sounds like you are having fun!
***x1n4u- is now known as x1n4u
<laertus>daviid: has the code in http://git.savannah.gnu.org/cgit/guile.git/log/?h=wip-elisp been integrated in to https://ftp.gnu.org/gnu/guile/guile-2.2.0.tar.gz ?
<daviid>laertus: very probably not
<daviid>but again, I'm not the right person to talk about this
<laertus>who should i ask?
<daviid>i just wanted to save you some time, and not study a very old repo ...
<daviid>if noone answers here, post an email to guile-user
<daviid>or guile-devel actually
<daviid>wisp-elisp is devel ...
<laertus>yeah, i appreciate your help... it's just that i just built guile from that tar file, not fully understanding that i should have built from that wip-elisp branch instead
<laertus>so at this point, if i rebuild guile from wip-elisp it'll take more time
<laertus>not a huge deal, but i was hoping i could just save that time
<daviid>laertus: yes you have to build from wisp-elisp and be patient, it can take quite a long time
<laertus>ok
<laertus>thanks for your help.. i'll do that
<daviid>playing with branch, you can't avoid a build from scratch, which depending on your computer power can take up to more then a day...
<laertus>yeah, i've unfortunately built guile a whole bunch of times now
<laertus>and i know it's super, super slow
<laertus>what's really weird, though, is that when i last built guile, which was from that 2.2.0 tar file, it only took 3 hours
<laertus>i don't know how that could have been possible... usually it does take me something like a day to build it
<laertus>i'll see how long it takes me to build this wip-elisp branch...
<daviid>laertus: when building from a tarball, which has boostrap binries included, it is a lot faster indeed, as expected ...
<laertus>oh
<laertus>that explains it!
<laertus>ACTION sighs
<laertus>oh well, i guess i'm in for a long ride this time :)
<daviid>laertus: you can hack while it's compiling ...
<laertus>that i will
<laertus>so once i compile this wip-elisp branch, should i still get guile-emacs from the wip branch of git://git.hcoop.net/git/bpt/emacs.git ?
<laertus>or is there a better/newer source?
<rekado_> https://git.elephly.net/software/guile-debbugs.git
<rekado_>it’s not much, but it’s a start