IRC channel logs

2017-10-28.log

back to list of logs

<jeko>I've to try it out, seems much simpler thant mine xD
<jeko>thank you !
<jeko>I need to sleep right now. See you guilers !
<mwette>later everyone
<numerobis>Hi! Does anyone know if there is there any way to generate tags file from a guile codebase? And, if not, is there an easy way to jump to a function definition from vim? Thank you!
***webshinra_ is now known as webshinra
<daviid>hylang.org
<daviid>#! /usr/bin/env hy
<daviid>(print "I was going to code in Python syntax, but then I got Hy.")
<amz3>:)
<cmaloney><3
<mwette>Hello, all. I have updated debbugs 27782, "scheme level mmap", with more code to implement mmap/munmap in Guile. I think it needs review. It does compile and not crash. The minimal usage is `(define bvec (mmap 0 #x100000))' which allocates a 1M chunk of memory.
<mwette>as a bytevector
<Apteryx_>Is fibers included in Guile 2.2.2?
<Apteryx_>I can't find a reference to it in the manual.
<mwette>By the way, the printer for bytevector should change: if I type `bvec' at the guile prompt I get #vu8(0 ... [ one million 0's ] ... 0)'
<mwette>no: check https://github.com/wingo/fibers
<amz3>here's an interesting project https://github.com/OpenGenus/cosmos
<mwette>amz3: thanks
<daviid>we could improve guile-lib, slowly but surely :), and for info, some of the math stuff are in guile-cv, convolution, gaussian filters, soon I will have FFT and friends ...
<OrangeShark>amz3: thanks for the link, that seems pretty nice
<ArneBab_>is there an implementation of unshuffle sort for Guile? http://central.gutenberg.org/articles/unshuffle_sort
<ArneBab_>it looks like specializing sort for arrays of integers could yield a factor 8 performance improvement: http://stereopsis.com/radix.html
<ArneBab_>unshuffle sort provides efficient sorting for linked lists instead of for arrays: http://www.pharaohbloggers.com/algorithms/unshuffle-sort/
<ArneBab_>how does that compare to what we do right now?