IRC channel logs

2017-10-25.log

back to list of logs

<codemac>Is there any way to print all current environment bindings?
<codemac>I'm reading a file of scheme data in, and there is a variable I'm defining in a lambda outside of the read that I want it to reference, but it's not working. I tried local-eval + (the-environment), I tried primitive-eval.. struggling to get a binding to be visible during a read of a file
<codemac>is this a case for fluids?
<codemac>see the error message here: https://gist.github.com/codemac/1b6af6a8f97d8e16cc33e5e336854559
<codemac>you can see the "page" variable not making it during the last read of an "unknown file" which is just the same template.pop file
<dustyweb>rekado: did you try the patches?
<dustyweb>they didn't apply for me...
<codemac>Ah, it looks like the read-hash-extend I'm doing doesn't have the bindings.
<dustyweb>wingo: I don't suppose there's a way to find out *which* frame on the stack is causing a continuation barrier?
<dustyweb>well
<dustyweb>I'm having errors with continuation barriers, but only probabalistically
<dustyweb>and I need to have this thing up, sigh :(
<dustyweb>ACTION feels defeated
<codemac>Is there any way to print all bindings in an environment?
<codemac>sorry if it seems like I'm asking random questions, thanks for any help
<codemac>aha, (use-modules (ice-9 session)) (apropos "regex")
<rekado_>dustyweb: they did apply for me, but it wouldn’t compile.
<rekado_>dustyweb: I wrote an email in response, but recently all my mail to @gnu.org are delayed, so it may not have been received yet.
<dsmith-work>Wednesday Greetings, Guilers
<bgamari>does anyone understand the limitations of cross-compilation of guile?
<m3tti>=6
<cmaloney>greets dsmith-work
<jeko>Hello guilers ! I am at the beginning of my journey with guile (and scheme) and I am looking for a ressource about how to structure my programs
<jeko>do i need test directories? src? or do i have to put a module and its tests in the same dir...?
<jeko>that kind of question
<jeko>is there a kind of "standard almost always true" ?
<dsmith-work>bgamari: Guile needs guile to build, so cross-compiling end up building guile twice.
<dsmith-work>It does work.
<bgamari>dsmith-work, hmm
<dsmith-work>Need the proper deps. Like libgc and whatnot
<bgamari>dsmith-work, sure
<bgamari>So I have a build environment guile
<bgamari>dsmith-work, yet I see https://debbugs.gnu.org/cgi/bugreport.cgi?bug=28920
<dsmith-work>At one time, I had it building with buildroot
<dsmith-work>Someone else has since added it to buildroot, but I haven't tried it.
<bgamari>dsmith-work, any idea where that error might be coming from and what it means?
<dsmith-work>ERROR: In procedure load-thunk-from-memory: ELF file does not have native word size
<dsmith-work>Looks like the wrong guile is trying to load the wrong .go files.
<manumanumanu>jeko: nope. Not what I have seen. Learn how the module system works (which is not obvious), and try the different things
<dsmith-work>jeko: There used to be a template package somewhere. Not sure where it went.
<dsmith-work>jeko: But I think it was for a package that wraps an external C lib.
<dsmith-work>Marten Grabueller comes to mind.
<bgamari>dsmith-work, hmm
<dsmith-work>Well, typoed that name!
<bgamari>dsmith-work, any debugging advice?
<bgamari>I essentially just ./configure'd with the desired target and build toolchain and ran make
<dsmith-work>Martin Grabmuller
<ArneBab_>jeko: you can start with a simple script and later move it to a full package.
<dsmith-work>bgamari: Hmm. Nope. The only suggestion would be to let guile build itself locally instead of using GUILE_FOR_BUILD
<bgamari>I see
<ArneBab_>jeko: at some point you’ll want to work out how to do a nice autotools setup with installation, pre-compilation and access to data.
<ArneBab_>jeko: but that’s likely some way off
<ArneBab_>(in the distance)
<dsmith-work>bgamari: You might want to use the mighty strace to try and see what is loading what.
<bgamari>sure
<bgamari>unfortunately it sounds like it's loading the object file from memory
<dsmith-work>bgamari: Is your guile-for-build the same version as what you are cross-building?
<bgamari>so it may be hard to determine where exactly it came from
<bgamari>dsmith-work, yes
<dsmith-work>That /should/ work.
<dsmith-work>bgamari: It's been a while since I've tried to cross-build.
<bgamari>dsmith-work, if I don't specify GUILE_FOR_BUILD configure tries to find a guile in PATH
<bgamari>so I'm not sure I can let it build itself locally
<dsmith-work>bgamari: Unfortuantely, I've changed jobs since then, and my notes/scripts/workingdir are there.
<bgamari>ahh, unfortunate indeed
<dsmith-work>bgamari: Also, I've never used guix.
<bgamari>well, this is nix, but in principle it really shouldn't matter
<bgamari>I just used nix to build the host guile
<dsmith-work>Ahh. Sorry about that. I misread.
<dsmith-work>bgamari: Here is the buildroot package https://git.busybox.net/buildroot/tree/package/guile
<dsmith-work>There are some patches there.
<dsmith-work>Not sure if that applies to your situation.
<dsmith-work>Not even sure if that build configuration works.
<bgamari>Yeah, I've been looking at that
<dsmith-work>bgamari: But *maybe* there are some clues there that will help?
<bgamari>I haven't tried it yet
<dsmith-work>I know I had guile running using buildroot on an rpi or beaglebone.
<bgamari>cool
<bgamari>well that is a good datapoint
<dsmith-work>bgamari: I'll see when I get home. I think I might still have that around.
<dsmith-work>Gonna be about 7 hours from now.
<bgamari>cool, I'll be around
<bgamari>dsmith-work, thanks!
<jeko>(Thanks to people who answer my question, sorry for delay and short come back, I write on my phone...) cheers
<OrangeShark>jeko: I am actually writing a blog post on how to structure a guile project. It based off of other projects I have looked at
<jeko>OrangeShark: I would like to read it for sure !
<hooverville>OrangeShark: me too (would like to read too)
***ftknox_ is now known as ftknox
<OrangeShark>jeko: hooverville it is almost done. It will eventually add stuff including testing and other stuff
<jeko>can you give us your blog address ? I will check regularily and maybe read some post as well :)
<OrangeShark>jeko: https://erikedrosa.com/
<jeko>OrangeShark: thank you
<OrangeShark>no problem
<hooverville>ACTION gives thumbs up
<bavier>jeko: I have an autotooled guile project at https://notabug.org/bavier/joy-in-the-morning
<bavier>the organization is based roughly on some of what's done in Guix
<bgamari>dsmith-work, I think guile 2.2.0 regressed with respect to cross compilation
<bgamari>dsmith-work, I can cross-compile 2.0
<bgamari>and indeed that's what buildroot uses
<dsmith-work>Ahh
<dsmith-work>ACTION points the Dread Finger of Accusation at.. wingo!
<bgamari>heh
<dsmith-work>Hmm.. I wonder if it's related to the newish bootstrapping .go files that come in the package tarball.
<dsmith-work>bgamari: Would you consider building from the stable 2.2 git branch? (instead of a release tarball)
<bgamari>dsmith-work, sure
<bgamari>dsmith-work, is there a chance it would work?
<dsmith-work>bgamari: Yes, I think so.
<dsmith-work>bgamari: My understanding is the package contains all 4 types of go files. It looks like when you are x-compiling, the wrong type is selected.
<dsmith-work>(that's just a guess)
<dsmith-work>If you build from git, you will only have the ones for your host. So that might make a difference.
<dsmith-work>(the 4 combos are 32/64 bit and big/little endian)
<dsmith-work>bgamari: But please be patient. It could take hours.
<jlicht>hello guile! I was wondering if there is already an existing module for parsing and/or querying html
<OrangeShark>jlicht: I believe guile-lib has an html parser
<dsmith-work> http://www.nongnu.org/guile-lib/doc/ref/htmlprag/
<dsmith-work>If the html is well formed, the sxml stuff built in might work?
<dsmith-work>ACTION never tried
<jlicht>thanks OrangeShark, dsmith-work: I will look into all of these options