IRC channel logs

2017-10-19.log

back to list of logs

<guile-guest1>hi
<sneek>Welcome back guile-guest1, you have 1 message.
<sneek>guile-guest1, Apteryx says: then you'll at least need to build proot -- in the same page it details how to build a statically linked proot on a 2nd machine and then transfer the binary to your server.
<guile-guest1>do you guys have link for example format gnu robots ?
***vicenteH` is now known as vicenteH
<roelj>What's an elegant way to generate a list with a sequence of numbers: '(1 2 3 4 5 6 7)?
<roelj>I now use http://paste.lisp.org/+7P0K
<roelj>But I hoped to find a function that already does this.
<janneke>roelj: (iota 7 1) in srfi-1?
<roelj>janneke: Thanks!
<roelj>Ehh.. How do I merge two lists again..? (define a '(A B C D E F)) (define b '(1 2 3 4 5 6)) (... a b) => ((A 1) (B 2) ...)
<roelj>Ah, (zip a b) seems to do that.
<civodul>zip!
<roelj>Is there an alternative to scandir that allows to select a subset of files without writing a lambda? So something like (scandir "data/prefix-*") => '("prefix-file1" "prefix-file2" "prefix-file3")
<civodul>there's 'find-files' in (guix build utils), but it's recursive
<civodul>or you could do (scandir dir (cut string-prefix? "prefix" <>))
<civodul>no lambda! :-)
<roelj>Haha, indeed.. no lambda :)
<roelj>That looks nice enough :)
<davexunit>ACTION learned how to use prompts to traverse a nested structure and produce a list of results without having to flatten nested lists
<civodul>sounds fun
<davexunit>I think I could use it to improve my parser combinator code
<davexunit>and guile-syntax-highlight
<davexunit>basically, each time the recursive process produces a value worth keeping, you abort with that result, the prompt handler simply conses the result onto the result of the continuation
<davexunit>the initial thunk given to call-with-prompt returns '() ultimately, and you get a nice proper list
<OrangeShark>davexunit: I do something similar to collect values in commonmark using just continuation passing style
<davexunit>neat
<davexunit>I imagine there are more examples of this style
<davexunit>it just took me awhile to understand it
<OrangeShark>I still need to understand prompts. For the continuation passing style, I just tried what I learned from the little/seasoned schemer.
<davexunit>once you wrap your head around prompts you will find uses for them all over
<davexunit>being able to write your own control flow operators is so great.
<dustyweb>davexunit: +1
<dustyweb>also
<dustyweb>I need to finish The Seasoned Schemer
<dustyweb>I'd really like to get to the CPS part.
<davexunit>yeah I never finished that book either
<OrangeShark>the CPS part was great :)
<OrangeShark>it shows you some common ways to use CPS
<stis>hej guilers!
<manumanumanu>Hej stis