IRC channel logs

2017-10-08.log

back to list of logs

<amz3`>IpswichTriptych: what do you plan to do after that? any plans?
<dustyweb>o/
<IpswichTriptych>amz3`: well, i just started using Guix, so i'm hoping to get a deeper understanding of how Guile is used with Guix
<amz3`>good luck ;)
<IpswichTriptych>ty! how about you, what are you working on?
<amz3`>a search engine
<amz3`>i guess
<amz3`>I've done several projects in guile, but I think now I will only work on the search engine
<IpswichTriptych>cool! does it search webpages or something else?
<amz3`>yeah it search web pages
<amz3`>but it's not online yet
<amz3`>I mean not anymore
<IpswichTriptych>i'd be glad to hear more about it if you care to share
<amz3`>yeah sure
<amz3`>if you are around
<amz3`>IpswichTriptych: subscribe to the guile mailing list https://lists.gnu.org/mailman/listinfo/guile-user/
<IpswichTriptych>sure thing
<IpswichTriptych>sub'd :)
<Toga_Virilis>I'm sitting on a portable implementation of srfi 89 which guile doesn't have yet (hence I wrote it) is there any easy way to upstream this anonymously?
<taylan>Toga_Virilis: you could use a pseudonymous email account and make sure you don't have your real name or email anywhere in your git config, email config, or elsewhere that may end up in commit metadata, email headers, etc.
<Toga_Virilis>taylan, ehhh
<Toga_Virilis>taylan, is there not like a way to just mail someone the single file that it is?
<taylan>Toga_Virilis: oh also I forgot: FSF copyright assignment :\\
<Toga_Virilis>taylan, yes, but I was told on reddit by someone that guile doesn't require that
<taylan>no idea if that allows for anonymity
<Toga_Virilis>But maybe that was Guix
<Toga_Virilis>How about I public domain it? Does that work?
<taylan>Guix doesn't, Guile did last time I wanted to contribute a patch
<Toga_Virilis>taylan, how about if I assign copyright to you, will you accept that without my real name?
<taylan>probably the FSF will still want to check whether the assignment is legally valid. that would just make things more complicated. also I'm in Germany.
<Toga_Virilis>Hmm
<Toga_Virilis>So is it more difficult to work with this if you're not from wherever the FSF is from?
<taylan>honestly I have barely an idea. I followed FSF instructions to assign copyright because they know what they're doing; we two probably don't :)
<Toga_Virilis>So you think it's possible that I give them the copyright if they agree to NDA my name?
<Toga_Virilis>Ahh
<Toga_Virilis>Oh well.
<taylan>you should speak to the copyright clerk
<Toga_Virilis>This seems really complex to upstream a 300-line SRFI implementation in a single file; which is probably to be honest why it's not there yet; this system seems pretty complex for small contributions.
<taylan>yeah copyright assignment is an infamous aspect of FSF contribution
<taylan>s/FSF/GNU/
<taylan>ACTION goes AFK
<Toga_Virilis>I guess it's not as much that I lose copyright which I don't care about as much as that it just seems to be too much hastle, but oh well it works for me. As I said the implementation is super portable so I might as well just put it online some-where.
<amz3`>héllo :)
<dustyweb>wingo: guile currently doesn't gc symbols, right? I wonder if this is still one way an adversary could make an application crash, even if space/time constrained
<dustyweb>effectively, keep generating random symbols across multiple evaluations until the symbol table makes the program run out of memory
<Apteryx>Has anyone seen this error in the Guile interpreter: ERROR: In procedure %readline: readline is not reentrant
<civodul>hmm no
<Apteryx>OK. Here's the snippet I tried copy-pasting in the REPL that lead to the problem: http://paste.lisp.org/display/358020
<Apteryx>and here's the data file used in the previous snippet (known-affected-packages.txt): http://paste.lisp.org/display/358020#1
<Apteryx>Also in my ~/.guile I have: (use-modules (ice-9 readline))(activate-readline)
<Apteryx>I guess the cwd is not what I expect and that it blocks trying to open the missing file "known-affected-packages.txt"? I'd expect it to bail out and tell me.
<Apteryx>It seems I need to "cancel" the evaluation using C-c to get an error. I wonder why Guile doesn't interrupt itself when it encounters an error instead of staying silent and apparently frozen. Here's the backtrace I managed to get after hitting C-c: http://paste.lisp.org/display/358025. At this point it is probably just a bug in my code, but it'd be nice for Guile to error out instead of staying silent!
<Apteryx>Is using "get-string-all" recommended to read a file as a string? I'm using it in combination with 'with-input-from-file' and it doesn't fly.
<Apteryx>Here's a quite minimal example (you just need some text file to read): http://paste.lisp.org/display/358030
<Apteryx>Seems the problem stems from the use of `with-input-from-file'
<Apteryx>Even more minimalist: (with-input-from-file "/home/maxim/.emacs" (display (current-input-port))) --> #<input: file /dev/pts/1>ERROR: ERROR: Wrong type to apply: #<unspecified>
<ArneBab_>Apteryx: use a lambla function: (with-input-from-file "/home/maxim/.emacs" (lambla()(display (current-input-port))))
<ArneBab_>Apteryx: you tried to evaluate the return value from display (#<unspecified>)
<Apteryx>ArneBab_: Oh, this is what a THUNK mean? I thought it could be about just any block of s-exp! Thanks.
<Apteryx>There is a definition under the Guile Reference documentation of the thunk? procedure: a procedure that does not accept
<Apteryx> arguments.
<ArneBab_>Apteryx: yepp, that’s what you get with (lambda () ...) — as well as with (define (somename) ...)
<ArneBab_>Apteryx: with lambda no name gets assigned to the procedure