IRC channel logs

2017-09-30.log

back to list of logs

<amz3`>o/
<amz3`>login page is done
<amz3`>I am working on the 'new post' page
<amz3`>like I said previously it's not difficult
<amz3`>but it's a lot of work
<wingo>sneek: later tell civodul: idle thought, the slot allocators uses integers as bitmasks
<sneek>Okay.
<wingo>sneek: with functions with many slots (more likely the case with long functions; heuristics can be complicated) that means more bignums
<wingo>sneek: later tell civodul with functions with many slots (more likely the case with long functions; heuristics can be complicated) that means more bignums
<sneek>Okay.
<wingo>sneek: later tell civodul: i wonder if those finalizers are perhaps cause of some of our gc woes?
<sneek>Got it.
<wingo>sneek: later tell civodul: i.e. bignum finalizers
<sneek>Okay.
<stis>hej guilers
<sneek>Welcome back stis, you have 4 messages.
<sneek>stis, wingo says: (5) yes, there is a finalizer slot on structs
<sneek>stis, wingo says: (3) you mean compile-time warnings? yes it would be nice in some ways if there were a warning handler as a fluid or soemthing
<sneek>stis, wingo says: (2) you can always build such a procedure of course :)
<sneek>stis, wingo says: (1) yeah really sorry about the guile maintenance situation! for me things will be better at end of october. but feel free to post and re-post until it gets attention :)
<stis>sneek later tell wingo: in case you stall a thread for later execution in fibers, you will unwind the stack and the problem is that a finally clause which is a dynwind will execute
<sneek>Okay.
<stis>sneek later tell wingo: if there was a per thread variable that indicated if the unwinding was of this case one can direct the finally clause to ignore the unwinding
<sneek>Got it.
<amz3`>time for a demo
<amz3`>but I need to upgrade my vps to strech :(
<amz3`>stretch*
<amz3`>my vps is so slow
<mwette>working on ffi and bytestructures support for varargs functions
<sneek>mwette, you have 1 message.
<sneek>mwette, ArneBab says: this release (wisp 0.9.5) also does the first step towards providing a wisp tutorial for beginners: It makes it easy to create a wisp project when you have vanilla Guile installed. And I wrote an article today which describes how to create a wisp project: http://www.draketo.de/proj/with-guise-and-guile/wisp-project.html
<mwette>ArneBab: Nice going.
<mwette>ArneBab: One more item: I believe there is no expression terminator besides newline (python has `;') so the manual should make clear that
<mwette>ArneBab: `foo : bar : baz' means `(foo (bar (baz)))' and not `(foo (bar) (baz))'. IMO, this needs to be explained w/o reference to Scheme.
<amz3`>here is the demo website for my blog engine, I put it online to test whether google can successfuly index pure scheme frontend applications
<amz3`> http://presence.hyperdev.fr/
<amz3`>you read correctly, my blog engine use scheme in the frontend and scheme in the backend :D
<amz3`>TODO: comments and stats
<QoDliBt>hi there
<amz3`>QoDliBt: hey
<mwette>amz3`: Great! Now only a few steps to be able to run an emacs editor in a browser window.
<OrangeShark>amz3`: nice, I can't wait to see more of it :)
<amz3`>OrangeShark: :)
<m3tti>hi there im trying to use fold or foldr in guile but it doesn't work
<m3tti>it says
<m3tti>In procedure module-lookup: Unbound variable: foldr
<m3tti>same for fold
<m3tti>what should i do
<ft>fold and fold-right are defined in (srfi srfi-1)
<m3tti>i see
<m3tti>:D
<m3tti>i'm new to scheme
<m3tti>i was used to lisp
<m3tti>and now i'm seeing the benefits of scheme :D
<ft>See the menu about modules and srfi support. There you'll find the documentation for the srfi-1 module.
<ft>On the interwebs: https://www.gnu.org/software/guile/manual/guile.html#SRFI_002d1-Fold-and-Map
<random_numbers>Is there any nice library/module for json?
<mwette>random_numbers: gitlab.com/dustyweb/guile-json
<random_numbers>mwette: Private project?
<mwette>random_numbers: I guess, but has been discussed on the guile mailing lists.
<random_numbers>I asked mainly because it's asking me to register.
<random_numbers>The devel list?
<mwette>yes
<mwette>check the archive
<random_numbers>Does it double as guile-users?
<mwette>try this: http://lists.gnu.org/archive/html/guile-devel/2017-05/msg00012.html
<random_numbers>mwette: I'm getting a 404 on https://gitlab.com/dustyweb/guile-json
<random_numbers>"
<random_numbers>The resource that you are attempting to access does not exist or you don't have the necessary permissions to view it."
<random_numbers> https://github.com/aconchillo/guile-json Is this an up-to-date copy of the same?