IRC channel logs

2017-09-22.log

back to list of logs

<amz3`>o/
<amz3`>nalaginrut: did you have a look at guile-js?
<amz3`>I made a small boilerplate to start coding web apps https://github.com/a-guile-mind/guile-web
<manumanumanu>ArneBab: The thing is, I don't think I have ever seen curly infix used. The closest thing is the racket ., (eg: (5 . < . 6) => (< 5 6)), but most people don't use that either
<nalaginrut>amz3: oh~nice, I didn't know it work now
<nalaginrut>I'll take look later, after I released 0.1.2, I have to consider to add good abstract for web frontend stuffs in Artanis
<nalaginrut>I think 0.1.2 will be in this or next month, with a better websocket implementation
<bavier`>ACTION having fun with threading in guile
<civodul>bavier`: what kind of fun? :-)
<bavier`>civodul: there are several ways to do threading in guile, I'm trying to figure out the right paradigm
<bavier`>civodul: I'm trying to "fix" guix's 'compile-all' script so that it integrates with make's jobserver
<bavier`>my laptop unfortunately starts to overheat if more than one core is busy for too long, which means 'guix pull' is painful
<bavier`>:P
<bavier`>I've not touched threading in guile much before, so this is fun
<civodul>heh, i see!
<cehteh>here it compiles on all availabel cores, but the problem is, that guile itself is so slow
<bavier`>cehteh: my problem's the opposite, I don't mind if it's slow, and I want to be able to use less cores
<cehteh>cant that be configured?
<bavier`>cehteh: currently not, 'guix pull' ignores the --cores option
<bavier`>maybe better discussion for #guix
<cehteh>ah ok
<cehteh>should be fixed yes, but just respecting the --cores option would be nice (or alternatively a --load option which starts jobs as long load stays under limit)
<ArneBab>manumanumanu: I’m using curly infix regularly
<ArneBab>manumanumanu: it’s really cool for if: (if (or {a = b} {c > d} {x equal? y}) #t #f)
<dsmith-work>Happy Friday, Guilers!!
<OrangeShark>happy friday
<manumanumanu>ArneBab: a matter of taste. I prefer the regular way :) However, doing (find {= 5 <>} my-list) really tickles me in the right spot
<manumanumanu>I haven't found a good way to alter the reader though, but I remember someone mentioning a library for doing just that
<amz3`>manumanumanu: guile-reader?
<dsmith-work>manumanumanu: http://www.nongnu.org/guile-reader/doc/guile-reader.html