IRC channel logs

2017-07-21.log

back to list of logs

<daviid>paroneayea: I think you'll like this :) http://imgur.com/Ie7dWdD
<daviid>ACTION secretly hopes paroneayea will present guile-cv to the world ... :)
<reepca>Hm, when should I be using custom ports and when should I be using soft ports?
<paroneayea>daviid: oh hey cool, you've got it integrated with geiser's image view stuff too huh
<daviid>yes, it's a user option, you can use gthumb, eog or the viewer of your choice
<daviid>paroneayea: here, for info: http://www.gnu.org/software/guile-cv/manual/html_node/Utilities.html#im_002dshow
<daviid>paroneayea: and with this guile-cv/geiser integration, one could write a tutorial for kids, à la drracket and picture programming :) - though guile-cv is a scintific image processing and analysis lib, it can be used to teach and have fun as well ...
<daviid>anyway, have to leave the place I'm working now, bb tomorow
<catonano>sneek later tell daviid guile-cv is awesome !
<sneek>Will do.
<ennoausberlin>Hello. I have a beginner question. As I understand in scheme code is data and data is code. So I decided to use a association list to store some key value pairs inside a file to use it for configuration. Whats the guile way to read in these assocs?
<lloda>ennoausberlin: (read port), or (call-with-input-file "filename" read)
<lloda>depending on what's on the alist, you may need to do more work to serialize
<ennoausberlin>its just something like ((temp_dir . "./tmp") (log_dir . "./log") ... etc)
<ennoausberlin>I want to set some variables depending on the assoc in the config file
<rain1>im just a little worried about how you would detect syntax errors in the config file
<ennoausberlin>the entries in the config usually dont change. And its not critical if program stops with an error. I just do myy first steps with guile
<ennoausberlin>call-with-input-file looks good
<rain1>(catch #t (lambda () (call-with-input-file "filename" read)) (lambda (err . args) (display `(something went wrong ,err)))) ; this works
<rain1>but yeah just (call-with-input-file "filename" read) is fine for starting.. I was just wondering how to check for parse errors
<ennoausberlin>rain1: thank you. I am not familiar with common scheme patterns. Thats why I am asking. Your solution does it the right way, I think. Thanks to both of you
<rain1>I installed guile on debian (2.0) but i only have guile not guild
<rain1>i wonder if i need a newer guile to get guild
<ennoausberlin>I did some work in Smalltalk and Ruby. So far I like scheme. Its fun to gain some knowledge. Sometimes I miss the Smalltalk environment but emacs does well for now
<ennoausberlin>rain1: I have debian stretch running and guild is there.
<ennoausberlin>Maybe in guile-2.0-devel
<rain1>oh great thaht was it!
<rain1>thanks
<ym>Doesn't "meta/uninstalled-env bash" environment works for emacs-wip build?
<webshinra>well, I use load or primitive-load for that kind of use, I should not?
<ym>You want to say that I can load some scheme file from guile's REPL to build emacs-wip from scratch?
<paroneayea>I ought to just import ice-9 match whenever I start to define a guile module at this rate
<reepca>I don't suppose there's a "substring"-like function for vectors which shares memory with the original?
<bavier`>reepca: you can use array procedures like make-shared-array on vectors
<bavier`>reepca: e.g. (define v #(1 2 3 4)) (define v' (make-shared-array v list 2))
<reepca>wow my info browsing skills failed pretty hard there
<bavier`>:)
<reepca>is there a way to use match to get both an element and the list containing that element? For example, to get the second element of a list as well as the sub-list containing everything from the second element onward?
<bavier`>reepca: e.g. (match '(1 2 3 4) ((_ . (and sub (sec . _))) sub))
<bavier`>there might be a better way to express that
<daviid>reepca: in this case, you may also consider member :)
<sneek>daviid, you have 1 message.
<sneek>daviid, catonano says: guile-cv is awesome !
<daviid>sneek: later tell catonano thank you!
<sneek>Will do.
<janneke>i'm fighting with include-from-path
<janneke>it works as expected in 2.2, with 2.0 i see unexpected behaviour
<janneke>wondering what changed here