IRC channel logs

2017-07-18.log

back to list of logs

***x1n4u- is now known as x1n4u
***darthlukan_ is now known as darthlukan
***webshinra_ is now known as webshinra
<z0d>hi
<amz3>hi
<z0d>I'm looking at libguile and I want to call e.g. scm_version from C. how can I convert Scheme string into a C string?
<z0d>does that even make sense?
<lloda>z0d: see scm_from_string, scm_to_string in the manual
<lloda>rather scm_to_stringn
<lloda> https://www.gnu.org/software/guile/manual/html_node/Conversion-to_002ffrom-C.html#Conversion-to_002ffrom-C
<z0d>lloda: thank you, checking
<hugo>Could anyone help me with how I best create a guile record (srfi-9) from some C code?
<paroneayea>mwette: amz3: I recorded a note on this, luckily...
<paroneayea> http://sebsauvage.net/paste/?e35b78e7e09ac8e8#w+OvsS8PQRzitvMqxKcbLZ26J7XN561zCHoYSfhczyA=
<paroneayea>oops that's the wrong one
<paroneayea>hm, maybe the info I thought I had doesn't match
<paroneayea>nm!
<amz3>intresting blog and interesting post
<amz3> http://blog.cleancoder.com/uncle-bob/2017/07/11/PragmaticFunctionalProgramming.html
<OrangeShark>amz3: oh cool, an Uncle Bob blog post. It is interesting to see him move to functional programming and clojure.
<magnicida>any take on the easiest way to get guile 2.2 on travis ci?
<magnicida>i am guessing just getting the source and building it in the travis script (+ cache?)
<magnicida>but maybe there is some better way...?
<magnicida>i am really hoping for guix support on travis some day (they already have nix) but who knows...
<grr_>Hi. Anyone here?
<grr_>Wondering if there is anyone that can help regarding a question as I am new to guile
<daviid>grr_: go ahead and ask, don't ask to ask...
<grr_>Thought I was the only person here - which is why I didnt ask.
<grr_>:-)
<grr_>Anyway...
<amz3>I see a lot people..
<grr_>I am trying to get some more information of web scraping with guile
<grr_>As well as the manual, I came across this page on the same question. However, the example assumes you are using the repl, or that you can determine the variable name ($1, $2, $10, etc)
<grr_>This is the page that covers it im better detail. https://lists.gnu.org/archive/html/guile-user/2012-01/msg00049.html
<grr_>However, how do you scrape -- getting the results of the html string into your oen variable?
<grr_>(http-get (string->uri "http://www.gnu.org/software/guile/")) ;;; Returns 2 results ... into $1 and $2
<grr_>I hope my question makes sense?
<grr_>PS -- Yes... I see lots of people (now) -- haven't used IRC before.
<daviid>grr_: in the manual, look for Returning and Accepting Multiple Values
<grr_>Hi daviid -- l shall have a nose...
<grr_>Ahh... Okay... I see where we are going here.
<grr_>I will have a proper look at this section later tonight (Multiple values)
<grr_>Thank you. However, if anyone knows -- why return multiple values when scheme is good with lists?
<grr_>Something to do with multi processes? Anyway - will look at the manual. Thank you.
<paroneayea>hello, friends
<daviid>hi paroneayea
<OrangeShark>hi paroneayea
<paroneayea>hi daviid, OrangeShark :)
<amz3>hi paroneayea
<paroneayea>hi amz3
<amz3>fwiw there is cython implementation of psycopg binary protocol called asyncpg that is reported to be the fastest pgsql driver around
<amz3> https://github.com/MagicStack/asyncpg/
<faalentijn>hello paroneayea
<janneke>o/
<paroneayea>amz3: cool
<paroneayea>and hi faalentijn
<catonano>hi paroneayea
<paroneayea>heya catonano
<catonano>:-)
<cmaloney>hello
<faalentijn>Hello cmaloney!
<amz3`>Scheme For The Win http://spectrum.ieee.org/static/interactive-the-top-programming-languages-2017
<random-nick>hm, why is scheme marked as "Mobile"?
<ft>And Haskell as embedded.
<amz3`>THose means it's used in the mobile industry
<ArneBab_>Go stumbles over GC cost, too: https://www.youtube.com/watch?v=q1h2g84EX1M ← I say "too", because I saw 50% GC load quite a few times with Guile.