IRC channel logs

2017-06-22.log

back to list of logs

***ozzloy_ is now known as ozzloy
<ArneBab_>ijp: do you have an idea how much time it would take to port your project to WebAssembly?
<ArneBab_>(here’s the fundamental information for that: https://developer.mozilla.org/en-US/docs/WebAssembly/Understanding_the_text_format )
<ArneBab_>(not for doing this now, only for strategic consideration in case you hit upon something during development which could make such a port easier)
***eagleflo_ is now known as eagleflo
<ijp>ArneBab_: AFAICT it's a mixed bag
<OrangeShark>I am trying to fix the issues found when running make distcheck for guile-git, one of the issues is the tests have test data and it accesses them in the test using a relative path to the data. When running distcheck, the tests are run in a different directory instead of the source directory, so it can't find these files. What is the best way to get the path of the data for the tests?
<paroneayea>ArneBab_: ijp: I wouldn't think it would really be feasible until webassembly easily exports their GC, right? also I wonder if making such a pass should wait anyway until Guile 3.0 starts doing the native compilation thing.
<dsmith-work>Hey hey
<ijp>paroneayea: lack of gc would be a big problem
<ijp>weirdest bug in a while, I have code that is supposed to be transposing a matrix, but instead seems to be summing the columns
<ijp>but there aren't any calls to the add primitive...
<ijp>so I think it must be some bad js
<jlicht>Hello guile! I would like to create a small set of utility functions for parsing some version numbers using guile. Is there an simple example of how to structure such a ¨stand-alone¨ guile project properly?
<catonano_on_mobi>jlicht: guile-gcrypt
<jlicht>thank you catonano_on_mobi ;-)
<catonano_on_mobi>jlicht: also my guile-freexl. It s not released yet but you can find the repo in my last thread on the mail8ng list
<davexunit>jlicht: use the autotools, basically.
<davexunit>configure.ac, Makefile.am
<jlicht>I was afraid it was time to bite that specific bullet
<dsmith-work>ijp: Weird!
<OrangeShark>jlicht: if you have any specific questions or issues about the set up for a project, be sure to ask them here.
<jlicht>I will, thanks!
<ijp>dsmith-work: it turns out that somehow my 'list' procedure was replaced with '+'
<ijp>okay, matrix code compiles now
<dsmith-work>ijp: ooo!
<paroneayea>ijp: nice!
<paroneayea>ijp: btw I thought your mail to the mailing list this week was really good. Yay!
<paroneayea>I've been doing guile so much, and now I'm back on some python
<paroneayea>and I keep forgetting commas, forgetting that I need to explicitly return things...
<paroneayea>also, I'm using run-python more, which is nicer than it used to be
<paroneayea>but
<paroneayea>I really miss how you can evaluate things in geiser and it correctly evalutes it inside the right module
<paroneayea>an amazing feature
<avoine>paroneayea: do you have a guile version of activipy?
<paroneayea>avoine: sure do
<avoine>I'm starting to exploring that
<paroneayea>it's called Pubstrate
<paroneayea>(pubstrate asobj)
<paroneayea>Pubstrate also contains, as it turns out, a full fledged activitypub implementation server, a partial client, and a work in progress AP test suite
<avoine>ok I found it on gitlab
<paroneayea>too much stuff :)
<paroneayea>needs to be split out
<paroneayea>not to mention a jsonld expander :)
<paroneayea>need to get that compactor done...
<paroneayea>avoine: I'd love to hear what you think of it though! take a look at tests/test-asobj.scm to see how things can be used I guess? or look at how it's used in the pubstrate/webapp/ code
<paroneayea>avoine: the pubstrate/webapp/templates.scm makes great use of its generic methods support
<avoine>ok, I need to read the spec first to understand all that :P
<paroneayea>avoine: haha, it's a lot to take in.. but luckily, there's a HACKING.org
<paroneayea>you could just focus on using asobj.scm though
<avoine>ok
<paroneayea>avoine: ping me if you have any questions :)
<avoine>paroneayea: I'll
<paroneayea>ACTION wates with anticipation for the rest of the sentence, then realizes that "I'll" could be a complete sentence, as "I will" :O
<paroneayea>*waits
<avoine>hehe indeed I mean "I will"
<androclus>(define myvar "hello")
<androclus>myvar
<amz3>"hello"
<OrangeShark>hey amz3
<OrangeShark>amz3: I was working the other day to get guile-git to pass make distcheck and my current issue is the tests are executed in a different directory, not the source directory. So the macro with-repository doesn't find the repository
<amz3>oh
<OrangeShark>any idea how to solve that?
<amz3>oh
<amz3>option 1) ask the test runner to copy the folder that contains the repositories with the tests
<amz3>well there is no option 2), I figured it's a bad idea
<OrangeShark>the only other idea would be to make it config to have the absolute path to the source directory
<amz3>yes that's the other idea
<amz3>somewhat
<amz3>yes
<OrangeShark>not sure which is the preferred way
<amz3>btw OrangeShark, how did you learn autotools?
<OrangeShark>amz3: mostly looking at other projects and reading a bit of the manuals. I don't think I could handle the more complex ones...
<amz3>I am still at the stage of 'wow so many tried to replace autotools and never succeed! wtf!'
<OrangeShark>yeah, seems like a challenge to reach as many features to what autotools covers.
***zv_ is now known as zv
<ijp>ACTION drowns in stubs